SXWN9008: saxon:call-template is not recognized as a Saxon i

Here should go questions about transforming XML with XSLT and FOP.
marlougfin
Posts: 3

SXWN9008: saxon:call-template is not recognized as a Saxon i

Wed Jul 08, 2015 2:22 pm

I am getting error when transforming the xml using the xslt in Oxygen XML Developer 17.0. I am using the transformer Saxon-PE 9.6.0.5.

Xslt Header:

Code: Select all

<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:fn="http://www.w3.org/2005/xpath-functions"
    xmlns:uuid="java:java.util.UUID" exclude-result-prefixes="xsl xs fn uuid saxon"
    extension-element-prefixes="saxon">
    <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>


Code that getting error:
<saxon:call-template name="{$templateName}">


This is to call template dynamically...


When I am using the previous version of the Oxygen Xml Developer, I don't encounter this kind of issue. This happened when I update to the latest version.
marlougfin
Posts: 3

SXWN9008: saxon:call-template is not recognized as a Saxon i

Wed Jul 08, 2015 2:35 pm

I am getting transformation error using Oxygen Xml Developer 17.0. I am using transformer Saxon-PE 9.6.0.5.

XST Header:

Code: Select all

<xsl:stylesheet version="2.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
    xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:fn="http://www.w3.org/2005/xpath-functions"
    xmlns:saxon="http://saxon.sf.net/" xmlns:uuid="java:java.util.UUID"
    exclude-result-prefixes="xsl xs fn uuid saxon"
    extension-element-prefixes="saxon">
    <xsl:output method="xml" version="1.0" encoding="UTF-8" indent="yes"/>


Code Error:
<saxon:call-template name="{$templateName}">


I am not getting this error in the previous version.

Code: Select all

Error Details:
Engine name: Saxon-PE 9.6.0.5
Severity: warning
Description: SXWN9008: saxon:call-template is not recognized as a Saxon instruction
Start location: 69:85
URL: http://www.saxonica.com/html/documentation/javadoc/net/sf/saxon/trans/SaxonErrorCode.html#SXWN9008
adrian
Posts: 2337

Re: SXWN9008: saxon:call-template is not recognized as a Sax

Wed Jul 08, 2015 3:29 pm

Hello,

I can confirm that saxon:call-template does not work with Saxon-PE/EE 9.6.0.5 (bundled with Oxygen v17.0). I see the same problem when running Saxon 9.6 in the command line completely independent from Oxygen. We will report this problem to Saxonica.

I do not have a workaround for this problem in v17.0. If you need to run this stylesheet please use v16.1 (Saxon 9.5.1.7). You can have both 16.1 and 17.0 installed side by side in separate folders.

Regards,
Adrian
Adrian Buza
<oXygen/> XML Editor, Schema Editor and XSLT Editor/Debugger
http://www.oxygenxml.com
Radu
Posts: 5224

Re: SXWN9008: saxon:call-template is not recognized as a Sax

Wed Jul 08, 2015 4:26 pm

Hi,

It seems that Saxon 9.6 officially removed support for saxon:call-template:

http://www.saxonica.com/html/documentation/xsl-elements/call-template.html

So you could try to write on the Saxon users list and ask for a possible alternative.

Regards,
Radu
Radu Coravu
<oXygen/> XML Editor
http://www.oxygenxml.com
marlougfin
Posts: 3

Re: SXWN9008: saxon:call-template is not recognized as a Sax

Thu Jul 09, 2015 4:59 am

Thanks guys for the confirmation and reply.

What I did is install Oxygen Xml Developer 16.1 to run my xslt that has saxon:call-template.

For now I will still use the lower version since that the main application I am using still using lower version of the saxon.

Return to “XSLT and FOP”

Who is online

Users browsing this forum: No registered users and 2 guests