Search found 74 matches

by whyme
Fri Oct 23, 2015 12:28 am
Forum: Feature Request
Topic: Batch schema conversions
Replies: 2
Views: 1785

Batch schema conversions

It would be nice in the Generate/Convert Schema dialogue box to choose a collection of schema files to convert to another former en bloc, not just one by one.
by whyme
Thu Oct 22, 2015 10:49 pm
Forum: Common Problems
Topic: oXygen 17.1, Schematron and normalize-unicode
Replies: 3
Views: 1374

oXygen 17.1, Schematron and normalize-unicode

I have a suite of files that were valid in oXygen 17.0 but now in 17.1 return a fatal error: Internal error evaluating template at line 181 in module... I've isolated the cause to the use of fn:normalize-unicode() in the schematron files when applied to non-ASCII characters (seems to work fine with ...
by whyme
Mon Sep 21, 2015 8:12 pm
Forum: Common Problems
Topic: Document Type Association rule on namespace for tag URN
Replies: 4
Views: 1730

Re: Document Type Association rule on namespace for tag URN

Sure, here's a snippet with the root element: <TAN-T xmlns="tag:textalign.net,2015:ns" ... >...</TAN-T> My workaround right now for association rules is this: tag:textalign.net*2015:ns, which is likely to be sufficient. The comma is mandated in tag URNs, which are valid namespaces, so perhaps in thi...
by whyme
Fri Sep 18, 2015 7:39 pm
Forum: Common Problems
Topic: Binding and unbinding filename autocompletion
Replies: 1
Views: 878

Binding and unbinding filename autocompletion

I am working with an XML vocabulary that defines @src such that it is not a URI. Is there any way to turn off the autocompletion feature that offers a list of local filenames one might want to pick? Also, is there a way to re-bind that filename autocomplete feature with another attribute or element ...
by whyme
Fri Sep 18, 2015 6:40 pm
Forum: Common Problems
Topic: Document Type Association rule on namespace for tag URN
Replies: 4
Views: 1730

Document Type Association rule on namespace for tag URN

Hi, I'm setting up a document type association bound to a namespace that is defined with a tag URN. The oXygen association rules aren't binding to documents that have the tag URN as a namespace. I've determined through trial and error that the comma (required by tag URNs) is preventing the namespace...
by whyme
Wed Sep 09, 2015 9:06 pm
Forum: Common Problems
Topic: Autocomplete of xsl:merge
Replies: 2
Views: 1027

Autocomplete of xsl:merge

A few bugs: When <xsl:merge> is autocompleted an invalid <xsl:merge-input> is inserted as an intermediary between <xsl:merge> and <xsl:merge-key>. When adding attributes to <xsl:merge-source> @for-each is offered as a false option. It seems that it should be replaced by @for-each-item and @for-each-...
by whyme
Tue Aug 18, 2015 10:35 pm
Forum: Common Problems
Topic: Saxon evaluating functions and variables unnecessarily
Replies: 1
Views: 1057

Saxon evaluating functions and variables unnecessarily

When I use Saxon 9.6 to run a transformation, and it comes across a statement such as this... <value-of select ="if ($a) then $a else $b"/> ...it is evaluating $b whether or not $a is true. For a full discussion, along with result discrepancies, see here: http://stackoverflow.com/questions/32077875/...
by whyme
Fri Aug 14, 2015 9:43 pm
Forum: Feature Request
Topic: Validation time
Replies: 2
Views: 1908

Validation time

It would be nice if, upon validating a single document (ctrl+shift+v) we got a note included in the bottom-most status bar indicating how much time it took to validate the file. Or if that feature already exists, the documentation is unclear on how to access it. That would be a big help for those of...
by whyme
Wed Jun 10, 2015 11:38 pm
Forum: Common Problems
Topic: Schematron invalidation message on included patterns
Replies: 1
Views: 1365

Schematron invalidation message on included patterns

I have a simple master schematron file (root <sch:schema>) + included schematron file (root <sch:pattern>). The first validates fine but the second, even when empty and otherwise valid, returns this error message: Scenario name: Schematron Document type: Schematron Engine name: ISO Schematron Severi...
by whyme
Wed Jun 03, 2015 4:01 pm
Forum: Common Problems
Topic: Schematron XPath format and indent inconsistencies (apparent
Replies: 4
Views: 2409

Re: Schematron XPath format and indent inconsistencies (appa

Thanks, Florin. To that could you add a third bug, that included Schematron files (which always have a rootmost element that is not sch:schema) do not exhibit the same behavior during format/indent as master Schematron files do? Thanks so much.
by whyme
Wed Jun 03, 2015 12:25 am
Forum: Common Problems
Topic: Schematron XPath format and indent inconsistencies (apparent
Replies: 4
Views: 2409

Schematron XPath format and indent inconsistencies (apparent

I am working with a suite of Schematron files that have dependencies (by way of sch:include). When I format and indent the master Schematron files (the including files, not the included), complex XPath expressions in sch:let/@value and sch:assert/@test (but not, strangely, in sch:report/@test) retur...
by whyme
Wed May 13, 2015 10:01 pm
Forum: Common Problems
Topic: Schematron quick fixes in Word archive
Replies: 1
Views: 1108

Schematron quick fixes in Word archive

I have applied a schematron file with quick fixes to an XML document within a Word file archive and validated the file. The tooltip (red lightbulb occupying the line number) works fine for any error I pick, but then it disappears after that first error is corrected. It does not appear again until th...
by whyme
Mon Mar 09, 2015 8:37 pm
Forum: Feature Request
Topic: link / a href option for xhtml toolbar / menu
Replies: 2
Views: 2597

link / a href option for xhtml toolbar / menu

In the standard oXygen Author menu for docbook, a variety of linking mechanisms are provided in the default toolbar and menu, and these are convenient. But I don't think a corresponding function exists in the Author mode for xhtml. Going into the custom settings for the xhtml menus and toolbars, I f...
by whyme
Fri Mar 08, 2013 9:07 am
Forum: Other Issues
Topic: Validating HTML5 and RDFa lite
Replies: 1
Views: 1265

Validating HTML5 and RDFa lite

I am unable to get oXygen to validate the recommended use of RDFa + HTML5: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE html> <html xmlns="http://www.w3.org/1999/xhtml"> <head> <title>Example Document</title> </head> <body vocab="http://schema.org/"> <p typeof="Blog"> Welcome to my <a property="...