Search found 64 matches

by jokester01au
Fri Feb 02, 2007 5:21 am
Forum: Common Problems
Topic: XSLT debugger in eclipse repeatedly flashes the toolbar
Replies: 8
Views: 6440

I have come to the conclusion that this is most likely caused by the fact that the oxygen toolbar has several more icons when an xml document is selected than when an xslt document is selected. This means that if there is just enough room for the toolbar when you're in xslt, then when an xml documen...
by jokester01au
Tue Jan 09, 2007 2:39 am
Forum: Common Problems
Topic: Xwatch doesnt update nodes/Values set correctly
Replies: 11
Views: 7521

Re: Xwatch doesnt update nodes/Values set correctly

We think that all sequences should be displayed the same even if they contain a single value. If some sequences are displayed in a different way the user is confused about the data type of that value. I can see the logic behind this. However it substantially increases the complexity of the UI. What...
by jokester01au
Fri Jan 05, 2007 3:15 am
Forum: Feature Request
Topic: Better reporting of missing named templates in XSLT
Replies: 2
Views: 4534

Better reporting of missing named templates in XSLT

You are correct about the wider context of this problem. My suggestion would be to identify where there are hints that already exist within oxygen as to the intended context of the currently edited file. For example, in the XSLT debugging context, the run mechanism already attempts to compile the st...
by jokester01au
Fri Jan 05, 2007 3:04 am
Forum: Common Problems
Topic: Xwatch doesnt update nodes/Values set correctly
Replies: 11
Views: 7521

Xwatch doesnt update nodes/Values set correctly

The expressions 1 and 't' are presented as node sets in the XWatch view only if you run the transformation with Saxon 8. This happens because in XSLT 2.0 they are evaluated as sequences. I understand that in XPath 2.0/XSLT 2.0 everything is a sequence. However, given that this is the case, it would...
by jokester01au
Thu Jan 04, 2007 1:14 am
Forum: Common Problems
Topic: Xwatch doesnt update nodes/Values set correctly
Replies: 11
Views: 7521

Xwatch doesnt update nodes/Values set correctly

Fair enough that you don't support milestone releases.

Both of these issues also occur using 3.2.1.
by jokester01au
Thu Jan 04, 2007 1:12 am
Forum: Common Problems
Topic: XSLT Debugger: Can't expand nodes in "Nodes/Values Set&
Replies: 2
Views: 3197

XSLT Debugger: Can't expand nodes in "Nodes

Fair enough that you don't support milestone releases.

This problem doesn't seem to occur on 3.2.1. If I manage to reproduce it there I'll let you know.
by jokester01au
Wed Jan 03, 2007 8:38 am
Forum: Common Problems
Topic: Xwatch doesnt update nodes/Values set correctly
Replies: 11
Views: 7521

Xwatch doesnt update nodes/Values set correctly

Hi, when you type an xwatch expression and press enter, the "nodes/values set" pane does not update. To workaround this, it is possible to force the "nodes/values set" pane to update by selecting a different xwatch expression and then selecting the new one once more, however this is obviously not de...
by jokester01au
Wed Jan 03, 2007 5:16 am
Forum: Feature Request
Topic: Better reporting of missing named templates in XSLT
Replies: 2
Views: 4534

Better reporting of missing named templates in XSLT

At the moment, if stylesheet A imports stylesheet B, which calls several named templates that exist in stylesheet A, then oxygen will report errors at each of the call-template instructions in B. However, stylesheet A may be run without problems, because once it imports B, all of the call-template i...
by jokester01au
Wed Jan 03, 2007 4:41 am
Forum: Common Problems
Topic: XSLT Debugger: Can't expand nodes in "Nodes/Values Set&
Replies: 2
Views: 3197

XSLT Debugger: Can't expand nodes in "Nodes/Values Set&

When debugging XSLT using XWatch, I am getting a problem where I can't expand nodes in the Nodes/Values Set pane. I have a variable "$eltList" selected in XWatch, and the Nodes/Values set pane displays a document/fragment and its immediate children. Those children all have + symbols, but clicking on...
by jokester01au
Thu Dec 21, 2006 2:06 am
Forum: Feature Request
Topic: Faster and/or more graceful handling of large XML files
Replies: 9
Views: 9838

Re: Faster and/or more graceful handling of large XML files

Unfortunately the Eclipse framework does not allow plugins to customize the file open operation. The framework calls the plugin after the content of the file is loaded from disk in memory. However, loading very large files in a basic text editor within eclipse is not a problem. It is only when load...
by jokester01au
Wed Dec 20, 2006 9:32 am
Forum: Feature Request
Topic: oxygen syntax colouring & outlining in eclipse compare v
Replies: 3
Views: 4700

oxygen syntax colouring & outlining in eclipse compare v

Comparing two xml files within eclipse currently operates in text only mode. This is better than nothing but it would be great if oxygen syntax colouring and outlining worked within compare view. It would be particularly good for the outline pane to display only the different sections - as is the ca...
by jokester01au
Wed Dec 20, 2006 9:30 am
Forum: Feature Request
Topic: Faster and/or more graceful handling of large XML files
Replies: 9
Views: 9838

Faster and/or more graceful handling of large XML files

Even worse, if you somehow end up in a situation where the workbench state contains an open xml file that is too large for oxygen to handle, eclipse will hang on loading. The only way I've found to get out of this situation is to remove the oxygen plugin, load eclipse and close the file that is too ...
by jokester01au
Wed Dec 20, 2006 9:28 am
Forum: Feature Request
Topic: Faster and/or more graceful handling of large XML files
Replies: 9
Views: 9838

Faster and/or more graceful handling of large XML files

Currently, when attempting to open an XML file that is more than a few megabytes, oxygen effectively hangs. This can result in loss of work and at the very least is rather annoying. It would be good if oxygen could provide a progress bar and cancel button when attempting operations such as opening o...
by jokester01au
Thu Dec 14, 2006 7:16 am
Forum: Common Problems
Topic: XSLT debugger doesn't display numerical variable values
Replies: 5
Views: 4282

Variables displaying N/A

Hi, Thanks for the explanation. From a users perspective I feel it would be better for debug mode to always force evaluation of in-scope variables and always display their value in the variables pane. If one is stepping through the code then the extra time required to evaluate the variables is very ...
by jokester01au
Thu Dec 14, 2006 5:45 am
Forum: Other Issues
Topic: Inspecting keys while debugging an XSL transform?
Replies: 8
Views: 9110

View keys in XSLT debugger

Hi, In fact, now that I come to try putting a key function into XWatch, it is telling me "The key() function is available only in XPath expressions within an XSLT stylesheet", so it seems that it is no longer possible to use XWatch for probing keys. I have tried this both in Eclipse and in the stand...
by jokester01au
Thu Dec 14, 2006 1:20 am
Forum: Feature Request
Topic: XSLT debugger to step into saxon:transform functions
Replies: 3
Views: 5364

XSLT debugger to step into saxon:transform functions

Hi, I asked Michael Kay about this. I have reproduced his response below. Regards, Joe. There is in fact such a mechanism, and I believe Stylus Studio uses it. Saxon calls extension functions using a class called ExtensionFunctionCall, which you can subclass by tailoring the ExtensionFunctionFactory...
by jokester01au
Wed Dec 13, 2006 6:40 am
Forum: Other Issues
Topic: Inspecting keys while debugging an XSL transform?
Replies: 8
Views: 9110

View Key sets in variables pane

Hi,

Its good that we can use XWatch to get a particular key value, but it would be even better if declared keys would appear in the variables pane.

Regards,
Joe.
by jokester01au
Wed Dec 13, 2006 5:47 am
Forum: Common Problems
Topic: XSLT debugger doesn't display numerical variable values
Replies: 5
Views: 4282

Incorrect display of variables in XSLT debug

Hi, I can give a better example of this problem. With the stylesheet attached below, when paused at the value-of tag, the variables pane displays $meBitCount with a "?" in the type column and nothing in the value column. Selecting the variable does nothing. However, if I type $meBitCount into the xw...
by jokester01au
Wed Dec 13, 2006 5:42 am
Forum: Common Problems
Topic: Eclipse XSLT debugger breakpoints don't break
Replies: 8
Views: 6406

Eclipse XSLT debugger breakpoints don't break

This problem also occurs in the standalone version (8.0). The complete file I am testing is below. If I set a breakpoint on any of the variable tags, the debugger doesn't break. Only if I set a breakpoint on value-of or template does the debugger break. I am running Windows Vista and JDK 1.6.0RC. Re...
by jokester01au
Wed Dec 13, 2006 5:38 am
Forum: Common Problems
Topic: XSLT debugger in eclipse repeatedly flashes the toolbar
Replies: 8
Views: 6440

XSLT debugger in eclipse repeatedly flashes the toolbar

Hi, Of course I can't reproduce the problem now. :( I am running several different configurations: Windows XP SP2 JDK 1.5.0_07 Eclipse 3.3M3 / 3.2.1 Oxygen 8.0 and Windows Vista Business JDK 1.6.0RC Eclipse 3.3M3 Oxygen 8.0 As I said, I haven't been able to reproduce the bug today. However, I'm reas...
by jokester01au
Sun Dec 10, 2006 5:26 am
Forum: Common Problems
Topic: XSLT debugger highlights incorrect line
Replies: 2
Views: 2920

XSLT debugger highlights incorrect line

Note: this is a problem only in the eclipse plugin, when debugging in the standalone version, the correct line is highlighted.

Joe.
by jokester01au
Sun Dec 10, 2006 5:24 am
Forum: Common Problems
Topic: XSLT debugger doesn't display numerical variable values
Replies: 5
Views: 4282

XSLT debugger doesn't display numerical variable values

Another bug in the XSLT debugger. Numerical variables don't seem to display correctly. For example, a new stylesheet with a template <xsl:template match="/"> <xsl:variable name="la"> 56 </xsl:variable> <xsl:apply-templates/> </xsl:template> will display "N/A" in the value column of the variables vie...
by jokester01au
Sun Dec 10, 2006 5:13 am
Forum: Common Problems
Topic: Eclipse XSLT debugger breakpoints don't break
Replies: 8
Views: 6406

Eclipse XSLT debugger breakpoints don't break

Hi, Another bug in the eclipse XSLT debugger. Breakpoints on certain elements fail to break. For example, if a new stylesheet is created, with a template <xsl:template match="/"> <xsl:variable name="la"> 56 </xsl:variable> </xsl:template> Then a breakpoint on the template start tag will work correct...
by jokester01au
Sun Dec 10, 2006 4:29 am
Forum: Feature Request
Topic: XSLT debugger to step into saxon:transform functions
Replies: 3
Views: 5364

XSLT debugger to step into saxon:transform functions

Hi, A handy feature of the saxon XSLT engine is the ability to split a transform up into a chain of smaller transforms using the saxon:transform function. It would be great if the oxygen xslt debugger was able to step into transforms executed in this manner. While it is possible to manually generate...
by jokester01au
Sun Dec 10, 2006 4:24 am
Forum: Common Problems
Topic: XSLT debugger in eclipse repeatedly flashes the toolbar
Replies: 8
Views: 6440

XSLT debugger in eclipse repeatedly flashes the toolbar

Hi, Another relatively minor but very annoying bug in the eclipse XSLT debugger for oxygen 8. Every time one of the buttons in the XSLT Debgger panel is pressed, the toolbar disappears then reappears. This has the effect of making all of the panels in the window jump down a line and then straight ba...
by jokester01au
Sun Dec 10, 2006 4:20 am
Forum: Common Problems
Topic: XSLT debugger highlights incorrect line
Replies: 2
Views: 2920

XSLT debugger highlights incorrect line

Hi, There is a relatively minor but rather annoying bug in the XSLT debugger within eclipse for Oxygen 8.0. When stepping, the XSLT panel highlights the line immediately BEFORE the line actually being processed. The status message in the XSLT Debugger view (where the run buttons are) reports the cor...
by jokester01au
Fri Mar 10, 2006 2:17 am
Forum: Feature Request
Topic: Synchronise XML Schema Logical Model view with schema text
Replies: 1
Views: 4107

Synchronise XML Schema Logical Model view with schema text

Hi,

It'd be great if the logical model view of the schema editor could synchronise with the schema text, in the same way that the full model does.

It would also be great to be able to toggle this on and off in both views.

I use oxygen within Eclipse 3.2.

Regards,
Joe.
by jokester01au
Tue Sep 13, 2005 1:48 am
Forum: Common Problems
Topic: Exception with XPath in Oxygen 6.1.1 and Eclipse 3.1
Replies: 11
Views: 6466

Oxygen in Eclipse XPath Bug

Hi Sorin, The target file for the XPath query is not included in the current workspace Yes, it is. As I explained in previous posts, this bug occurs when trying to run XPath queries on XML documents INSIDE the workspace. I believe it must have something to do with the workspace metadata, since chang...
by jokester01au
Mon Sep 12, 2005 8:33 am
Forum: Common Problems
Topic: Exception with XPath in Oxygen 6.1.1 and Eclipse 3.1
Replies: 11
Views: 6466

Continued problem with XPath in Oxygen 6.1.1 and Eclipse 3.1

Hi George, Further to my previous post, the bug temporarily disappeared when I moved my workspace to C:\MyWorkspace However, it has now reappeared within this workspace. Can you suggest what I can do to identify what is raising this bug? If it helps to diagnose the issue, I can send you my workspace...
by jokester01au
Tue Aug 16, 2005 2:32 am
Forum: Common Problems
Topic: Exception with XPath in Oxygen 6.1.1 and Eclipse 3.1
Replies: 11
Views: 6466

Attempting to isolate problem

Hi George, I have isolated this problem to some degree. Previously, my various workspaces have resided within the directory c:\JavaProjects It appears that all of the workspaces within this directory display the same XPath problem. I have now tried numerous workspaces outside this directory and all ...