Search found 140 matches

by martindholmes
Mon Jan 31, 2011 8:43 pm
Forum: Common Problems
Topic: Memory problems with 12.1
Replies: 8
Views: 2302

Memory problems with 12.1

Since upgrading to 12.1, I've had numerous crashes with out-of-memory errors, and lots of freezes as well, doing XSLT transformations that worked fine under the last version. I keep increasing the memory allocation in the oxygen.vmoptions file, but it doesn't seem to help. Have there been any change...
by martindholmes
Tue Oct 05, 2010 5:53 pm
Forum: Common Problems
Topic: Build number updated but date unchanged on download page
Replies: 3
Views: 1390

Re: Build number updated but date unchanged on download page

That's great -- much easier to understand. Thanks!

Martin
by martindholmes
Thu Sep 30, 2010 8:10 pm
Forum: Common Problems
Topic: Build number updated but date unchanged on download page
Replies: 3
Views: 1390

Build number updated but date unchanged on download page

This morning oXygen told me there was an update to 12.0, so I went to the download page. It shows the release date as September 14 (which is the same as the original version 12.0 I downloaded on that day). However, checking the build number shows 2010092112, as opposed to 2010091411, which is my ver...
by martindholmes
Mon Jun 21, 2010 7:16 pm
Forum: Common Problems
Topic: Content completion change in version 11
Replies: 1
Views: 834

Content completion change in version 11

I'm noticing that the content completion/suggestion system is not working as helpfully as it used to in previous versions. I'm editing a document, and I go to enter an attribute value which is defined as one or more URIs, like this: <ref target="#aida_1994">Aida (1994)</ref> In previous versions, wh...
by martindholmes
Thu Jun 03, 2010 6:55 pm
Forum: Common Problems
Topic: Problems with 11.2 -- reverted to 10.3
Replies: 3
Views: 1443

Re: Problems with 11.2 -- reverted to 10.3

Hi there, I have tried running 11.2 with both the OpenJDK (which is my default) and the Sun JRE which is in the oXygen directory. I'd ended up with the OpenJDK because it was causing fewer lockups, but I've now switched back to the bundled JRE. The - sun.boot.library.path points to <oxygen-installat...
by martindholmes
Fri May 28, 2010 5:52 pm
Forum: Common Problems
Topic: Problems with 11.2 -- reverted to 10.3
Replies: 3
Views: 1443

Problems with 11.2 -- reverted to 10.3

Using oXygen on Ubuntu Lucid 64-bit with a quad-core processor and 8GB of RAM. I've been trying to get used to oXygen 11.2 for a few weeks now, and I've finally given up and reverted to 10.3. These are the problems I'm having: The application locks up after a couple of hours of use, and at the same ...
by martindholmes
Fri Sep 04, 2009 7:10 pm
Forum: Common Problems
Topic: Code templates delete selected text
Replies: 1
Views: 817

Code templates delete selected text

I'd really like to use code templates for some of my most common markup tasks, so that I can add (say) a tag with several attributes in one operation. However, if I apply a code template with some text selected, instead of wrapping the template around the selected text, it deletes the selection. I'd...
by martindholmes
Wed Aug 26, 2009 7:21 pm
Forum: Common Problems
Topic: Odd behaviour with "Open in System Application"
Replies: 3
Views: 1061

Odd behaviour with "Open in System Application"

Using oXygen 10.3 on 64-bit Ubuntu Jaunty (9.04): When I choose to "Open file in system application" from the right-click menu in the project browser, I get some rather odd behaviour with a range of different file types, including .doc, .pdf and .odt. Instead of just launching the program configured...
by martindholmes
Thu May 15, 2008 6:34 pm
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3367

Re: Saxon 9B broken in oXygen 9.2?

That did it! I installed to a new folder, then deleted the old folder in Program Files. I think this might indicate that the uninstaller which runs at the beginning of the install process isn't quite cleaning up everything, though, at least if you install to the same location as the last version. I ...
by martindholmes
Thu May 15, 2008 5:46 pm
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3367

Re: Saxon 9B broken in oXygen 9.2?

I installed 9.2 with the regular Windows installer, on XP (SP3), and it apparently went through the process of uninstalling version 9.1. It did install to the same folder, though (Program Files\oxygen). I have other versions of Saxon on my system, from other tools, but I would expect oXygen to use i...
by martindholmes
Thu May 15, 2008 1:50 am
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3367

Saxon 9B broken in oXygen 9.2?

Since installing oXygen 9.2, I'm having trouble with an XSLT 2.0 stylesheet that was working fine under 9.1. When I try to run a transformation with the stylesheet, I get only the vague error: Saxon 9B null When I try to validate the XSLT file, I get this error: Description: net.sf.saxon.style.XSLVa...
by martindholmes
Thu Dec 13, 2007 2:18 am
Forum: Other Issues
Topic: XInclude and content completion
Replies: 1
Views: 2423

XInclude and content completion

Hi there, We're contemplating a large TEI project which would involve editors working on thousands of small files, each of which would contain ref elements linking to the xml:id attribute of other tags. Most of these other tags will be in a separate document, like this: In doc 1: <list> <item xml:id...
by martindholmes
Wed Jul 04, 2007 1:49 am
Forum: Other Issues
Topic: Xinclude elements from the same document
Replies: 1
Views: 3532

Xinclude elements from the same document

I'm trying to get around the huge amount of duplication that typically happens in TEI documents, where titles, authors and similar info tend to appear in two or three different places. I'm doing this by using XInclude to include data from one part of the document in another part of the same document...
by martindholmes
Fri Mar 24, 2006 8:10 pm
Forum: Common Problems
Topic: Getting rid of pretty-print
Replies: 1
Views: 2343

Getting rid of pretty-print

I have a stack of documents that have been damaged by the use of pretty-print -- by which I mean that someone editing the files, who didn't really understand pretty-print and how to configure it, has pretty-printed thousands of instances of mixed content where spaces and returns shouldn't actually e...
by martindholmes
Thu Jan 26, 2006 9:38 pm
Forum: XSLT and FOP
Topic: XSLT transformation for schema documents
Replies: 1
Views: 2975

XSLT transformation for schema documents

Hi there, I have some TEI P5 documents that start like this: <TEI xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.tei-c.org/ns/1.0 imt_p5.xsd" xmlns:svg="http://www.w3.org/2000/svg" xmlns="http://www.tei-c.org/ns/1.0" version="5.0"> When I run an XSLT transformat...
by martindholmes
Mon Aug 15, 2005 8:29 pm
Forum: Common Problems
Topic: Problems updating from 6.0 to 6.1.1
Replies: 1
Views: 1884

Solved by deleting lib folder

I ended up deleting the entire lib folder from the program folder and running the installer again using "Repair".

I think there's something about the installer that prevents it from replacing existing jar files.

Cheers,
Martin
by martindholmes
Mon Aug 15, 2005 8:10 pm
Forum: Common Problems
Topic: Problems updating from 6.0 to 6.1.1
Replies: 1
Views: 1884

Problems updating from 6.0 to 6.1.1

I keep running the installer for the latest version, but it's failing to update my old installation; when I run the app and click on Help / About, I still see 6.0, build 2005051805. Has anyone else seen this behaviour?

Cheers,
Martin
by martindholmes
Thu Apr 21, 2005 6:11 pm
Forum: Common Problems
Topic: Complete freeze editing XSLT
Replies: 5
Views: 3983

Hi there, This is the stylesheet (hope it comes through OK on the forum): <?xml version="1.0" encoding="utf-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0" xmlns:fo="http://www.w3.org/1999/XSL/Format"> <!-- Bibliography elements, going to MLA style. This is compli...
by martindholmes
Wed Apr 20, 2005 6:47 pm
Forum: Common Problems
Topic: Complete freeze editing XSLT
Replies: 5
Views: 3983

Some additional info: -I'm running the latest update of Java 1.5: J2SE Version 1.5.0 (build 1.5.0_02-b09). -I'm running on dual monitors. oXygen is on the left monitor; if I move it to the right (which I'd prefer to do), the popup menus etc. continue to appear on the left monitor, but I guess that's...
by martindholmes
Wed Apr 20, 2005 6:24 pm
Forum: Common Problems
Topic: Complete freeze editing XSLT
Replies: 5
Views: 3983

Complete freeze editing XSLT

Hi there, I've had repeated instances of oXygen freezing when I'm editing an XSLT file; I have to kill the app and restart it. The file is pretty small (only 282 lines), and the freeze always seems to happen when I'm typing a new tag, as I type the = sign after an attribute, or the following quote. ...