Search found 151 matches

by martindholmes
Thu Feb 09, 2012 8:34 pm
Forum: Common Problems
Topic: Turn off behaviour in project window?
Replies: 1
Views: 853

Turn off behaviour in project window?

One or two versions ago, oXygen introduced a new feature whereby the file which is open for editing is always selected in the project window. I thought this was a good idea when I first experienced it, but I'm finding it quite annoying now; most problematic is what happens when I close a file, becau...
by martindholmes
Wed Aug 31, 2011 6:23 pm
Forum: Other Issues
Topic: Version 13: BIDI triggered for document with no BIDI characters
Replies: 2
Views: 1438

Version 13: BIDI triggered for document with no BIDI characters

Since upgrading to version 13, I'm seeing the BIDI warning triggered for XML files which don't contain any BIDI characters. The document properties show BIDI as "true". I seem to remember this problem in an earlier version, but I can't remember how it was solved -- perhaps by turning off BIDI comple...
by martindholmes
Wed May 11, 2011 7:15 pm
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Re: Problem running stylesheetDocumentation.sh

It's the Sun Java: hcmc@Jenkins2:~$ java -version java version "1.6.0_25" Java(TM) SE Runtime Environment (build 1.6.0_25-b06) Java HotSpot(TM) 64-Bit Server VM (build 20.0-b11, mixed mode) But I'd forgotten all about the licence. Since it's headless, I've never started oXygen up so it's never asked...
by martindholmes
Wed May 11, 2011 1:39 am
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Re: Problem running stylesheetDocumentation.sh

I just moved the JRE elsewhere, so now it's presumably using the installed Sun Java. But I'm getting another error now: using oXygen XML Editor stylesheet documentation generator. Exception in thread "main" java.lang.ExceptionInInitializerError at ro.sync.xsl.documentation.XSLStylesheetDocumentation...
by martindholmes
Tue May 10, 2011 7:46 pm
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Re: Problem running stylesheetDocumentation.sh

It came courtesy of the TEI Debian package repo here: http://tei.oucs.ox.ac.uk/teideb/binary I was just following some instructions to get the TEI packages installed, and never realized there were no 64-bit versions. The 32-bit ones seemed to install just fine using apt-get, but I guess they'll neve...
by martindholmes
Tue May 10, 2011 2:34 am
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Re: Problem running stylesheetDocumentation.sh

Could this sort of error result from running a 32-bit oXygen package (with a 32-bit JRE) on 64-bit Ubuntu?

Cheers,
Martin
by martindholmes
Tue May 10, 2011 2:03 am
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Re: Problem running stylesheetDocumentation.sh

Yes, I should have mentioned that I've tried that. I get the same result: sh /usr/share/oxygen/stylesheetDocumentation.sh Script file for generating XSL Stylesheet documentation using oXygen XML Editor stylesheet documentation generator. /usr/share/oxygen/stylesheetDocumentation.sh: 41: /usr/share/o...
by martindholmes
Mon May 09, 2011 6:50 pm
Forum: Other Issues
Topic: Problem running stylesheetDocumentation.sh
Replies: 9
Views: 2377

Problem running stylesheetDocumentation.sh

Hi there, I'm not really sure whether this is an oXygen issue or not, but I'm posting here in the hope that someone might have seen this and solved it before. I'm in the process of setting up a Jenkins "Continuous Integration Server" as part of a TEI project, and having trouble getting one of the bu...
by martindholmes
Tue Mar 01, 2011 8:27 pm
Forum: Common Problems
Topic: New keyboard bug in 12.1
Replies: 3
Views: 1210

Re: New keyboard bug in 12.1

I have some Compiz effects enabled ("wobbly windows" for instance), and I'm using the NVIDIA proprietary graphics driver (it's a dual-monitor setup). But I don't have this problem in any other Java apps as far as I can tell. If no-one else has reported it, though, and you can't reproduce it, there m...
by martindholmes
Wed Feb 23, 2011 10:24 pm
Forum: Common Problems
Topic: New keyboard bug in 12.1
Replies: 3
Views: 1210

New keyboard bug in 12.1

Hi there, After upgrading to 12.1, I've noticed a very annoying and persistent bug with regard to keyboard input. Whenever I summon a dialog box (for instance with Control + F for Find, or Control + E for "tag selected text"), if I start typing a little too quickly, before the dialog box is fully in...
by martindholmes
Mon Jan 31, 2011 8:48 pm
Forum: Common Problems
Topic: Memory problems with 12.1
Replies: 8
Views: 2481

Re: Memory problems with 12.1

Related to this, I have one fervent request: oXygen seems to save its current state (which project and files are open) only when it shuts down, and particularly only on a clean shutdown. That means that whenever it crashes, it forgets what project and files I have open, and also seems to lose any ch...
by martindholmes
Mon Jan 31, 2011 8:43 pm
Forum: Common Problems
Topic: Memory problems with 12.1
Replies: 8
Views: 2481

Memory problems with 12.1

Since upgrading to 12.1, I've had numerous crashes with out-of-memory errors, and lots of freezes as well, doing XSLT transformations that worked fine under the last version. I keep increasing the memory allocation in the oxygen.vmoptions file, but it doesn't seem to help. Have there been any change...
by martindholmes
Tue Oct 05, 2010 5:53 pm
Forum: Common Problems
Topic: Build number updated but date unchanged on download page
Replies: 3
Views: 1503

Re: Build number updated but date unchanged on download page

That's great -- much easier to understand. Thanks!

Martin
by martindholmes
Thu Sep 30, 2010 8:10 pm
Forum: Common Problems
Topic: Build number updated but date unchanged on download page
Replies: 3
Views: 1503

Build number updated but date unchanged on download page

This morning oXygen told me there was an update to 12.0, so I went to the download page. It shows the release date as September 14 (which is the same as the original version 12.0 I downloaded on that day). However, checking the build number shows 2010092112, as opposed to 2010091411, which is my ver...
by martindholmes
Mon Jun 21, 2010 7:16 pm
Forum: Common Problems
Topic: Content completion change in version 11
Replies: 1
Views: 913

Content completion change in version 11

I'm noticing that the content completion/suggestion system is not working as helpfully as it used to in previous versions. I'm editing a document, and I go to enter an attribute value which is defined as one or more URIs, like this: <ref target="#aida_1994">Aida (1994)</ref> In previous versions, wh...
by martindholmes
Thu Jun 03, 2010 6:55 pm
Forum: Common Problems
Topic: Problems with 11.2 -- reverted to 10.3
Replies: 3
Views: 1533

Re: Problems with 11.2 -- reverted to 10.3

Hi there, I have tried running 11.2 with both the OpenJDK (which is my default) and the Sun JRE which is in the oXygen directory. I'd ended up with the OpenJDK because it was causing fewer lockups, but I've now switched back to the bundled JRE. The - sun.boot.library.path points to <oxygen-installat...
by martindholmes
Fri May 28, 2010 5:52 pm
Forum: Common Problems
Topic: Problems with 11.2 -- reverted to 10.3
Replies: 3
Views: 1533

Problems with 11.2 -- reverted to 10.3

Using oXygen on Ubuntu Lucid 64-bit with a quad-core processor and 8GB of RAM. I've been trying to get used to oXygen 11.2 for a few weeks now, and I've finally given up and reverted to 10.3. These are the problems I'm having: The application locks up after a couple of hours of use, and at the same ...
by martindholmes
Fri Sep 04, 2009 7:10 pm
Forum: Common Problems
Topic: Code templates delete selected text
Replies: 1
Views: 900

Code templates delete selected text

I'd really like to use code templates for some of my most common markup tasks, so that I can add (say) a tag with several attributes in one operation. However, if I apply a code template with some text selected, instead of wrapping the template around the selected text, it deletes the selection. I'd...
by martindholmes
Wed Aug 26, 2009 7:21 pm
Forum: Common Problems
Topic: Odd behaviour with "Open in System Application"
Replies: 3
Views: 1193

Odd behaviour with "Open in System Application"

Using oXygen 10.3 on 64-bit Ubuntu Jaunty (9.04): When I choose to "Open file in system application" from the right-click menu in the project browser, I get some rather odd behaviour with a range of different file types, including .doc, .pdf and .odt. Instead of just launching the program configured...
by martindholmes
Thu May 15, 2008 6:34 pm
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3582

Re: Saxon 9B broken in oXygen 9.2?

That did it! I installed to a new folder, then deleted the old folder in Program Files. I think this might indicate that the uninstaller which runs at the beginning of the install process isn't quite cleaning up everything, though, at least if you install to the same location as the last version. I ...
by martindholmes
Thu May 15, 2008 5:46 pm
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3582

Re: Saxon 9B broken in oXygen 9.2?

I installed 9.2 with the regular Windows installer, on XP (SP3), and it apparently went through the process of uninstalling version 9.1. It did install to the same folder, though (Program Files\oxygen). I have other versions of Saxon on my system, from other tools, but I would expect oXygen to use i...
by martindholmes
Thu May 15, 2008 1:50 am
Forum: XSLT and FOP
Topic: Saxon 9B broken in oXygen 9.2?
Replies: 10
Views: 3582

Saxon 9B broken in oXygen 9.2?

Since installing oXygen 9.2, I'm having trouble with an XSLT 2.0 stylesheet that was working fine under 9.1. When I try to run a transformation with the stylesheet, I get only the vague error: Saxon 9B null When I try to validate the XSLT file, I get this error: Description: net.sf.saxon.style.XSLVa...
by martindholmes
Thu Dec 13, 2007 2:18 am
Forum: Other Issues
Topic: XInclude and content completion
Replies: 1
Views: 2496

XInclude and content completion

Hi there, We're contemplating a large TEI project which would involve editors working on thousands of small files, each of which would contain ref elements linking to the xml:id attribute of other tags. Most of these other tags will be in a separate document, like this: In doc 1: <list> <item xml:id...
by martindholmes
Wed Jul 04, 2007 1:49 am
Forum: Other Issues
Topic: Xinclude elements from the same document
Replies: 1
Views: 3632

Xinclude elements from the same document

I'm trying to get around the huge amount of duplication that typically happens in TEI documents, where titles, authors and similar info tend to appear in two or three different places. I'm doing this by using XInclude to include data from one part of the document in another part of the same document...
by martindholmes
Fri Mar 24, 2006 8:10 pm
Forum: Common Problems
Topic: Getting rid of pretty-print
Replies: 1
Views: 2406

Getting rid of pretty-print

I have a stack of documents that have been damaged by the use of pretty-print -- by which I mean that someone editing the files, who didn't really understand pretty-print and how to configure it, has pretty-printed thousands of instances of mixed content where spaces and returns shouldn't actually e...
by martindholmes
Thu Jan 26, 2006 9:38 pm
Forum: XSLT and FOP
Topic: XSLT transformation for schema documents
Replies: 1
Views: 3103

XSLT transformation for schema documents

Hi there, I have some TEI P5 documents that start like this: <TEI xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.tei-c.org/ns/1.0 imt_p5.xsd" xmlns:svg="http://www.w3.org/2000/svg" xmlns="http://www.tei-c.org/ns/1.0" version="5.0"> When I run an XSLT transformat...
by martindholmes
Mon Aug 15, 2005 8:29 pm
Forum: Common Problems
Topic: Problems updating from 6.0 to 6.1.1
Replies: 1
Views: 1966

Solved by deleting lib folder

I ended up deleting the entire lib folder from the program folder and running the installer again using "Repair".

I think there's something about the installer that prevents it from replacing existing jar files.

Cheers,
Martin
by martindholmes
Mon Aug 15, 2005 8:10 pm
Forum: Common Problems
Topic: Problems updating from 6.0 to 6.1.1
Replies: 1
Views: 1966

Problems updating from 6.0 to 6.1.1

I keep running the installer for the latest version, but it's failing to update my old installation; when I run the app and click on Help / About, I still see 6.0, build 2005051805. Has anyone else seen this behaviour?

Cheers,
Martin
by martindholmes
Thu Apr 21, 2005 6:11 pm
Forum: Common Problems
Topic: Complete freeze editing XSLT
Replies: 5
Views: 4124

Hi there, This is the stylesheet (hope it comes through OK on the forum): <?xml version="1.0" encoding="utf-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0" xmlns:fo="http://www.w3.org/1999/XSL/Format"> <!-- Bibliography elements, going to MLA style. This is compli...
by martindholmes
Wed Apr 20, 2005 6:47 pm
Forum: Common Problems
Topic: Complete freeze editing XSLT
Replies: 5
Views: 4124

Some additional info: -I'm running the latest update of Java 1.5: J2SE Version 1.5.0 (build 1.5.0_02-b09). -I'm running on dual monitors. oXygen is on the left monitor; if I move it to the right (which I'd prefer to do), the popup menus etc. continue to appear on the left monitor, but I guess that's...