Search found 236 matches

by sderrick
Thu Feb 10, 2011 8:58 pm
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

Sorin,

Log file not generated because I have Oxygen installed on /opt directory

I reinstalled in my home directory(completely new install), copied new .jar, setup log file generation, ran transform, crashed and then sent you the log file via the link provided.
by sderrick
Thu Feb 10, 2011 8:18 pm
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

Sorin, Still had excessive resource drain and crash, after renaming my options folder. Installed new oxygen.jar and created file. Ran transform which did crash after 3 minutes. No log files were generated? I sent in the log4j.properties file I created and a picture of the about box in a problem repo...
by sderrick
Thu Feb 10, 2011 1:25 am
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

I would really like to solve this problem.

I realize now that any time I run any script that lasts mroe than a second or two Oxygen is completely unresponsive until the script finishes..

Maybe setting the memory available in Oxygen's startup script to 1.5 GB was a bad idea?
by sderrick
Wed Feb 09, 2011 8:28 pm
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

Of course I have other files loaded in the editor! Who wouldn't? All are pretty small, css files and other scripts. I ran the script again. Oxygen about box reports 55MB of memory used by JVM with just the two files loaded, xml and xsl. My system monitor says the JVM Oxygen is running in is using 12...
by sderrick
Wed Feb 09, 2011 1:41 am
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

Oh, you mentioned the JVM via Oxygen using an inordinate amount of memory. On the command line which is finishing in 17 seconds vs Oxygens 3+ minutes and crashing, I am using the saxon9-9.1.0.7.jar. Using the same jar file only uses about 400KB of memory vs 1.5GB for Oxygen and using the same jar fi...
by sderrick
Tue Feb 08, 2011 10:08 pm
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

Re: XSLT resource Problem in 12.1(crashes)

What is the exact version number of Saxon that you run in the command line{/quote] 9.1.0.7 what is the Saxon version that you set in the transformation scenario in Oxygen? 9.3.0.4 What schema does the TEI XML file declare? <TEI xmlns="http://www.tei-c.org/ns/1.0" xml:id="tfccs.main.sh"> Is it TEI P...
by sderrick
Mon Feb 07, 2011 5:02 pm
Forum: Common Problems
Topic: Breakpoint in XML not working
Replies: 2
Views: 803

Re: Breakpoint in XML not working

Thanks for the lightning quick reply! I normally use the Sun JDK, but Ubuntu come with the OPenJDK and I momentarily switched to it to see if it made any difference. I started Oxygen from a Icon app launcher and saw no complaint about using the OpenJDK. I will try reducing the optimization level and...
by sderrick
Sun Feb 06, 2011 3:59 am
Forum: Common Problems
Topic: Breakpoint in XML not working
Replies: 2
Views: 803

Breakpoint in XML not working

Oxygen 11.2 or 12.1, Ubuntu 10.04, Sun JDK or OpenJDK

I know this use to work!

I set a break point in the XML(tei) source and the debugger never stops. Doesn't matter how many I set it ignores them all?
by sderrick
Sun Feb 06, 2011 2:27 am
Forum: Common Problems
Topic: XSLT resource Problem in 12.1(crashes)
Replies: 10
Views: 2109

XSLT resource Problem in 12.1(crashes)

Oxygen 12.1 running on Ubuntu 10.04 I have some xslt scripts that process TEI documents and generate large files. 20+ MB. Using the saxon executable from the command line it takes about 15 seconds to process. I monitored my system(dual cpu, 3GB ram) while running the scripts and it uses about 300MB ...
by sderrick
Sat Dec 25, 2010 7:21 am
Forum: XML Schemas
Topic: Oxygen complains about <p> tag following <div tag in TEI ?
Replies: 4
Views: 3140

Re: Oxygen complains about <p> tag following <div tag in TEI ?

I just upgraded to build 2010100114 hoping that would fix it.

No joy....
by sderrick
Sat Dec 25, 2010 6:42 am
Forum: XML Schemas
Topic: Oxygen complains about <p> tag following <div tag in TEI ?
Replies: 4
Views: 3140

Oxygen complains about <p> tag following <div tag in TEI ?

Here is a sample of a simple TEI/XML document. The last <p>..</P> tag is flagged(red squiggly line) as not valid? It looks valid to me and teh TEI spec seems to say its valid? <?xml version="1.0" encoding="UTF-8"?> <?oxygen RNGSchema="http://www.tei-c.org/release/xml/tei/custom/schema/relaxng/tei_al...
by sderrick
Tue Dec 21, 2010 7:55 pm
Forum: XSLT and FOP
Topic: retain unicode characters such as &#x002d; in xml to xml tra
Replies: 3
Views: 4033

Re: retain unicode characters such as &#x002d; in xml to xml tra

<?xml version="1.0" encoding="UTF-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="2.0"> <xsl:character-map name="minus"> <xsl:output-character character="-" string="-"/> </xsl:character-map> <xsl:output use-character-maps="minus"/> <xsl:template match="/"...
by sderrick
Tue Dec 21, 2010 2:27 am
Forum: XSLT and FOP
Topic: retain unicode characters such as &#x002d; in xml to xml tra
Replies: 3
Views: 4033

Re: retain unicode characters such as &#x002d; in xml to xml tra

I hacked it by changing all x002d chars to x202d and then the parser didn't replace it with a keuboard - minus sign...

Scott
by sderrick
Tue Dec 21, 2010 2:01 am
Forum: XSLT and FOP
Topic: retain unicode characters such as &#x002d; in xml to xml tra
Replies: 3
Views: 4033

retain unicode characters such as &#x002d; in xml to xml tra

I have some xml files that I need to run a xsl script on. The xml file has numerous(thousands) of unicode caracters specified. Some in that are in standard ascii and some not. I added <xsl:output encoding="US-ASCII"/> to my script which kept all but x002d, that being in the US ascii set. How can i r...
by sderrick
Sun Dec 12, 2010 10:26 pm
Forum: General XML Questions
Topic: <xsl:template match="p"> not working
Replies: 1
Views: 2796

<xsl:template match="p"> not working

I'm writing an xslt transform to number all the <p> tags in a xml document My initial script below <?xml version="1.0" encoding="UTF-8"?> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xd="http://www.oxygenxml.com/ns/doc/xsl" exclude-result-prefixes="xd" version="1.0"> <xsl:t...
by sderrick
Sat Dec 04, 2010 2:17 am
Forum: General XML Questions
Topic: Using additional TEI module
Replies: 2
Views: 1435

Re: Using additional TEI module

Thanks Radu, I will try the all schema.

Scott
by sderrick
Fri Dec 03, 2010 4:43 am
Forum: General XML Questions
Topic: Using additional TEI module
Replies: 2
Views: 1435

Using additional TEI module

I'm somewhat of a newbie in regards to TEI. I am editing a bunch of TEI documents, all using the standard schema with this at the top of each document <TEI xmlns="http://www.tei-c.org/ns/1.0"> However I am in need some of the elements in the msdescription module which is not included in the default ...
by sderrick
Sat Oct 23, 2010 11:24 pm
Forum: XSLT and FOP
Topic: xpath-default-namespace getting in the way
Replies: 2
Views: 1653

Re: xpath-default-namespace getting in the way

George,

thanks for the reply.

That did the trick!

thanks again,

Scott
by sderrick
Sat Oct 23, 2010 6:19 pm
Forum: XSLT and FOP
Topic: xpath-default-namespace getting in the way
Replies: 2
Views: 1653

xpath-default-namespace getting in the way

I am taking over a project that has some existing stylesheets. One of them has this at the top <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns="http://www.tei-c.org/ns/1.0" xpath-default-namespace="http://www.tei-c.org/ns/1.0" xmlns:...
by sderrick
Wed Oct 06, 2010 6:23 pm
Forum: Common Problems
Topic: Version 12 not saving state?
Replies: 4
Views: 1391

Re: Version 12 not saving state?

opening a local project fixed the problem.

Scott
by sderrick
Wed Sep 29, 2010 8:19 pm
Forum: Common Problems
Topic: Version 12 not saving state?
Replies: 4
Views: 1391

Re: Version 12 not saving state?

I entered a bug report.
by sderrick
Wed Sep 29, 2010 8:11 pm
Forum: Common Problems
Topic: Version 12 not saving state?
Replies: 4
Views: 1391

Re: Version 12 not saving state?

No, this has nothing to do with Windoze shutting down incorrectly. First I'm on Linux. Second, I am closing the application my self, not rebooting linux and relying on Oxygen responding to a HUP or SHUTDOWN signal. In version 11, the state was always saved. With version 12 its completely broken in t...
by sderrick
Tue Sep 28, 2010 5:29 pm
Forum: Common Problems
Topic: Version 12 not saving state?
Replies: 4
Views: 1391

Version 12 not saving state?

I just upgraded to 12 a couple weeks ago.

Version 11, would reopen the files I had open at the last shutdown. Now in version 12 it doesn't do this? Its a blank editor when started. :oops:

I really miss the feature of restoring its state form the last shut down. Any way I can enable that?

Scott
by sderrick
Mon Sep 20, 2010 4:18 pm
Forum: Common Problems
Topic: Upgrading to Version 12 in linux
Replies: 3
Views: 1159

Re: Upgrading to Version 12 in linux

makes sense. Thanks for keeping things up to date..

Great Editor!

Scott
by sderrick
Sat Sep 18, 2010 7:06 am
Forum: Common Problems
Topic: Upgrading to Version 12 in linux
Replies: 3
Views: 1159

Re: Upgrading to Version 12 in linux

Hmm.. must a been a reboot issue? After shutting things down and firing up my pc again I searched around and found the configuration directory. .com.oxygen.. Should have looked harder. Realized version 12 is supposed to the same stuff version 11 does. So I fired up Version 12 again and Voila! It was...
by sderrick
Fri Sep 17, 2010 5:22 pm
Forum: Common Problems
Topic: Upgrading to Version 12 in linux
Replies: 3
Views: 1159

Upgrading to Version 12 in linux

I'm pretty happy with 11.2, but I'm always a sucker for upgrades! I installed version 12 in a different folder than 11.2 is sitting in, as insurance. You never know. Fired up version 12 and it doesn't have any of my laboriously applied version 11.2 preferences nor my collection of xsl transforms? Ox...