Search found 5 matches

by MarcelM
Tue Sep 17, 2019 4:19 pm
Forum: General XML Questions
Topic: "Locate" button is disabled in Index tab of CHM output
Replies: 8
Views: 2701

Re: "Locate" button is disabled in Index tab of CHM output

Hi, the reason for the 'Locate' button problem is a change in the file "...\dita-ot-3.3\plugins\org.dita.htmlhelp\xsl\map2htmlhelp\map2hhpImpl.xsl": There is an Oxygen Patch: <!-- OXYGEN PATCH START EXM-18626 --> Auto Index=Yes Binary TOC=Yes Compatibility=1.1 or later <!-- OXYGEN PATCH END EXM-1862...
by MarcelM
Wed Aug 28, 2019 11:39 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: "Display referenced content" generates error
Replies: 6
Views: 705

Re: "Display referenced content" generates error

Hi Radu, I have found the problem: The topic with the referenced elements contains a topic within a topic: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd"> <topic id="Inhalt"> <title>Namen A</title> <topic id="nnn"> <title/> <body> <p> <text i...
by MarcelM
Wed Aug 28, 2019 10:28 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: "Display referenced content" generates error
Replies: 6
Views: 705

Re: "Display referenced content" generates error

Hi Radu, the root map is correctly selected. I opened the same project in 19.1 and 21.1, did the same selections of root map and settings. Version 19.1 displays all conkeyrefs correctly. Version 21.1 shows errors. Please see results of both versions in attachments: Marcel Oxygen19.1.png Oxygen21.1.p...
by MarcelM
Tue Aug 27, 2019 4:45 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: "Display referenced content" generates error
Replies: 6
Views: 705

"Display referenced content" generates error

Hi, I switched from Oxygen 19.1 to 21.1. Now within autor mode all conkeyrefs are no more resolved. There is an error message displayed for all conkeyrefs (example below): Element ID 'Produktname' not found in topic with ID 'Inhalt' The project worked fine in Oxygen 19.1 Is there a new setting withi...
by MarcelM
Tue Feb 05, 2019 12:39 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: keyscope attribute does not work as expected
Replies: 1
Views: 482

keyscope attribute does not work as expected

Hello, I try to work with the "keyscope" attribute on two maprefs in the main "Map.ditamap". Each referenced map defines the same key "topic". This key is used in a topic with a keyref (see <dt>A</dt>) and it works as expected. If I use the key within a <p> element (see <p id="Referrer"> in Template...