Search found 72 matches

by Carl
Wed May 06, 2020 9:19 pm
Forum: Common Problems
Topic: Text that should have been hidden by "props" still showing
Replies: 4
Views: 98

Re: Text that should have been hidden by "props" still showing

Hi Radu. Yes--I am often frustrated by the fact that my keyboard shortcuts stop working in Oxygen. For example, CMD-X, CMD-V, etc. stops working for cut and paste. I will try your CMD-Tab trick to see if that helps. I have experienced issues where OxygenXML will just "freeze" for about 10 seconds an...
by Carl
Tue May 05, 2020 11:55 pm
Forum: Common Problems
Topic: Text that should have been hidden by "props" still showing
Replies: 4
Views: 98

Re: Text that should have been hidden by "props" still showing

Very strange--I tried it again just now and I cannot reproduce the problem. The marked content is being hidden.

Perhaps it was a random glitch in my system? My Mac and Oxygen have been experiencing random freezes lately.
by Carl
Mon May 04, 2020 8:42 pm
Forum: Common Problems
Topic: Text that should have been hidden by "props" still showing
Replies: 4
Views: 98

Text that should have been hidden by "props" still showing

In my project, I've defined several props, including one called "PDF Hide", which shows as props="pdf-hide" in the code. In my PDF transformation, I have set the filter to "Exclude from output all elements with": props = pdf-hide props = PDF Hide At work on my Linux machine, the props filtering is w...
by Carl
Tue Mar 24, 2020 3:08 am
Forum: Feature Request
Topic: Highlight active topic in the ditamap
Replies: 5
Views: 234

Re: Highlight active topic in the ditamap

Thanks, Radu. I tried changing the colour of this grey background in the preferences, but gave up after several tries. It appears to be uneditable?
by Carl
Wed Mar 18, 2020 12:07 am
Forum: Feature Request
Topic: Automatically switch root map based on open ditamap
Replies: 7
Views: 295

Re: Automatically switch root map based on open ditamap

That is a good, concise explanation, Radu! It makes sense to me.

Ironically, it's much easier for me to comprehend your "if not using keys" example. Sounds natural to me. Maybe it's because this is how I did this before, prior to DITA!
by Carl
Wed Mar 18, 2020 12:05 am
Forum: Feature Request
Topic: Highlight active topic in the ditamap
Replies: 5
Views: 234

Re: Highlight active topic in the ditamap

Thank you, Radu! It turns out that my "Link with editor" button was turned off. This is exactly what I wanted. I even figured out how to change the colour of the highlight in the ditamap to make it more obvious. On a related note, why are all the topics within a ditamap (in the Maps Manager) highlig...
by Carl
Tue Mar 17, 2020 3:48 am
Forum: Feature Request
Topic: Highlight active topic in the ditamap
Replies: 5
Views: 234

Highlight active topic in the ditamap

I have a very common problem, but haven't figured out if there is a feature to help me out. If not, this is a good feature request. It's very simple: I open my user manual with resolved topics in the editor. The manual could be 100 pages or more. I scroll through the editor, reviewing the resolved t...
by Carl
Sat Mar 14, 2020 1:27 am
Forum: Feature Request
Topic: Automatically switch root map based on open ditamap
Replies: 7
Views: 295

Re: Automatically switch root map based on open ditamap

Thanks, Radu. Chris has summarized the enhancement request well. Right now, it's unfeasible to work with ditamaps with different root maps simultaneously. On a related issue, I never really understood keyrefs and the advantages of using them. Seems a lot more hassle to me when they keep breaking bec...
by Carl
Thu Mar 12, 2020 8:55 pm
Forum: Feature Request
Topic: Automatically switch root map based on open ditamap
Replies: 7
Views: 295

Automatically switch root map based on open ditamap

I am working with different ditamaps in the Map Manager and I have different topics open. One annoying thing I've encountered is when I switch between ditamaps, I must also constantly remember to change the root map. If I don't, my open topics suddenly start showing a slew of "Key not found" as the ...
by Carl
Wed Mar 11, 2020 7:00 pm
Forum: Common Problems
Topic: Profiling attributes suddenly disappeared
Replies: 4
Views: 200

Re: Profiling attributes suddenly disappeared

Yes, things worked normally again when I changed the DITA Type Document from " DITA " to " *DITA* ", or when I changed it to the actual custom DITA document that I had created (it's better to use "*DITA*" though). Radu said the preferences should have defaulted to "*DITA*" in the first place, but mi...
by Carl
Tue Mar 10, 2020 9:35 pm
Forum: Common Problems
Topic: Profiling attributes suddenly disappeared
Replies: 4
Views: 200

Re: Profiling attributes suddenly disappeared

Thanks Radu, that worked! Turns out I had created a new DITA document type based on your solution to another question I had (about forcing the editor to do line breaks, even in a code block). This broke the link to the profiling attributes. Oddly enough, my Preferences were showing just " DITA " as ...
by Carl
Tue Mar 10, 2020 2:20 am
Forum: Common Problems
Topic: Profiling attributes suddenly disappeared
Replies: 4
Views: 200

Profiling attributes suddenly disappeared

Until today, I was able to apply profiling attributes by right-clicking the selected text and choosing Edit Profiling Attributes . But for whatever reason, I just see "There are no attribute conditions defined" when I do this. When I click "Configure profiling attributes and values", the Preferences...
by Carl
Tue Mar 03, 2020 1:15 am
Forum: Common Problems
Topic: Line wraps in code block?
Replies: 1
Views: 156

Line wraps in code block?

I have noticed that text within <codeblock> tags do not line wrap in the editor. When compiled as WebHelp, they also do not line wrap unless there is an explicit line break within the code. But this code does wrap when PDF is the output. My question: It was probably by design that code blocks do not...
by Carl
Tue Jan 07, 2020 11:01 pm
Forum: Other Issues
Topic: WebHelp topic tooltip shows garbled text
Replies: 1
Views: 157

WebHelp topic tooltip shows garbled text

I understand the that "<shortdesc>" element is used to display tooltip text when you hover over a topic in WebHelp. Most of the time it works, but I've seen instances where the displayed tooltip contains garbled text. I've check the <shortdesc> contents and nothing seems to be amiss. That is, unless...
by Carl
Wed Dec 11, 2019 4:15 am
Forum: Other Issues
Topic: How to fix this "elements must consist of well-formed character data"?
Replies: 1
Views: 372

How to fix this "elements must consist of well-formed character data"?

I am receiving this error "The content of elements must consist of well-formed character data or markup". It's repeated five times for a single line in my topic. I can't figure out what this means--the OxygenXML validator isn't helping.

Please see the attached screenshot.
2019-12-10_17-09-28.png
2019-12-10_17-09-28.png (247.75 KiB) Viewed 372 times
by Carl
Wed Dec 11, 2019 3:40 am
Forum: Common Problems
Topic: How to search XML code in all my topics?
Replies: 5
Views: 335

Re: How to search XML code in all my topics?

Yes, using the "Restrict to XPath" option worked. I never would have figured this out myself--talk about non-obvious!

Can't you make a search that actually searches ALL the text in a dita topic? A simple text string search is all I need.
by Carl
Tue Dec 10, 2019 2:44 am
Forum: Common Problems
Topic: How to search XML code in all my topics?
Replies: 5
Views: 335

Re: How to search XML code in all my topics?

Thanks Radu. I have attached a screenshot showing my Find settings. I believe I've made it as liberal as I could, yet I still get: Scanned Files: 357 Occurrences: 0 I copied the conkeyref[/b] string directly from my topic and I know there are many many instances of this string in my project. I canno...
by Carl
Thu Dec 05, 2019 11:13 pm
Forum: Common Problems
Topic: How to search XML code in all my topics?
Replies: 5
Views: 335

How to search XML code in all my topics?

This problem has vexed me ever since I started using OxygenXML: how do I search for specific XML code? For example, I want to find all occurrences of: conkeyref="corp-vars/corp" And replace it with: conkeyref="strings-corp/corp" I've tried different options under "Find/Replace in Files", but I can't...
by Carl
Sat Nov 30, 2019 3:19 am
Forum: Common Problems
Topic: "Image not found" error on PDF transformation
Replies: 1
Views: 175

"Image not found" error on PDF transformation

I have discovered a curious glitch: when I PDF my entire project (from the DITA Maps Manager), the output contains all my images, as expected. But when I PDF individual topics, sometimes the image appears, other times it is excluded! When excluded, I get errors like this: System ID: /home/clum/repos...
by Carl
Thu Sep 19, 2019 1:46 am
Forum: Common Problems
Topic: How to add a line break in the middle of a <p> paragraph?
Replies: 3
Views: 377

Re: How to add a line break in the middle of a <p> paragraph?

Hi Radu. So what you're saying is that this line break feature added 10 years ago was quickly removed, because it didn't work in DITA? I am surprised to hear that line breaks are not requested very often. I agree that I don't use it often, but when it's needed, a workaround is difficult. For example...
by Carl
Wed Sep 18, 2019 3:08 am
Forum: Common Problems
Topic: How to add a line break in the middle of a <p> paragraph?
Replies: 3
Views: 377

How to add a line break in the middle of a <p> paragraph?

Hello. This simple word processing task has eluded me in Oxygen. I did a Google search and found this response from Radu 10 years ago: Re: Entering a newline from the middle of a tag Post by Radu » Fri Oct 02, 2009 1:32 am Hello Mark, Oxygen 11 (available in a few weeks) will have the Insert new lin...
by Carl
Mon Sep 16, 2019 8:38 pm
Forum: Common Problems
Topic: WebHelp Search broken in latest v21.1 update
Replies: 10
Views: 705

Re: WebHelp Search broken in latest v21.1 update

Hi. I already had clean.output = yes. And I renamed the output folder, allowing Oxygen to create a new WebHelp output folder. Neither worked: when I switched back to build 2019090904, the resulting WebHelp will not search.

Will it help if I send you a copy of my faulty WebHelp?
by Carl
Fri Sep 13, 2019 9:40 pm
Forum: Common Problems
Topic: WebHelp Search broken in latest v21.1 update
Replies: 10
Views: 705

WebHelp Search broken in latest v21.1 update

A few days ago, my OxygenXML Author notified me there was an update. So I installed the update and continued working. Everything seemed normal. Today, I did another WebHelp compile using the WebHelp Responsive transformation that I've been using all along. The compile completed normally and the WebH...
by Carl
Thu Jul 11, 2019 7:01 pm
Forum: Common Problems
Topic: Where are these related topic links coming from?
Replies: 11
Views: 1571

Re: Where are these related topic links coming from?

Hi Radu. I am revisiting your reply above, as I thought I got rid of the problem but now it's reappeared in my project again. I don't understand this sentence from your reply: so forcefully treating all links as generic topics by setting the @type attribute on the related links element I don't see a...
by Carl
Tue Jul 09, 2019 8:38 pm
Forum: Common Problems
Topic: Misaligned step number when graphic is present
Replies: 6
Views: 574

Re: Misaligned step number when graphic is present

Thanks, Radu. I tried the HTML5 version and it does align properly. I will look to see if we can adapt that for our template.

I am new to DITA--what's the difference between "FO" and "HTML5"? Why would I use one over the other?
by Carl
Mon Jul 08, 2019 11:42 pm
Forum: Common Problems
Topic: Misaligned step number when graphic is present
Replies: 6
Views: 574

Re: Misaligned step number when graphic is present

I am using the Global transformation "DITA Map PDF - based on XSL-FO - Copy". My version of Oxygen is XML Author 21.1, build 2019061404.
by Carl
Wed Jul 03, 2019 8:02 pm
Forum: Common Problems
Topic: Misaligned step number when graphic is present
Replies: 6
Views: 574

Misaligned step number when graphic is present

Here is a minor but annoying visual glitch that I can't figure out how to resolve. In a numbered step, if there is a graphic in the line (for example, a button illustration), the line is :pushed down: to accommodate the taller graphic, but step number stays in the same place. This results in an awkw...
by Carl
Thu Jun 27, 2019 11:48 pm
Forum: Common Problems
Topic: Compiled CHM file disappears
Replies: 3
Views: 542

Re: Compiled CHM file disappears

Hi Radu. It just occurred to me maybe the reason why I can't create CHM is that I'm running on Linux? I just upgraded to OxygenXML version 21 and now the CHM compile does result in output in the CHM directory, but it's just my source files as HTML files. Then there are three separate .hhc, .hhk, and...
by Carl
Tue Jun 25, 2019 12:04 am
Forum: Common Problems
Topic: Version 21 WebHelp compilation errors
Replies: 4
Views: 540

Re: Version 21 WebHelp compilation errors

I have sent you a copy of my DITA OT console output. Hopefully you can resolve this as this error is blocking me from compiling a WebHelp for our release. (We need WebHelp from v21, because it resolves a security issue.) For what it's worth, I tried creating a simple 2-topic test project, and the We...
by Carl
Mon Jun 24, 2019 9:19 pm
Forum: Common Problems
Topic: Version 21 WebHelp compilation errors
Replies: 4
Views: 540

Re: Version 21 WebHelp compilation errors

Radu, I have emailed the DITA OT console output to your Support email, referencing this topic. Hopefully you will be able to figure this out quickly, as we need WebHelp output from version 21 imminently.