Search found 20 matches

by Seb
Fri Sep 14, 2018 12:26 pm
Forum: Other Issues
Topic: How to switch off inserting line breaks within tags
Replies: 3
Views: 149

Re: How to switch off inserting line breaks within tags

I then would like to request this feature. We apply transformations to the XML files after they have been edited with Oxygen. After the transformation, the line breaks within tags disappear, because they are obviously not representable in a DOM. A (Git) diff of the file before and after the transfor...
by Seb
Thu Sep 13, 2018 5:57 pm
Forum: Other Issues
Topic: How to switch off inserting line breaks within tags
Replies: 3
Views: 149

How to switch off inserting line breaks within tags

How can I disable Oxygen inserting line breaks within XML tags like this:


Code: Select all

...<hi
                           rendition="#u"
                        >
by Seb
Tue Jun 06, 2017 2:44 pm
Forum: Other Issues
Topic: Files open in unsorted order
Replies: 2
Views: 479

Re: Files open in unsorted order

Hi adrian,

thanks for the hint with the selection. This may solve my problem. Otherwise, I will get back to you. (I'm using the most recent Oxygen 19 build).
by Seb
Tue Jun 06, 2017 2:20 pm
Forum: Other Issues
Topic: Files open in unsorted order
Replies: 2
Views: 479

Files open in unsorted order

Sometimes, opening several XML files (via the "Project" view) results in these files being opened in random order. This means, that the tab bar of the editor window does not display them in the correct alphabetical order, even though these documents are sorted alphabetically in the Project...
by Seb
Thu Jun 01, 2017 3:26 pm
Forum: Other Issues
Topic: Oxygen Ctrl+Tab uses history instead of position
Replies: 6
Views: 907

Re: Oxygen Ctrl+Tab uses history instead of position

I vote for this feature too.
by Seb
Fri May 05, 2017 4:15 pm
Forum: Other Issues
Topic: Insert same UUID twice
Replies: 8
Views: 2064

Re: Insert same UUID twice

Perfect! This does exactly what I wanted to achieve. Again, thank you very much and no need to be sorry.
by Seb
Fri May 05, 2017 12:19 pm
Forum: Other Issues
Topic: Insert same UUID twice
Replies: 8
Views: 2064

Re: Insert same UUID twice

I have used the editor variable ${selection} in my initial post: <addSpan spanTo="#${uuid}"/>${selection}<anchor xml:id="${uuid}"/> Then you have used ${selection} in your XSLT snippet. From that I thought it would be clear that I want to wrap the selection. You have provided a s...
by Seb
Thu May 04, 2017 5:31 pm
Forum: Other Issues
Topic: Insert same UUID twice
Replies: 8
Views: 2064

Re: Insert same UUID twice

Thanks again. But this does not seem to keep the selection which I want to wrap: <xsl:template match="/"> <addSpan spanTo="#{$ID}"/>${selection}<anchor xml:id="{$ID}"/> </xsl:template> After the first action has deleted the selection, the second action has no reference ...
by Seb
Thu May 04, 2017 3:59 pm
Forum: Other Issues
Topic: Insert same UUID twice
Replies: 8
Views: 2064

Re: Insert same UUID twice

Thanks. It works.

Is there also way to use "XSLTOperation" as a replacement for "InsertOrReplaceFragmentOperation", so that selected text will not be duplicated?
by Seb
Thu May 04, 2017 1:07 pm
Forum: Other Issues
Topic: Insert same UUID twice
Replies: 8
Views: 2064

Insert same UUID twice

I want to create an Author Mode action (InsertFragmentOperation) that generates a single UUID and inserts it in two positions. Doing this <addSpan spanTo="#${uuid}"/>${selection}<anchor xml:id="${uuid}"/> results in two different UUIDs being inserted. Is there a way to insert the...
by Seb
Tue May 02, 2017 12:59 pm
Forum: Other Issues
Topic: Rendering of space character in Author Mode
Replies: 2
Views: 673

Rendering of space character in Author Mode

Consider this document: <?xml version="1.0" encoding="UTF-8"?> <?xml-stylesheet href="style.css" type="text/css"?> <p>ἄτοπον ἅμα ζητεῖν ἐπιστήμην καὶ τρόπον<space/>ἐπιστήμης</p> And this stylesheet: p { display: block; } space { content: " "; -oxy-di...
by Seb
Wed Apr 19, 2017 2:00 pm
Forum: Other Issues
Topic: Tilde glyph not visible on print
Replies: 4
Views: 712

Re: Tilde glyph not visible on print

Yes, I'm using File->Print.

It doesn't matter if I'm using "Microsoft Print to PDF" or a real printer. There's always the fallback box glyph, even in the PDF.

Please note, that the tilde I'm using is Unicode char U+223C.
by Seb
Tue Apr 18, 2017 6:59 pm
Forum: Other Issues
Topic: Tilde glyph not visible on print
Replies: 4
Views: 712

Tilde glyph not visible on print

Consider this document: <?xml-stylesheet href="#s1" type="text/css"?> <doc> <s id="s1"> s { display: none; } p { display: block; } tilde { content: "∼"; font-style: italic; } </s> <p><tilde/></p> </doc> When I open it in Author Mode, I can see the tilde glyph ...
by Seb
Mon Apr 10, 2017 1:12 pm
Forum: Other Issues
Topic: Line breaks on empty elements in Author Mode
Replies: 6
Views: 1139

Re: Line breaks on empty elements in Author Mode

Hi Radu,

sounds good. Will you update this threat when this has been resolved? Then I'd activate the notifier service.
by Seb
Tue Apr 04, 2017 12:43 pm
Forum: Other Issues
Topic: Line breaks on empty elements in Author Mode
Replies: 6
Views: 1139

Re: Line breaks on empty elements in Author Mode

Hi Radu, thanks for the reply. None of these settings seem to have any effect. The word is still broken in Author mode. Just to make sure that I have not been too unspecific about the issue, let me give you two screenshots: Text Mode: http://i.imgur.com/1ezMCJa.png Author Mode: http://i.imgur.com/Na...
by Seb
Mon Apr 03, 2017 4:46 pm
Forum: Other Issues
Topic: Line breaks on empty elements in Author Mode
Replies: 6
Views: 1139

Line breaks on empty elements in Author Mode

I have a question regarding line break handling in oXygen Author Mode on empty elements. It is related to https://www.oxygenxml.com/forum/topic10259.html Suppose, I have this XML: <p>This is an example of an original text, where a line break occurs in bet<lb type="inWord"/> ween a word.</p...
by Seb
Fri Mar 10, 2017 2:02 pm
Forum: Other Issues
Topic: Disable content completion in Attributes view
Replies: 2
Views: 518

Re: Disable content completion in Attributes view

Hi Radu,

thank you. You understood correctly, and creating a cc_config.xml has solved my problem. It's even better that I can switch off suggestions per attribute name instead of globally.
by Seb
Thu Mar 09, 2017 3:35 pm
Forum: Other Issues
Topic: Disable content completion in Attributes view
Replies: 2
Views: 518

Disable content completion in Attributes view

Hi, I want to disable content completion in the Attributes view, because this often leads to mistakes in our project. I know about the content completion preferences [1], but they do not seem to have any effect on the Attributes view. I also know about this doc page [2], but there is no mention on h...
by Seb
Tue Feb 21, 2017 4:18 pm
Forum: SDK-API, Frameworks - Document Types
Topic: Surround with elements and copy text content
Replies: 2
Views: 604

Re: Surround with elements and copy text content

Hi Radu,

thank you! This is exactly what I was looking for.
by Seb
Mon Feb 20, 2017 8:13 pm
Forum: SDK-API, Frameworks - Document Types
Topic: Surround with elements and copy text content
Replies: 2
Views: 604

Surround with elements and copy text content

Hi, I'm wondering if this is somehow possible with Author Mode actions: Selecting a text snippet "Hey" in Author mode, turning it into this: <a><b><d>Hey</d></b><c>Hey</c></a> I tried to implement such a tagging mechanism with a combination of "ExecuteMultipleWebappCompatibleActionsOp...

Go to advanced search