Search found 132 matches

by tomjohnson1492
Mon Jan 12, 2015 6:37 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

Re: confirmation email for webhelp with feedback doesn't wor

I even tried it with a prev build (16.0) and got the same result.
by tomjohnson1492
Mon Jan 12, 2015 6:22 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

Re: confirmation email for webhelp with feedback doesn't wor

I just tried signing up again and experienced the same problem. The confirm email is: Welcome Shannon [shannon] to the test Webhelp system! Please click the link below to confirm your registration: http://idratherbewriting.com/webhelpfeedbacktest/oxygen-webhelp/resources/confirm.html?idNnwyMDE1LTAxL...
by tomjohnson1492
Sat Jan 10, 2015 10:17 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

Re: confirmation email for webhelp with feedback doesn't wor

Just to confirm that the issue wasn't due to any security restrictions in my environment at work, I created a test webhelp with feedback project here: http://idratherbewriting.com/webhelpfeedbacktest Try to sign up to comment on the topic. When you do, you'll get an email telling you to confirm the ...
by tomjohnson1492
Sat Jan 10, 2015 9:44 pm
Forum: Other Issues
Topic: webhelp with feedback needs parameter option
Replies: 6
Views: 1899

Re: webhelp with feedback needs parameter option

Okay, but the current design for this output is problematic. If I change the TOC, add some style to my skin file, or do anything else other than just update text in a topic, I have to reupload the oxygen-webhelp folder. This folder contains a blank config.php file that overwrites my existing configu...
by tomjohnson1492
Sat Jan 10, 2015 9:24 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

Re: confirmation email for webhelp with feedback doesn't wor

If you have a fix for this, let me know. I have about 20 people who will be reviewing documentation on Monday and I've told them to comment anonymously, without logging in. I tried changing the file permissions to everything in the oxygen-webhelp directory to 777, but it had no effect. The confirm.h...
by tomjohnson1492
Sat Jan 10, 2015 9:02 pm
Forum: Other Issues
Topic: Remove br tags around images with webhelp output?
Replies: 7
Views: 2269

Re: Remove br tags around images with webhelp output?

I added an adjacent sibling select to hide the br tags:

Code: Select all

p.p + br, br + br {display:none;}
by tomjohnson1492
Sat Jan 10, 2015 8:53 pm
Forum: Other Issues
Topic: Remove br tags around images with webhelp output?
Replies: 7
Views: 2269

Re: Remove br tags around images with webhelp output?

I'm wondering if there's a fix for this. It looks pretty bad in my output and I'm not quite sure how to fix it. I tried adding display:none for my br tags, but it messes with other elements, such as related links.
by tomjohnson1492
Fri Jan 09, 2015 9:25 pm
Forum: Feature Request
Topic: Make Oxygen webhelp load faster
Replies: 5
Views: 2544

Re: Make Oxygen webhelp load faster

The speed issue is killing me. Sometimes it takes 3 seconds for a basic page to load. Given that there's no database query here, I can't imagine where the latency is. This issue a huge priority for me to get fixed. Thanks.
by tomjohnson1492
Fri Jan 09, 2015 9:16 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

It's good to know there's a lot of progress on developing a more robust stylesheet. I'm eagerly awaiting your upcoming release.
by tomjohnson1492
Fri Jan 09, 2015 9:15 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

Re: confirmation email for webhelp with feedback doesn't wor

I wish this commenting feature weren't so buggy and fragile.
by tomjohnson1492
Fri Jan 09, 2015 8:09 pm
Forum: Other Issues
Topic: confirmation email for webhelp with feedback doesn't work
Replies: 8
Views: 2448

confirmation email for webhelp with feedback doesn't work

I have oxygen webhelp with feedback integrated. When a user signs up for an account in order to comment, an email validation is sent. However, when the user clicks the link in the validation email, it goes to a blank page. Here's a sample validation link: http://mysite.com/sampleproject/oxygen-webhe...
by tomjohnson1492
Fri Jan 09, 2015 7:38 pm
Forum: Other Issues
Topic: Sometimes topic content doesn't appear
Replies: 18
Views: 4379

Re: Sometimes topic content doesn't appear

I'm glad it's not happening for you. Here's what I think is going on. I'm on a Mac with Chrome. I test set up all my build outputs directly to the built-in webserver directory for the Mac. So I view the content locally, which probably gets cached. Chrome dislikes Javascript on my local machine, even...
by tomjohnson1492
Fri Jan 09, 2015 10:59 am
Forum: Feature Request
Topic: making <oxygen/> return something
Replies: 1
Views: 1006

making <oxygen/> return something

Okay, this would be a neat little parlor trick feature only, but I once tried entering <oxygen/> to see if it would return anything. It doesn't. It's invalid XML. when you think about it. oxygen's logo is invalid xml. I think that every time I see it. Why not add a special feature there that produce...
by tomjohnson1492
Fri Jan 09, 2015 10:57 am
Forum: Other Issues
Topic: Sometimes topic content doesn't appear
Replies: 18
Views: 4379

Re: Sometimes topic content doesn't appear

just uploaded it via your form. Thanks for taking a look at it.
by tomjohnson1492
Fri Jan 09, 2015 10:51 am
Forum: Other Issues
Topic: Sometimes topic content doesn't appear
Replies: 18
Views: 4379

Re: Sometimes topic content doesn't appear

<oXygen/> XML Author 16.1, build 2014100319

i'll send you the project and see if you can reproduce it.
by tomjohnson1492
Fri Jan 09, 2015 10:49 am
Forum: Other Issues
Topic: webhelp with feedback needs parameter option
Replies: 6
Views: 1899

Re: webhelp with feedback needs parameter option

yeah, that works but is still not so ideal in my opinion.
by tomjohnson1492
Fri Jan 09, 2015 10:32 am
Forum: Other Issues
Topic: Sometimes topic content doesn't appear
Replies: 18
Views: 4379

Re: Sometimes topic content doesn't appear

I have version 16.1. Yes, the content on the right pane (where all the help content appears) is sometimes blank. it's erratic and somewhat hard to reproduce consistently. I use Chrome almost exclusively.
by tomjohnson1492
Fri Jan 09, 2015 10:17 am
Forum: Other Issues
Topic: Sometimes topic content doesn't appear
Replies: 18
Views: 4379

Sometimes topic content doesn't appear

This is kind of a strange issue, but with the webhelp output, sometimes the content of a topic doesn't appear when I go to the topic. Or it briefly appears and then disappears. I have to drag the horizontal slider (what separates the TOC pane from the main content pane) a little bit left or right to...
by tomjohnson1492
Fri Jan 09, 2015 10:15 am
Forum: Feature Request
Topic: fixed width option
Replies: 1
Views: 1141

fixed width option

For the webhelp output, can you add a "fixed width" parameter that allows me to specify a max width, something like 800px? I really hate it how the liquid layout takes up the entire screen (on my 21 inch Mac Thunderbolt display, seeing one line stretch 2 feet long is really lame) doesn't f...
by tomjohnson1492
Fri Jan 09, 2015 10:12 am
Forum: Other Issues
Topic: webhelp with feedback needs parameter option
Replies: 6
Views: 1899

webhelp with feedback needs parameter option

With Oxygen webhelp with feedback, there should be a parameter to check that says "Include install directory". This way, after the first time you generate the webhelp and install it, you can uncheck this box and the install directory wouldn't be included. Then when you regenerate the help,...
by tomjohnson1492
Fri Jan 09, 2015 12:50 am
Forum: Other Issues
Topic: Remove br tags around images with webhelp output?
Replies: 7
Views: 2269

Remove br tags around images with webhelp output?

When you include an image in a webhelp file, the output puts two br tags before and after the image, like this: http://www.screencast.com/t/dxR4IbnKTB As a result, I have a lot of excess white space around the image. Why is the webhelp plugin adding all of these br tags in there? This is poor practi...
by tomjohnson1492
Mon Jan 05, 2015 8:31 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

Thanks for the fix. BTW, what about all the link underlining (even in non-links)? Do you have a fix for that as well?
by tomjohnson1492
Wed Dec 31, 2014 12:45 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

I realize that the keyref does resolve, but for some reason the keyref name appears before it. Maybe I can just add a display:none to whatever is styling the [versionx] part?
by tomjohnson1492
Wed Dec 31, 2014 12:19 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

Sure, here's how you can reproduce the keyref bug. 1. Create a map with this code: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE map PUBLIC "-//OASIS//DTD DITA Map//EN" "map.dtd"> <map> <title>DITA Topic Map</title> <topicref href="version_test.dita&qu...
by tomjohnson1492
Tue Dec 23, 2014 9:11 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

Thanks for pointing out the location of the customized CSS stylesheet. You're right -- the table of contents and cross references appear. However, keyrefs don't appear. See http://www.screencast.com/t/VLGQXdetxt. Additionally, a lot of the links are underline the entire sentence rather than just the...
by tomjohnson1492
Tue Dec 23, 2014 8:24 pm
Forum: Common Problems
Topic: rellinks inconsistency
Replies: 3
Views: 1108

Re: rellinks inconsistency

For some topics in my help, I want the rellinks turned on. For other sections, I want them turned off. I realize this creates some inconsistency, but it was something I was trying. In your experiment, try turning on rellinks for just one section in your ditamap. The normal approach to do this would ...
by tomjohnson1492
Tue Dec 23, 2014 10:00 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

Hey, that worked. I added a new parameter called princeExecPath with a value of /usr/local/bin/prince and it worked. Now, another question. Have you developed a custom stylesheet for Prince that will render user guides well? Particularly, is there a way to get cross references such as "see &quo...
by tomjohnson1492
Tue Dec 23, 2014 3:45 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

If I type

Code: Select all

echo $PATH
I see /usr/local/bin as one of the paths returned. I'm not sure why the prince PDF transform is failing in Oxygen. Any ideas?
by tomjohnson1492
Tue Dec 23, 2014 3:05 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Configure DITA-OT with PrinceXML
Replies: 20
Views: 6151

Re: Configure DITA-OT with PrinceXML

I'm interested in trying out Prince. However, I'm not quite sure how to add prince to my classpath on a Mac. Can you tell me how to do that? I do have prince installed in /usr/local/bin. I'm able to run the Prince transformations using the command line, but I'd rather run it from Oxygen directly. Th...
by tomjohnson1492
Tue Dec 16, 2014 8:38 pm
Forum: Feature Request
Topic: Understanding conditional filtering
Replies: 6
Views: 1863

Re: Understanding conditional filtering

I'm not exactly sure. Sometimes I make a change, and then later when I'm doing my transforms I realize that they aren't filtering. I would need to experiment more to see what triggers the selector to drop. At any rate, I switched to using ditaval files instead.

Go to advanced search