Search found 71 matches

by mphare
Mon Jan 30, 2012 9:25 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Does Oxygen XML support DITA Map Specialization?
Replies: 2
Views: 1368

Re: Does Oxygen XML support DITA Map Specialization?

Hi Radu, Knowing that OxygenXML supported Map Specialization was enough to keep me looking for an answer in my code. My fear was I would spend a lot of time searching only to find out later Map Specialization wasn't supported. But, since I knew it was I went back through the code and eventually foun...
by mphare
Fri Jan 27, 2012 12:12 am
Forum: DITA (Editing and Publishing DITA Content)
Topic: Does Oxygen XML support DITA Map Specialization?
Replies: 2
Views: 1368

Does Oxygen XML support DITA Map Specialization?

Hi, Using OxygenXML Editor 13.2 on Windows XP. I have created a Map specialization and deployed the pieces to the DITA-OT, but opening the specialized map file in the Oxygen DITA Maps Manager does not show me all the things the map is pointing to, the way it does for non-specialized Maps. I can vali...
by mphare
Wed Jan 25, 2012 7:45 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: XSLT Extension to DITA-OT is not behaving as I believe it should
Replies: 2
Views: 4503

Re: XSLT Extension to DITA-OT is not behaving as I believe it should

Hi Radu,

Excellent!

I completely overlooked the need for type="file" attribute and just didn't notice the incorrect case usage.

Problem solved!

Thanks,

- m
by mphare
Tue Jan 24, 2012 7:12 pm
Forum: General XML Questions
Topic: Validating XML with DTD through a Catalog
Replies: 3
Views: 2588

Re: Validating XML with DTD through a Catalog

I appreciate the response.
I was sure I was not understanding something fundamental regarding DOCTYPEs.

No problems with the bug, leaving .dtd in the ID is a fine workaround.

Thanks for the information!

- m
by mphare
Tue Jan 24, 2012 6:48 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: XSLT Extension to DITA-OT is not behaving as I believe it should
Replies: 2
Views: 4503

XSLT Extension to DITA-OT is not behaving as I believe it should

I am using Oxygen XML Editor 13.2 First, I am crash coursing myself through DITA and specialization. I have successfully created an extension to extend topic. I've deployed it to the Toolkit in Oxygen and I've run the XHTML transformation script and I get the results I expected. Now, I want to creat...
by mphare
Sat Jan 21, 2012 6:16 pm
Forum: General XML Questions
Topic: Validating XML with DTD through a Catalog
Replies: 3
Views: 2588

Validating XML with DTD through a Catalog

Hi, I am using Oxygen 13.2 and am going though some DITA tutorials that use DTDs. I believe this question is general XML, not DITA specific, but will re-post in the DITA forum if you believe it is specific to DITA. I have setup a DTD that is accessed through an XML catalog. Oxygen is resolving thoug...
by mphare
Thu Mar 03, 2011 10:34 pm
Forum: Other Issues
Topic: Editor function to find the closing tag??
Replies: 3
Views: 1269

Re: Editor function to find the closing tag??

No, the problem is my tags may be far apart and I can't see the closing tag when I'm on the opening tag. I may be at the opening tag and I need to quickly navigate to the closing tag so I can add some new content, or I may be at the closing tag and I need to navigate to the opening tag to do some ed...
by mphare
Fri Feb 25, 2011 1:27 am
Forum: Other Issues
Topic: Editor function to find the closing tag??
Replies: 3
Views: 1269

Editor function to find the closing tag??

Hi, Using Oxygen XML 12.1 in Win7/64 I've used Oxygen since v4 and I guess I've never looked for this before. Is there a way to quickly locate the end tag if I am on the start tag (or find the start tag if I an on the end tag)? Kind of like how some C++ / Java editors allow you to find the matching ...
by mphare
Mon Feb 21, 2011 7:00 pm
Forum: Common Problems
Topic: Cannot Refresh Folder in Project View
Replies: 3
Views: 1003

Re: Cannot Refresh Folder in Project View

Thanks, Adrian!
by mphare
Mon Feb 21, 2011 5:37 pm
Forum: Common Problems
Topic: Cannot Refresh Folder in Project View
Replies: 3
Views: 1003

Re: Cannot Refresh Folder in Project View

My problem may be that I created the folder using 'Logical Folders from File System' and I get a blue folder icon. So, maybe this is not physically tied to the file system and updates/refreshes won't work. Then, what is the 'Refresh' menu item for?
by mphare
Mon Feb 21, 2011 5:30 pm
Forum: Common Problems
Topic: Cannot Refresh Folder in Project View
Replies: 3
Views: 1003

Cannot Refresh Folder in Project View

I am currently running Oxygen XML 12.1, build 2011021814. I have noticed this problem since moving to Windows 7 Pro / 64b. Previously, I was able to refresh folders in my project view and any files with the red exclamation mark (files I deleted) would be removed from the folder. Also, any new files ...
by mphare
Fri Aug 06, 2010 5:15 pm
Forum: Other Issues
Topic: Default Schema Editor View
Replies: 4
Views: 1551

Re: Default Schema Editor View

Turning off the Schema Diagram View was something I was looking for, too. Thanks for the pointer to the Preferences. As a suggestion, it would be nice to be able to show/no-show the diagram quicker than tracing though a menu hierarchy and the preferences dialog. Could we maybe have a button? Current...
by mphare
Wed Jan 13, 2010 7:10 pm
Forum: Common Problems
Topic: Getting Message: No XML document selected
Replies: 5
Views: 1329

Re: Getting Message: No XML document selected

Opps... found it in the preference.

Thanks again for the help!
by mphare
Wed Jan 13, 2010 7:06 pm
Forum: Common Problems
Topic: Getting Message: No XML document selected
Replies: 5
Views: 1329

Re: Getting Message: No XML document selected

That does seem to be the problem.

Is there a way to un-hijack, or re-hijack the associations and give them back to Oxygen?

Thanks for the help!
by mphare
Wed Jan 13, 2010 1:25 am
Forum: Common Problems
Topic: Getting Message: No XML document selected
Replies: 5
Views: 1329

Re: Getting Message: No XML document selected

I have a 3 seat license, so I installed another Oxygen Editor 11.1 on my laptop also running Galileo. That one works fine. All the tabs show the structure as I would have expected them too. So, what can be different between the two installations? Why would one work and not the other? Some Preference...
by mphare
Tue Jan 12, 2010 7:48 pm
Forum: Common Problems
Topic: Getting Message: No XML document selected
Replies: 5
Views: 1329

Getting Message: No XML document selected

Hi, I've just upgraded from Editor 9.3 to 11.1. I had this problem prior to the upgrade and was hoping the upgrade would fix the problem. In Eclipse 3.5 (Galileo), when I open an XML or XSL file, the tabs on the right of the perspective (Model, Attribute, Elements, Entities, etc..) show the message ...
by mphare
Wed May 21, 2008 12:45 am
Forum: Common Problems
Topic: XSLT Completion under Eclipse
Replies: 3
Views: 1457

Re: XSLT Completion under Eclipse

No, I don't get the list at all. Typing 's' just puts in an 's'.
by mphare
Mon May 19, 2008 5:57 pm
Forum: Common Problems
Topic: XSLT Completion under Eclipse
Replies: 3
Views: 1457

XSLT Completion under Eclipse

I'm using Oxygen 9.2. When editing XSLTs in Eclipse, sometimes I do not get the first attribute to complete. What I mean is, I type in: '<xsl:value-of s' or <xsl:apply-templates s' and it doesn't complete 'select' for the letter 's'. It did complete 'value-of' from the letter 'v' or the 'apply-templ...
by mphare
Mon May 19, 2008 5:42 pm
Forum: Other Issues
Topic: Defaulted XSLT Processor when using Eclipse
Replies: 6
Views: 3054

Re: Defaulted XSLT Processor when using Eclipse

Doing that I will need a transformation scenario for each XSL file.
It's OK if Eclipse can't do it, I was just asking if it could.

Thanks!
by mphare
Sat May 17, 2008 4:41 am
Forum: Other Issues
Topic: Defaulted XSLT Processor when using Eclipse
Replies: 6
Views: 3054

Re: Defaulted XSLT Processor when using Eclipse

Yes, but I don't want to specify the urls explicitly. I want the behaviour that I get when I choose the XSLT perspective (i.e. an open XSL is selected into the XSL control and an open XML is selected in the XML control.) The only difference is I want the default processor to be the XSLT 2.0 Saxon9B ...
by mphare
Thu May 15, 2008 8:03 pm
Forum: Other Issues
Topic: Defaulted XSLT Processor when using Eclipse
Replies: 6
Views: 3054

Re: Defaulted XSLT Processor when using Eclipse

Thanks, that works.

Now, can I get the XSL file to be selected in the XSL combobos and the XML file to be selected in the XML combobox?

I can get one or the other using $CurrentFileURL, but I cannot get both.
by mphare
Thu May 15, 2008 4:56 pm
Forum: Other Issues
Topic: Defaulted XSLT Processor when using Eclipse
Replies: 6
Views: 3054

Defaulted XSLT Processor when using Eclipse

Until I get my copy of Oxygen 9 (hopefully next week sometime), I'm still using 8.2 I'm using it under Eclipse, mainly because I'm doing some Java and PHP for this project. When I switch to the Oxygen XSLT perspective, the XSLT processor defaults to Saxon6.5.5. But, I'm using XSLT 2.0 so I need Saxo...
by mphare
Fri Apr 25, 2008 5:36 pm
Forum: Other Issues
Topic: Error 500 when accessing a WebDAV url
Replies: 4
Views: 2595

Re: Error 500 when accessing a WebDAV url

mmm... think I got it.
I imported from the web the webdav url into the project.

Now, it didn't copy everything from the web site onto my local harddrive did it?

Thanks,

- m
by mphare
Fri Apr 25, 2008 5:22 pm
Forum: Other Issues
Topic: Error 500 when accessing a WebDAV url
Replies: 4
Views: 2595

Re: Error 500 when accessing a WebDAV url

Thanks, checking the error log showed me I had left out the DAVLockDB directive in the apache config file. Works great now. But now I have question.. can I add a WebDAV directory to the project tree so I can see all the subdirs and files? This is going to be a little difficult to use if I can only b...
by mphare
Fri Apr 25, 2008 6:05 am
Forum: Other Issues
Topic: Error 500 when accessing a WebDAV url
Replies: 4
Views: 2595

Error 500 when accessing a WebDAV url

Hi, I'm still on Oxygen v.8.2, hopefully that will be changing in the next few weeks. I have set up a mod_dav on my Apache 2.2 server (running on Windows XP) and I can access the configured location from a web server. I cannot, however, access it from Oxygen. I get an Error 500 when I put the locati...
by mphare
Wed Apr 23, 2008 6:49 pm
Forum: General XML Questions
Topic: XInclude and Fragement Identifiers
Replies: 1
Views: 2728

XInclude and Fragement Identifiers

Hi, I've been handed a bunch of XML files (a few 100) and they all use XInclude with the href using Fragment Identifiers (href="http://www/TL1/SomeFile.xml#SomeTag) Is there no way to get Fragment Id support in Oxygen? (I'm currently using v.8.2, but I've put in for an uprade to v.9, so I'll have th...
by mphare
Thu Apr 03, 2008 9:17 pm
Forum: Common Problems
Topic: Error Adding Resources to eXist DB
Replies: 2
Views: 1980

Re: Error Adding Resources to eXist DB

I think I've asked this question before..
so please disregard.

Thanks!
by mphare
Thu Apr 03, 2008 7:48 pm
Forum: Common Problems
Topic: Error Adding Resources to eXist DB
Replies: 2
Views: 1980

Error Adding Resources to eXist DB

Hi, Now that I have my Oxygen 8.2 running with my eXist, I'm trying to add files to the DB. When I try to add an XML file I get this error: Error: Could not parse file D:\mphare\NE Documents\NMIS-Exporting\data_orig_28Jan08\data_orig_28Jan08\FLASHWAVE_9500\01-01\tl1_data\fnc\Cmd\ALARM\init-ao_v0.xml...
by mphare
Thu Apr 03, 2008 7:33 pm
Forum: Common Problems
Topic: eXist Database, can't get it to work
Replies: 5
Views: 1866

Re: eXist Database, can't get it to work

So, I uninstalled both versions of Oxygen and eXist, re-installed everything and it's all working now!

Thanks!
by mphare
Thu Apr 03, 2008 5:15 pm
Forum: Common Problems
Topic: eXist Database, can't get it to work
Replies: 5
Views: 1866

Re: eXist Database, can't get it to work

Thanks Sorin, In Options->Preferences->Data Sources:Connections I have one entry named TL1. Editing that entry provides: XML DB URI: xmldb:exist://<my_hostname>:8080/exist/xmlrpc User: tl1user Password: ******** Collections: /db OK, Apply, OK, all produce no Error Messages Now, in the Database Explo...