Search found 22 matches

by John_Tait
Fri Jun 23, 2017 1:15 pm
Forum: DocBook
Topic: Abstract of set not in navigation when set is nested (DocBook)
Replies: 5
Views: 1133

Re: Abstract of set not in navigation when set is nested (DocBook)

Thanks for your reply on the Docbook Apps Users list.
by John_Tait
Thu Jun 22, 2017 12:11 pm
Forum: DocBook
Topic: Abstract of set not in navigation when set is nested (DocBook)
Replies: 5
Views: 1133

Abstract of set not in navigation when set is nested (DocBook)

Hi. I've found a reproducable error when nesting a set in another set (DocBook 5.1, Oxygen 18.0). I thought that it might be caused because the set contained articles (new for DocBook 5.1) but it appears again when the set contains books. I have reproduced both below. This affects chunked HTML and E...
by John_Tait
Wed May 14, 2014 12:50 pm
Forum: DocBook
Topic: Saving parameters in DocBook transformation
Replies: 2
Views: 2522

Re: Saving parameters in DocBook transformation

Great, thanks - just what I was looking for.

John
by John_Tait
Wed May 14, 2014 11:11 am
Forum: DocBook
Topic: Saving parameters in DocBook transformation
Replies: 2
Views: 2522

Saving parameters in DocBook transformation

Hi I have edited project DocBook parameters by selecting one of the defaults (DocBook HTML - Chunk), pressing the "Edit" button, and changing the values of the parameters in the new "DocBook HTML - Chunk - Copy" scenario. I have spent some time tweaking the parameters to get the ...
by John_Tait
Fri Jan 17, 2014 6:33 pm
Forum: DocBook
Topic: Couldn't find hyphenation pattern error
Replies: 5
Views: 4459

Re: Couldn't find hyphenation pattern error

I've managed to reproduce the error. Not all of these might cause the error, but I can't unpick it easily because my cross-referencing goes across the individual files. Anyeay if I have a set (DocBook5 document), and books are included in the set with XInclude, and the title of the books contain an ...
by John_Tait
Mon Jan 13, 2014 3:48 pm
Forum: DocBook
Topic: Couldn't find hyphenation pattern error
Replies: 5
Views: 4459

Re: Couldn't find hyphenation pattern error

I've been commenting out much of the document. I think (one of) the issues is that the index term in the title seems to clause a build error. I can build it when I remove the <indexterm> element. Strange. <?xml version="1.0" encoding="UTF-8"?> <?xml-model href="http://docboo...
by John_Tait
Mon Jan 13, 2014 2:46 pm
Forum: DocBook
Topic: Couldn't find hyphenation pattern error
Replies: 5
Views: 4459

Couldn't find hyphenation pattern error

Hi I'm encountering a build error while building a DocBook PDF. HTML build works fine. I can't figure this one out at all - please help. It's a DocBook5 set constructed with XIncludes. Error log below. Thanks, John The process 'Apache FOP' ended with code: 1. The error was: ERROR - Couldn't find hyp...
by John_Tait
Mon Nov 25, 2013 5:46 pm
Forum: DocBook
Topic: What’s the right link for the job?!?
Replies: 9
Views: 4749

Re: What’s the right link for the job?!?

Thanks. The Master Files works really well - I'm using a "set" as the top level. I can just pick the cross-references from a list. It's "invisible" to me if where the actual xincluded file is. DocBook 5 now appears to work as well as DITA for me for producing modular documentatio...
by John_Tait
Fri Nov 15, 2013 6:36 pm
Forum: DocBook
Topic: What’s the right link for the job?!?
Replies: 9
Views: 4749

Re: What’s the right link for the job?!?

I found the answers really helpful here. The DocBook 5 documentation is excellent, but it covers a number of legacy cases. I had the same problem with choosing how to build modular documents and cross-reference the modules. Using <xref linkend="foo"> with <element xml:id="foo"> a...
by John_Tait
Tue Oct 15, 2013 3:47 pm
Forum: Common Problems
Topic: Oxygen 15.1 doesn't seem to save edited transformation scena
Replies: 2
Views: 870

Oxygen 15.1 doesn't seem to save edited transformation scena

Hi I have edited the transformation scenarios for DocBook to edit the parameters (section numbering, etc.) Even if I save them, edited scenarios don't seem to be available after I shut down and restart Oxygen 15.1. I have tried this with the DITA transformation, and the same thing happens. Do I need...
by John_Tait
Thu Mar 14, 2013 4:35 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Webhelp update problems
Replies: 7
Views: 1686

Re: Webhelp update problems

WOuld it be possible for you to please preview the mobile version. I'm keenly awaiting it.
by John_Tait
Sat Mar 09, 2013 10:47 am
Forum: Other Issues
Topic: Can I compare EPUB files?
Replies: 2
Views: 1518

Re: Can I compare EPUB files?

Thanks
by John_Tait
Fri Mar 08, 2013 12:52 pm
Forum: Other Issues
Topic: Can I compare EPUB files?
Replies: 2
Views: 1518

Can I compare EPUB files?

Oxygen Author can view EPUB files without editing them, and Diff Files is a great utility, but I can't seem to compare EPUB files. I know I can unzip them, but is there a direct way to compare different versions of the same EPUB file?

John
by John_Tait
Thu Feb 07, 2013 6:29 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Webhelp general question
Replies: 6
Views: 2104

Re: Webhelp general question

Okay, thanks. I still think that some kind of dynamic rendering would be very useful, especially for technical authors like me who aren't equipped to develop databases, but I do get the point that a client-server model is more appropriate for handling queries. Many thanks and good luck for XMLPrague...
by John_Tait
Thu Feb 07, 2013 4:42 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Webhelp general question
Replies: 6
Views: 2104

Re: Webhelp general question

Thanks for your prompt reply. I don't work in computer documentation (or use DITA at work at all). What I'm thinking about is a simple general case that could be applied to any kind of online content. Please see a toy database on my website (which I use for self-teaching about DITA): http://www.john...
by John_Tait
Thu Feb 07, 2013 3:09 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Webhelp general question
Replies: 6
Views: 2104

Webhelp general question

Could you briefly please let us know of any improvements and additions to DITA Webhelp in the upcoming 14.2, and beyond? I think Webhelp output is a real asset in the oXygen products, as it positions oXygen as a real end-to-end solution. I hope that it can continue to be developed. I'd really like t...
by John_Tait
Mon Jan 28, 2013 2:29 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Conditional processing of topic in map with specialised props attribute
Replies: 4
Views: 1692

Re: Conditional processing of topic in map with specialised props attribute

Just tried it, by copying across my small customisations from the topic.dtd file into the map.dtd file.

Works perfectly - thanks!

John
by John_Tait
Mon Jan 28, 2013 12:51 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Conditional processing of topic in map with specialised props attribute
Replies: 4
Views: 1692

Conditional processing of topic in map with specialised props attribute

Hi I've been able to apply specialised conditional processing to elements (e.g. <p> elements) within a topic. When I apply the conditional processing attribute to a topicref (to knock out the whole topic), I get an error. Here's my map <?xml version="1.0" encoding="UTF-8"?> <!DOC...
by John_Tait
Tue Jan 22, 2013 3:40 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Subject scheme map: Inc;lude/exclude works, flag doesn't
Replies: 3
Views: 1292

Re: Subject scheme map: Include/exclude works, flag doesn't

Ah, great, thank-you. I have removed the chunk attribute and it behaves as expected.

Thank-you for reporting the bug and many thanks for your quick and highly professional reply.

John
by John_Tait
Tue Jan 22, 2013 12:04 pm
Forum: DITA (Editing and Publishing DITA Content)
Topic: Subject scheme map: Inc;lude/exclude works, flag doesn't
Replies: 3
Views: 1292

Subject scheme map: Inc;lude/exclude works, flag doesn't

Hi I'm using 14.1. I can't explain the following behaviour. Is it a bug, or am I doing something wrong? When I use a subject scheme map to exclude content, it works. When I use the same subject scheme map to flag content, it doesn't. Here is my map: <?xml version="1.0" encoding="UTF-8...

Go to advanced search