Search found 6 matches

by dmccreary
Sat Jan 23, 2010 7:56 pm
Forum: Common Problems
Topic: "Open URL" and "Save to URL" dialog forgets recent servers
Replies: 3
Views: 1275

Re: "Open URL" and "Save to URL" dialog forgets recent servers

I have also found this problem takes me a lot of time to reenter each of the servers. It would be VERY nice if all the database connections would appear in a drop-down list!

Thanks for considering the fix.
by dmccreary
Tue Mar 27, 2007 5:13 pm
Forum: Common Problems
Topic: Problems calling DB2 stored procedures
Replies: 3
Views: 6447

Hello Stefan, Thank you again for your quick reply. I tried taking out the semicolon and I added both one and five parameters (not sure how many I need) but I could not get the query to run. In this example, the values of the parameters are in the document itself so I am note sure why I need to spec...
by dmccreary
Mon Mar 26, 2007 6:34 pm
Forum: Common Problems
Topic: Problems calling DB2 stored procedures
Replies: 3
Views: 6447

Problems calling DB2 stored procedures

From page 124 of the DB2 9 pureXML Guide the following stored procedure uses question marks to pass parameters: CALL DB2XMLFUNCTIONS.XMLUPDATE( '<updates> <update action="append" col="1" path="/Customer"> <Email>newEmail@yahoo.com</Email> </update> </updates>', 'select doc from xps where id=1', 'upd...
by dmccreary
Fri Mar 23, 2007 5:44 pm
Forum: Common Problems
Topic: Error Messages from DB2 XQuery
Replies: 1
Views: 3054

Error Messages from DB2 XQuery

Hi, oXygen is working great for editing eXist and DB2 XQueries. One problem I am having with DB2 is getting readable error messages back to the Eclipse Error panel of oXygen. Here is a simple XQuery with a missing semicolon in the let statement. (it should be let foo := 'bar' let $foo = 'bar' return...
by dmccreary
Fri Mar 16, 2007 4:49 pm
Forum: Common Problems
Topic: "Null source reader" error with eXist XQuery
Replies: 4
Views: 3650

Can not execute XQueries with eXist

Hi, Thanks for the response. We have tried to analyze the problem on our end. We are now finding that the error is not specific to this XQuery file but common to other XQueries. Can you tell me how to enable logging? I searched all the Windows/Preferences options for oXygen and did not find any chec...
by dmccreary
Thu Mar 15, 2007 7:44 pm
Forum: Common Problems
Topic: "Null source reader" error with eXist XQuery
Replies: 4
Views: 3650

"Null source reader" error with eXist XQuery

I am getting a "Null source reader" when I try to execute an XQuery using eXist. This appears to be specific to one XQuery file. Others seem to work. The XQuery runs without any error when I used the eXist admin interface to execute the script. Here is the script that generates the error: xquery ver...