Search found 11 matches

by Nicol Bolas
Sat Nov 24, 2007 5:35 am
Forum: Common Problems
Topic: Document Type Association shortcut Bug
Replies: 5
Views: 2941

I'm using the standalone Oxygen. And putting the action in the menu bar fixed it.

Why is that necessary for the standalone Oxygen?
by Nicol Bolas
Thu Nov 22, 2007 1:26 am
Forum: Common Problems
Topic: Document Type Association shortcut Bug
Replies: 5
Views: 2941

BTW, I tried restarting Oxygen, but that didn't help.
by Nicol Bolas
Thu Nov 22, 2007 1:24 am
Forum: Common Problems
Topic: Document Type Association shortcut Bug
Replies: 5
Views: 2941

Document Type Association shortcut Bug

I'm having a problem making additions to this work correctly. I duplicated the DocBook 5 version, so that I could modify it. I added a new Action to the list of actions in Author mode, and I gave it a shortcut key of "Ctrl+Shift+G". I checked to see that this shortcut was not in use either elsewhere...
by Nicol Bolas
Thu May 03, 2007 2:15 am
Forum: Other Issues
Topic: XML Catalog not working?
Replies: 9
Views: 6804

It almost works now. Or to be fair, the example I posted works, but I then realized that a slightly more complex yet still important example fails. One where this line comes after the RNGSchema include: <?oxygen SCHSchema="http://docbook.org/xml/5.0CR3/rng/docbookxi.rng"?> Thus allowing validation w...
by Nicol Bolas
Tue May 01, 2007 1:17 am
Forum: Other Issues
Topic: XML Catalog not working?
Replies: 9
Views: 6804

oXygen uses system mappings to solve schema locations and you have only uri mappings in the catalog. As mentioned in my initial post, I didn't write this catalog; it's the one that came with the DocBook 5 download. Presumably, they think it is a valid catalog. Is there some specific reasoning for t...
by Nicol Bolas
Mon Apr 30, 2007 9:25 pm
Forum: Other Issues
Topic: XML Catalog not working?
Replies: 9
Views: 6804

Alright: <catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog" prefer="public"> <!-- ............................................................ --> <!-- XML Catalog for DocBook .................................... --> <!-- File catalog.xml ........................................... --> <!-...
by Nicol Bolas
Mon Apr 30, 2007 8:31 pm
Forum: Other Issues
Topic: XML Catalog not working?
Replies: 9
Views: 6804

If it does not work on your computer please post a small sample document. OK: <?xml version="1.0" encoding="UTF-8"?> <?oxygen RNGSchema="http://docbook.org/xml/5.0CR3/rng/docbookxi.rng" type="xml"?> <book xmlns="http://docbook.org/ns/docbook" version="5.0cr3"> <title>Book Title</title> <chapter> <t...
by Nicol Bolas
Fri Apr 27, 2007 10:48 pm
Forum: Other Issues
Topic: XML Catalog not working?
Replies: 9
Views: 6804

XML Catalog not working?

I was using Oxygen on what became a standalone machine (we lost Internet access for a period of time), and something very peculiar happened. I was unable to validate any of my documents. Nor could I get content completion to work. Now, the schema's they were using (DocBook 5 CR3) were assigned with ...
by Nicol Bolas
Sat Mar 03, 2007 8:56 am
Forum: Other Issues
Topic: DocBook 5 RNG Performance
Replies: 2
Views: 4389

DocBook 5 RNG Performance

I've noticed some performance issues with regard to using the RelaxNG DocBook 5 schema, and they seem unusual. I know the DocBook 5 RNG schema is fairly large, so having some initial slowdown is expected. But what I'm getting is rather unexpected. Anytime I open up a DocBook 5 document, Oxygen freez...
by Nicol Bolas
Thu Dec 14, 2006 11:10 am
Forum: Common Problems
Topic: Oxygen 8 keeps using Internet Explorer
Replies: 4
Views: 3776

That worked... kinda. It's not using IE, but the other problems remain. Oxygen 7.x used the Windows-defined file associations (probably via a "start" command-line command) for opening the file. That's the behavior that I want back, if for no other reason than the fact that it's silly to open a PDF i...
by Nicol Bolas
Sun Dec 10, 2006 9:34 pm
Forum: Common Problems
Topic: Oxygen 8 keeps using Internet Explorer
Replies: 4
Views: 3776

Oxygen 8 keeps using Internet Explorer

Whenever I perform a transformation scenario that says "Open in browser", Oxygen 8 uses IE, when my default browser is Firefox. Even worse, this still happens when I use a conversion to PDF, so my computer gets strange when Internet Explorer tries to open a PDF. This all was working fine in Oxygen 7...