Search found 8 matches

by ivan603
Tue Feb 07, 2006 8:44 am
Forum: XSLT and FOP
Topic: Displaying Base64Binary Problem
Replies: 1
Views: 2850

Displaying Base64Binary Problem

Hi all, i encountered a problem on displaying node value which is in Base64Binary data type when send it to XSL page. The node value is showing belows: <MessageTest xmlns:dt="urn:schemas-microsoft-com:datatypes" dt:dt="bin.base64">VABlAHMAdABpAG4AZwA=</MessageTest> The original value before convert ...
by ivan603
Fri Jan 27, 2006 12:02 pm
Forum: General XML Questions
Topic: Cannot Get Whitespace Characters
Replies: 0
Views: 7495

Cannot Get Whitespace Characters

I have a problem to get the content's characters using DOM object in VB. Belows are my coding: Dim objDOM As New DOMDocument40 Dim nodeOne As IXMLDOMElement objDOM.preserveWhiteSpace = True Set nodeOne = objDOM.createNode("element", "TestNode", "") nodeOne.nodeTypedValue = Chr(13) & Chr(10) & Chr(32...
by ivan603
Tue Nov 15, 2005 7:01 am
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

Hi george,

Is your output is in Bold and Red color?

Hello, every body -> should be displayed in Bold text

This is testing message -> should be displayed in Red color

The expected output should not contains the start tag and end tag of <Bold> and <Font>

Thank you. :wink:
by ivan603
Tue Nov 15, 2005 7:00 am
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

Hi george,



Is your output is in Bold and Red color?

Hello, every body -> should be displayed in Bold text

This is testing message -> should be displayed in Red color

The expected output should not contains the start tag and end tag of <Bold> and <Font>

Thank you. :wink:
by ivan603
Sat Nov 12, 2005 3:45 am
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

Hi georg, i use <xsl:copy-of select="./node()"/> but the output still same. Below is my html code in XSL: <Table> <TR> <TD> <Span> <xsl:attribute name="class">msgContent</xsl:attribute> <xsl:apply-templates select=".//MessageContent"/> </Span> </TD> </TR> </Table> <xsl:template match="MessageContent...
by ivan603
Fri Nov 11, 2005 10:01 am
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

Hi george, thanks for your suggestion. I use <xsl:apply-templates select=".//MessageContent"/> <xsl:template match="MessageContent"> <pre> <xsl:value-of select="."/> </pre> </xsl:template> the result contains the carriage return character. But how do i apply the disable-output-escaping in this case?...
by ivan603
Thu Nov 10, 2005 5:52 am
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

Hi sorin, thank u for your help. But my knowledge in XSL is quite limited. Can you explain how to get the string in XSL? Actually my XSl already contains <xsl:output method="html" version="4.0"/>, when i add <xsl:output cdata-section-elements="a" method="xml"/>, a problem occured. Is it using <![CDa...
by ivan603
Wed Nov 09, 2005 12:47 pm
Forum: XSLT and FOP
Topic: XSL Displaying Problem
Replies: 9
Views: 5856

XSL Displaying Problem

Hi all, i have a problem in XSL. Actually i have a xml string that contain some XML nodes. I define one of the node as Base64Binary data type. I use <xsl:value-ofselect='nodeName'> in xsl to get the value, but the problem i found is it returned the encoded string to me, not the original string. Can ...