Edit online

Translator Helper Add-on

Oxygen XML Author offers an add-on that provides support for helping translators. Once the add-on is installed, you can use Google Translate to create a preliminary translation for your XML content that can later be manually improved. The add-on is also useful for showing potential customers how a DITA project will look like after it is translated into their native language.

To install the add-on, follow these instructions:

  1. Go to Help > Install new add-ons to open an add-on selection dialog box.
  2. Enter or paste http://www.oxygenxml.com/InstData/Addons/default/updateSite.xml in the Show add-ons from field.
  3. Select the Translator Helper add-on and click Next.
  4. Read the end-user license agreement. Then select the I accept all terms of the end-user license agreement option and click Finish.
  5. Restart Oxygen XML Author.

Features:

  • You can translate content to various languages using Google Translate:
    1. In Oxygen XML Author, select the content you want to translate in Author mode. You can also select the entire contents of the document.
    2. Right-click, select Google Translate Into, and choose the target language.
    3. Copy the translated content from the resulting web page (the easiest way to do this is to use the Copy translation button).
    4. Go back to Oxygen XML Author. If your original selection included multiple inline elements (or entire block elements or the entire document), a dialog box will be displayed. Click the Replace button to replace the selection with the copied translated content. If you leave the Show original content side-by-side option selected, the original untranslated content will be displayed in the Translator Helper side view.
  • You can choose to display your original content in a Translator Helper side view so that you can see the original untranslated content side-by-side with the content that you are editing/translating. To open this side view, right-click anywhere in the Author mode editor pane and select the Original Content Side By Side action (or select Window > Show View > Translator Helper).