Edit online

The Oxygen team is dedicated to developing software products that are usable for everyone, including those with physical challenges and disabilities. Oxygen XML Editor is designed to adhere to the U.S. Government Section 508 accessibility standards: https://www.oxygenxml.com/xml_editor/section508.html.

Adjusting Fonts and Colors

If you have low vision, go to Options > Preferences > Appearance > Fonts where you can adjust the font styles and sizes used in the entire application, both for the editing areas and UI labels. If you have color blindness, you can also adjust most of the colors used in Oxygen XML Editor by going to Options > Preferences > Appearance and changing the current color theme. You can also search for other color-related settings in the Preferences dialog box.

Installing Oxygen XML Editor

Installation kits for Windows and Linux are made using the Install4j product. If you have problems navigating the Install4j installation wizard, you can run the installation from a command-prompt application using the -c flag like this:
C:\Users\your_user_name\Downloads\oxygenAuthor-64bit.exe -c

Screen Reader Software

If you are using a text to speech narrator, Oxygen XML Editor supports this since it is a Java application and it is periodically tested on Windows using both the NVDA and JAWS screen readers.

Using the JAWS (Job Access With Speech) Screen Reader with Oxygen XML Editor

The JAWS screen reader can be downloaded from: http://www.freedomscientific.com/Products/Blindness/JAWS.

For JAWS to work, you need to enable the Java access bridge in Oxygen XML Editor: http://docs.oracle.com/javase/7/docs/technotes/guides/access/enable_and_test.html.

To enable the Java access bridge:
  1. Since Oxygen XML Editor comes bundled with its own Java VM, you need to open a command-prompt application and use the cd command to go to the Oxygen XML Editor installation directory (for example, in Windows, it would be something like this:
    cd C:\Program Files\Oxygen XML Editor 21.1
  2. Then run the following command:
    jre\bin\jabswitch -enable
  3. Press Enter and you should receive a notification that the access bridge has been enabled.

Once the Java access bridge is enabled and as long as the JAWS narrator is active, when Oxygen XML Editor starts, the narrator will start reading content from Oxygen XML Editor and you can interact with the application and read menus, content from open XML documents, and UI components from dialog boxes and side views.

Using the NVDA Screen Reader with Oxygen XML Editor

The NVDA screen reader can be downloaded for free from: https://www.nvaccess.org/.

For NVDA to work, you need to enable the Java access bridge in Oxygen XML Editor: http://docs.oracle.com/javase/7/docs/technotes/guides/access/enable_and_test.html.

To enable the Java access bridge:
  1. Since Oxygen XML Editor comes bundled with its own Java VM, you need to open a command-prompt application and use the cd command to go to the Oxygen XML Editor installation directory (for example, in Windows, it would be something like this:
    cd C:\Program Files\Oxygen XML Editor 21.1
  2. Then run the following command:
    jre\bin\jabswitch -enable
  3. Press Enter and you should receive a notification that the access bridge has been enabled.
Once the Java access bridge is enabled and as long as the NVDA narrator is started, when Oxygen XML Editor starts, the narrator will start reading content from Oxygen XML Editor and you can interact with the application and read menus, content from open XML documents, and UI components from dialog boxes and side views.
Important: If after these steps the narrator still does not read anything from a started Oxygen XML Editor application, please go to the folder C:\Windows\SysWOW64\ and make sure the library WindowsAccessBridge-32.dll is present there. If it is not present, try to search online, download the library file and copy it to the folder. Then restart Oxygen XML Editor.
Tip: Besides the main editing area, Oxygen XML Editor also has side views (for example, the Attributes, Outline, Elements views) that help with editing the XML content. NVDA has a registered bug that makes the narrator read content from the side views when editing in the main editing area. Because of this, the following workflow is suggested:
  1. Start Oxygen XML Editor.
  2. Go to the Window menu and select Maximize Editing Area (hold Alt, then W, then M). This action will hide all side views and allow you to properly edit in the main editing area.
  3. Whenever you want to open a side view, go to Window > Show View (hold Alt, then W, then S) and choose the view you want to open. For example, to show the Elements view, you can use the shortcut hold Alt, then W, then S, then E.
  4. When you are done using the side view, go to the Window menu and select Hide current view (hold Alt, then W, then H) to hide the side view and return the focus to the main editing area.

Hints for the Visually Impaired

Here are a few hints for using Oxygen XML Editor if you are visually impaired:
  • The top main menu contains actions to open, save, and close documents, switch between open documents, or switch between the various editing modes for XML documents that are already open. All actions in the main menu bar should have mnemonics making it possible to memorize various shortcuts. For example, using the alt-w-s-e shortcut should open the Window menu, open the Show view submenu from it and show the Elements view,
    • The File menu contains actions to open, save, or close the currently edited XML document.
    • The Edit menu contains actions to undo/redo or cut/copy/paste content. They also have the usual shortcuts that can be used instead of directly invoking the actions from the menu.
    • The Find menu contains an action to show the Find/Replace dialog box. Sometimes the JAWS narrator overloads the CTRL+F shortcut and presents its own find/replace window but the Oxygen XML Editor Find/Replace dialog box provides the ability to perform complex find/replace operations in the open file.
    • In the Options menu, you have access to the Preferences dialog box that contains global application settings and access to the Menu Shortcut Keys table where you can configure shortcuts for the most commonly used actions.
    • The Window menu includes actions to switch between open XML documents. Also, you can use the Show view submenu to open a particular side view and move the focus to that view.
  • An open XML document can be edited with accessibility support either in the Text editing mode (where the XML tags are accessible in the edited content) or in the visual Author editing mode (where the XML tags are hidden and only the text content is shown). You can switch between these editing modes by using the Document > Edit Mode menu.
    • Text mode provides access to the entire source document with all of its XML content, just like you have in any text editing application.

      Pressing the < key will present a list of available XML elements. If you do not want to choose from the list whenever you want to insert an XML element, you have two choices:
      • After the list of available XML elements is shown, you can press the ESC key to close it and continue to manually insert the XML tag.
      • You can disable the content completion list from the Options > Preferences > Editor / Content Completion page by deselecting Enable Content Completion. After the content completion is disabled, you can force it to be displayed by using the Ctrl+Space keyboard shortcut.

      In addition, using the Window > Show view submenu, you can change focus to the Attributes, Elements, or Outline view. The Attributes view presents the existing and possible attributes that can be inserted in an XML tag. The Elements view shows you the list of XML elements that can be inserted at the cursor position (also, pressing F2 on a selected element presents its annotation). The Outline view shows the current path in the XML structure.

    • Author mode is useful for reviewing written XML content because it has support for change tracking and for adding comments. Editing in the Author visual editing mode, you have access to only the text content in the XML document.

      Pressing Shift+F2 will read the current element context where the cursor is located. Pressing Ctrl+Shift+F3 will read the current element context and the entire path in the XML structure where the cursor is located. You can also use Outline view to better understand the XML structure.

      In the Author editing mode, you can also use the Attributes and Elements views similar to using them in the Text editing mode. Pressing Enter in the Author visual editing mode can also be used to present a list of allowed elements at the current position.