Edit online

The global options cover various aspects of the overall operation of Oxygen XML Editor. To configure the Global options, open the Preferences dialog box (Options > Preferences) and go to Global.

The following options are available in the Global preferences page:
Automatic Version Checking
If this option is selected, Oxygen XML Editor will check for a new version on startup.
Check for Oxygen-related events at startup
If this option is selected, Oxygen XML Editor will check for various new event updates on the Oxygen XML Editor website and if any new events are found, they will be presented at startup.
Check for notifications
If selected (default value), the application will check for various types of messages from the Oxygen XML Editor website and they will be displayed in the status bar. The types of messages include the addition of new videos on the website, the announcement of upcoming webinars and conferences where the Oxygen XML Editor team will participate, and more.
Language
This option specifies the language used in the user interface. You can choose between English, French, German, Dutch, Japanese, or Chinese. You must restart Oxygen XML Editor for the change to take effect.
Other language
This option sets the language used in the user interface using an interface localization file. For details about creating this file, see Localizing the User Interface. You can use this option to set the language of the user interface to a language that is not shipped with Oxygen XML Editor.
Note: If some interface labels are not rendered correctly after restarting the application, (for example, Korean characters are not displayed correctly), make sure that your operating system has the appropriate language pack installed (for example, the East-Asian language pack).
Line separator
This option specifies the type of line separator to be used when saving files. Use System Default to select the normal line separator for your OS. The other two possible selections are Unix-like and Windows-like.
Notes:
  • This option is ignored if the Detect the line separator on file open option is selected AND a line separator is automatically detected.
  • When changing the selection in this option, the change does not affect an opened file until you make a modification to the file and save it. At that point, all line separators in the file will change to the type of line separator you chose in this option.
Detect the line separator on file open
When this option is selected, the editor detects the line separator when a file is loaded and it uses it when the file is saved. If this option is not selected, you can use the Line separator option to choose the type of line separator to be used when saving files.
Tip: To see the line separator type for the current file, you can use the Properties view (Window > Show View > Properties).
Default Internet browser
This option sets the Web browser that Oxygen XML Editor will use to do the following:
  • Open (X)HTML or PDF transformation results.
  • Open a web page.

If you leave this setting blank, the system default browser will be used.

Open last edited files from project
When this option is selected, Oxygen XML Editor opens the files you had open the last time you used a project whenever you open the application or switch to that project.
Check opened files for file system changes

When this option is selected, Oxygen XML Editor checks the content of the all open editors to see if they have been updated by another application. If the file has changed, Oxygen XML Editor will ask you if you want to reload the file.

Auto update unmodified editors on file system changes
If this option is selected, Oxygen XML Editor automatically updates unmodified editors if the edited file changes externally.
Beep on operation finished
When this option is selected, Oxygen XML Editor beeps when a validation or transform action ends. Different tones are used for success and failure. The tones used may depend on the sound settings in your operating system.
Show memory status
When this option is selected, the memoryOxygen XML Editor uses is displayed in the status bar. To free memory, click the Free unused memory button located at the right side of the status bar. The memory status bar turns yellow or red when Oxygen XML Editor uses too much memory. You can change the amount of memory available to Oxygen XML Editor by changing the parameters of the application launcher.
Order of switching between editor tabs
This option specifies the order for switching between open file tabs when using Ctrl + Tab (Command + Tab on OS X) or Ctrl + Shift + Tab (Command + Shift + Tab on OS X). You can choose between:
  • Recently used order - Switches to the most recently used tab.
  • Visual order - Switches to the next tab in visual order.
File Chooser Dialog section
Use platform file chooser (Windows and Mac OS X)

This option is selected by default and it specifies that the native file chooser is used. You can deselect this option if you want the Java Swing file chooser to be used instead. If Oxygen XML Editor encounters a problem while using the native file manager, it will avoid using it again in the current session, even if this option is selected.

Consider application bundles to be directories when browsing (Mac OS X only)
This option is available only on the Mac OS X platform. When selected, the file browser dialog box allows you to browse inside an application bundle, as in a regular folder. Otherwise, it is not allowed (the same as the Finder application on Mac OS X).
Note: The same effect can be obtained by setting the apple.awt.use-file-dialog-packages property to true or false in the Info.plist descriptor file of the Oxygen XML Editor application:
<key>apple.awt.use-file-dialog-packages</key>
<string>false</string>
Show hidden files and directories
If this option is selected, Oxygen XML Editor shows system hidden files and folders in the file browser dialog box and the folder browser dialog box.
Tip: On Mac OS X, you need to press Command + Shift + Period in the file browser to show hidden files.
File chooser opens
This option specifies the starting directory that the file browser dialog box will open. You can choose between:
  • Directory of the selected file - The file browser opens the folder where the selected file is stored, depending on the current selection (for example, a file could be selected from the Project view, DITA Maps Manager, main editing pane, or another location within the application).
  • Last visited directory - The file browser opens the last visited folder.