Edit online

The DITA perspective provides an editing environment with default side-views and other interface components that are optimal for working with DITA projects. To switch the focus to this perspective, select the DITA button in the top-right corner of Oxygen XML Author or select DITA from the Window > Open perspective menu. If you open a DITA resource from the DITA Maps Manager while in another perspective, a message will appear asking if you want to switch to the DITA perspective.

The layout of this perspective is composed of the following components:
Menus
Most of the menus are common for all types of documents, but this perspective also include DITA-specific actions in the DITA Maps and DITA menus.
Toolbars
Many of the toolbar buttons are common for all types of documents, but Author mode also includes DITA-specific toolbar actions. The toolbars can be configured to suit your specific needs.
Editor Pane
The main editing pane where you spend most of your time reading, editing, applying markup, and validating your documents.
Views

Oxygen XML Author includes a large variety of dockable views to assist you with editing, viewing, searching, validating, transforming, and organizing your documents. By default, this perspective displays the most commonly used views for DITA users and you can choose to display others by selecting them from the Window > Show View menu. The layout of the views can also be configured according to your preferences.

Some of the most helpful views in the DITA perspective include the following:
  • DITA Maps Manager view - This view helps you organize, manage, and edit DITA maps.
  • DITA Reusable Components view - This view is helpful if you use a large amount of keys or reusable components in your DITA project. It collects all of the keys and reusable components that are defined in the root map and presents them in several tabs. It includes various features to make it easy to locate and insert references to the reusable content.
  • DITA Resource Hierarchy/Dependencies view - This view displays the hierarchy or dependencies for resources that are directly referenced in the DITA topic.
  • Project view - Enables the definition of projects and logical management of the documents they contain.
  • Open/Find Resource view - Designed to offer advanced search capabilities in various scopes.
  • Outline view - It provides an XML tag overview and offers a variety of functions, such as modifications follow-up, document structure change, document tag selection, and elements filtering.
  • Results view - Displays the messages generated as a result of user actions such as validations, transformation scenarios, spell checking in multiple files, search operations, and others. Each message is a link to the location related to the event that triggered the message.
  • Attributes view - Presents all possible attributes of the current element and allows you to edit attribute values. You can also use this view to insert attributes in Text mode. Author mode also includes an in-place attribute editor.
  • Elements view - Presents a list of all defined elements that you can insert at the current cursor position according to the document's schema. In Author mode, this view includes tabs that present additional information relative to the cursor location.