Edit online

By default, Oxygen XML Editor contains built-in data source drivers for SharePoint. Use this data source to create a connection to a SharePoint server that will be available in the Data Source Explorer view.

To configure a SharePoint connection, follow these steps:

  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. In the Connections panel click the New button.
  3. Enter a unique name for the connection.
  4. Select SharePoint in the Data Source combo box.
  5. Fill-in the connection details:
    1. Set the URL to the SharePoint repository in the field SharePoint URL.
    2. Set the server domain in the Domain field. If you are using a SharePoint 365 account, leave this field empty.
    3. Set the user name to access the SharePoint repository in the User field.
    4. Set the password to access the SharePoint repository in the Password field.
  6. To view your connection, go to the SharePoint Browser view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu).
    For more information about connecting to repository located on a SharePoint server, watch our video demonstration: