Edit online

Available in the Enterprise edition only.
Note: Oxygen XML Editor supports MarkLogic version 4.0 or later.

To configure a connection to a MarkLogic database, follow these steps:

  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Connections panel.
  3. Enter a unique name for the connection.
  4. Select a previously configured MarkLogic data source from the Data Source drop-down menu.
  5. Enter the connection details.
    1. The host name or IP address of the installed MarkLogic engine in the XDBC Host field.
      Oxygen XML Editor uses XCC connector to interact with MarkLogic XDBC server and requires the basic authentication schema to be set. Starting with version MarkLogic 4.0 the default authentication method when you create an HTTP or WebDAV Server is digest, so make sure to change it to basic.
    2. Set the port number of the MarkLogic engine in the Port field. A MarkLogic XDBC application server must be configured on the server on this port. This XDBC server will be used to process XQuery expressions against the server. Later, if you want to change the XDBC server, instead of editing the configuration just use the Use it to execute queries action from Data Source Explorer.
    3. Set the user name to access the MarkLogic engine in the User field.
    4. Set the password to access the MarkLogic engine in the Password field.
    5. Optionally, in the WebDAV URL field, set the URL used for browsing the MarkLogic database in the Data Source Explorer view.
      The Database field specifies the database for which the XQuery expressions are executed. If you set this option to default, the database associated to the application server of the configured port is used.
  6. Click the OK button to finish the connection configuration.
  7. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.