Edit online

Starting with version 17, Oxygen XML Editor comes bundled with Java 8, which does not provide built-in access to JDBC-ODBC data sources. To access such sources, you need to find an alternative JDBC-ODBC bridge or use a platform-independent distribution of Oxygen XML Editor along with a Java VM version 7 or 6.

To configure a connection to an ODBC data source, follow these steps:

  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Connections panel.

    The dialog box for configuring a database connection is displayed.

    Figure 1: Connection Configuration Dialog Box

  3. Enter a unique name for the connection.
  4. Select JDBC-ODBC Bridge in the Data Source drop-down list.
  5. Enter the connection details.
    1. Enter the URL of the ODBC source.
    2. Enter the user name of the ODBC source.
    3. Enter the password of the ODBC source.
  6. Click the OK button to finish the connection configuration.
  7. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.