Edit online

To configure a connection to a generic JDBC database, follow these steps:

  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Connections panel.
  3. Enter a unique name for the connection.
  4. Select the Generic JDBC data source in the Data Source drop-down menu.
  5. Enter the connection details.
    1. Enter the URL of the generic JDBC database, with the following format:jdbc: <subprotocol>: <subname>.
    2. Enter the user name for the connection to the generic JDBC database.
    3. Enter the password for the connection to the generic JDBC database.
  6. Click the OK button to finish the connection configuration.
  7. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.