Edit online

Attention: For this manual procedure, you need to already have an eXist database server installed.
Tip: There is an easier way to configure an eXist database connection using a built-in wizard. For more information, see How to Configure an eXist Connection Using the Built-in Wizard.

Step 1: Configure eXist Data Source Drivers

Oxygen XML Editor supports eXist database server versions up to and including version 4.5. To configure a data source for an eXist database, follow these steps:
  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Data Sources panel.
  3. Enter a unique name for the data source.
  4. Select eXist from the driver Type drop-down menu.
  5. Click the Add Files button to add the eXist driver files. The following driver files should be added and they are found in the installation directory of the eXist database server. Make sure you copy the files from the installation of the eXist server where you want to connect from Oxygen XML Editor.
    • The exist.jar file located in the base directory.
    • All JAR files in the lib/core/ directory.
  6. Click the OK button to finish the data source configuration.

Step 2: Configure an eXist Connection

To configure a connection to an eXist database, follow these steps:
  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Connections panel.
  3. Enter a unique name for the connection.
  4. Select a previously configured eXist data source from the Data Source drop-down menu.
  5. Enter the connection details:
    1. Set the URI to the installed eXist engine in the XML DB URI field.
    2. Set the user name in the User field.
    3. Set the password in the Password field.
    4. Enter the start collection in the Collection field.

      eXist organizes all documents in hierarchical collections. Collections are like directories. They are used to group related documents together. This text field allows the user to set the default collection name.

  6. Click the OK button to finish the connection configuration.
  7. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.

For more information about running XQuery against an eXist XML database, watch our video demonstration: