Edit online

Oxygen XML Editor supports Berkeley DB XML versions 2.3.10, 2.4.13, 2.4.16 & 2.5.16. To configure a connection to a Berkeley DB XML database, follow these steps:

  1. Open the Preferences dialog box (Options > Preferences) and go to Data Sources.
  2. Click the New button in the Connections panel.
  3. Enter a unique name for the connection.
  4. Select a previously configured Berkeley data source from the Data Source drop-down menu.
  5. Enter the connection details.
    1. Set the path to the Berkeley DB XML database directory in the Environment home directory field. Use a directory with write access. DO NOT use the installation directory where Berkeley DB XML is installed if you do not have write access to that directory.
    2. Select the Verbosity level: DEBUG, INFO, WARNING, or ERROR.
    3. Optionally, you can select the Join existing environment checkbox.
      If selected, an attempt is made to join an existing environment in the specified home directory and all the original environment settings are preserved. If that fails, try reconfiguring the connection with this option unchecked.
  6. Click the OK button to finish the connection configuration.
  7. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.