Edit online

The Oxygen team is dedicated to developing software products that are usable for everyone, including those with physical challenges and disabilities. Oxygen XML Editor was designed to adhere to the U.S. Government Section 508 accessibility standards: https://www.oxygenxml.com/xml_editor/section508.html

Adjusting Fonts and Colors

If you have low vision, go to Options > Preferences > Appearance > Fonts where you can adjust the font styles and sizes used in the entire application, both for the editing areas and UI labels. If you have color blindness, you can also adjust most of the colors used in Oxygen XML Editor by going to Options > Preferences > Appearance and changing the current color theme. You can also search for other color-related setting in the Preferences dialog box.

Text to Speech Narrators (JAWS)

If you are using a text to speech narrator, Oxygen XML Editor support this since it is a Java application and it is periodically tested on Windows using the JAWS screen reader: http://www.freedomscientific.com/Products/Blindness/JAWS.

For JAWS to work, you need to enable the Java access bridge in Oxygen XML Editor: http://docs.oracle.com/javase/7/docs/technotes/guides/access/enable_and_test.html

Since Oxygen XML Editor comes bundled with its own Java VM, you need to open a console in the jre folder bundled with Oxygen XML Editor and run the following command:

D:\PATH\TO\OXYGEN_INSTALLATION_FOLDER\jre>bin\jabswitch -enable

You will receive a notification in the console that the access bridge has been enabled.

Once the Java access bridge is enabled and if the JAWS narrator is active, when Oxygen XML Editor starts, the narrator will start reading content from Oxygen XML Editor and you can interact with the application, read menus, content from opened XML documents, and UI components from dialog boxes and side views.

Hints for the Visually Impaired

Here are a few hints for using Oxygen XML Editor if you are visually impaired:
  • The top main menu should contain most of the actions that you need to open, save, and close documents, switch between opened documents, or switch between the various editing modes for XML documents that are already opened.
    • The File menu contains actions to open, save, or close the currently edited XML document.
    • The Edit menu contains actions to undo/redo or cut/copy/paste content. They also have the usual shortcuts that can be used instead of directly invoking the actions from the menu.
    • The Find menu contains an action to show the Find/Replace dialog box. Sometimes the JAWS narrator overloads the CTRL-F shortcut and presents its own find/replace window but the Oxygen XML Editor Find/Replace dialog box provides the ability to perform complex find/replace operations in the opened file.
    • In the Options menu, you have access to the Preferences dialog box that contains global application settings and access to the Menu Shortcut Keys table where you can configure shortcuts for the most commonly used actions.
    • The Window menu includes actions to switch between opened XML documents. Also, you can use the Show view submenu open a particular side view and move the focus to that view.
  • An opened XML document can be edited with accessibility support either in the Text editing mode (where the XML tags are accessible in the edited content) or in the visual Author editing mode (where the XML tags are hidden and only the text content is shown). You can switch between these editing modes by using the Document > Edit Mode menu.
    • Text mode provides access to the entire source document with all of its XML content, just like you have in any text editing application. In addition, using the Window > Show view submenu, you can change focus to the Attributes, Elements, or Outline view. The Attributes view presents the existing and possible attributes that can be inserted in an XML tag. The Elements view shows you the list of XML elements that can be inserted at cursor position (also, pressing F2 on a selected element presents its annotation). The Outline view shows the current path in the XML structure.
    • Author mode is useful for reviewing written XML content because it has support for change tracking and for adding comments. Editing in the Author visual editing mode, you have access only to the text content in the XML document. Pressing Shift-F2 will read to you the location in the XML structure. Again, you can also use the Outline view for this. In the Author editing mode, you can also use the Attributes and Elements views similar to using them in the Text editing mode. Pressing ENTER in the Author visual editing mode can also be used to present a list of allowed elements at the current position.