Edit online

The Project view is designed to assist you with organizing and managing related files grouped in the same XML project. The actions available in the contextual menu and on the toolbar associated to this panel allows you to create XML projects and provide shortcuts to various operations for the project documents.

Figure 1: Project View

By default, the view is positioned on the left side of the Oxygen XML Editor window, above the Outline view. If the view has been closed, it can be reopened at any time from the Window > Show View menu (or using the Show Project View action from the Project menu).

Project View Toolbar

The tree structure occupies most of the view area. In the upper left side of the view, there is a drop-down menu that contains all recently used projects. You can use this history drop-down menu to quickly switch to a recently opened project. If you enable the Remember layout changes for each project option in the Application Layout preferences page, the application will remember the layout, files opened, and editing location for your session when you switch projects.

At the bottom of the drop-down menu there are the actions to open and create a project:
Open Project (Ctrl + F2 (Command + F2 on OS X))
Opens an existing project. Alternatively, you can open a project by dropping an Oxygen XML Editor XPR project file from the file explorer into the Project panel.
Note: When a project is opened for the first time, a confirmation dialog box will be displayed that asks you to confirm that the project came from a trusted source. This is meant to help prevent potential security issues.
New Project
Creates a new, empty project.
The following actions are grouped in the upper right corner:
Collapse All
Collapses all project tree folders. You can also collapse/expand a project tree folder if you select it and press the Enter key or Left Arrow to collapse and Right Arrow to expand.
Link with Editor
When selected, the project tree highlights the currently edited file, if it is found in the project files.
Note: This button is disabled automatically when you move to the Debugger perspective.
Settings
A submenu that contains the following actions:
Filters
Allows you to filter the information displayed in the Project view. Click the toolbar button to set filter patterns for the files you want to show or hide. Also, you can set filter patterns for the linked directories that are hidden.
Show Full Path
When selected, linked files and folders are presented with a full file path.
Enable Master Files Support
Select this option to enable the Master Files support.
Change Search and Refactor operations scope
Allows you to change the collection of documents that define the context of the search and refactor operations.
  • Use only Master Files, if enabled - Restricts Oxygen XML Editor to perform the search and refactor operations starting from the master files that are defined for the current resource. This option is available when you select Project in the Select the scope for Search and Refactor operations dialog box and the Master Files support is enabled.
  • Working sets - Allows you to specify the set of files that will be used for the scope of the search and refactor operations.

File Explorer Area

The rest of the view is basically a file explorer similar to most other commonly used file explorers. The XML project (.xpr file) is a logical container with a collection of resources (folders and files). The types of resources displayed include:

  • Logical folders with Linked folders/files - Marked with a blue icon on Windows and Unix/Linux () and a magenta icon on Mac OS X (), they help you group files within the project. This folder type is used as containers for linked resources (shortcuts). The icons for file shortcuts include a shortcut symbol () and names of folder shortcuts are displayed in bold text. The logical folders are created on the project root or inside other logical folders by using the contextual menu action New > Logical Folder, and the linked folders/files are added using Add Files, Add Folder, or by dragging and dropping files/folders from the view or the system file explorer. Remove from Project can be used to remove them from the project and the Remove from Disk (Shift+Delete) action can be used to remove them from both the project and the local file system.
  • Physical folders and files - Marked with the operating system-specific icon for folders (usually a yellow icon on Windows and a blue icon on Mac OS X). These folders and files are mirrors of real folders or files that exist in the local file system. They are created or added to the project by using contextual menu actions (such as New > File, New > Folder, Copy, and Paste) or by dragging and dropping files/folders from the view or the system file explorer. Also, the contextual menu action Remove from Disk (Shift+Delete) can be used to remove them from the project and local file system.
Figure 2: Project View with Both Types of Resources

Creating New Projects

The following action is available from the New menu when right-clicking any item, the Project menu, or from the drop-down menu in the top-left of the Project view:
New Project
Creates a new, empty project.

Managing Project Contents

There are various contextual menu actions, shortcuts, and ways to organize the folders and files inside the project:

Creating New Folders and Files
Right-click any item > New > File
Opens a New file dialog box that helps you create a new file and adds it to the project structure.
Right-click any item in a physical folder > New > Folder
Opens a New Folder dialog box that allows you to specify a name for a new folder and adds it to the structure of the project.
Right-click any item in a logical folder > New > Logical Folder
Creates a logical folder in the tree structure (the icon is a magenta folder on Mac OS X ).
Right-click on a logical folder > New > Logical Folders from Web
Replicates the structure of a remote folder accessible over FTP/SFTP/WebDAV, as a structure of logical folders. The newly created logical folders contain the file structure of the folder it points to.
Adding Resources

You can add resources by using drag and drop (or Copy and Paste) actions from within the Project view or dragging them from the system file explorer. Files may have multiple instances within the folder system, but cannot appear twice within the same folder.

Adding Resources to Logical Folders

You can add resources to logical folders by using the following actions available in the contextual menu when invoked on a logical folder (or the project's root container):

Add Folder
Adds a link to a physical folder, whose name and content mirror a real folder that exists in the local file system (the icon for this action is different on Mac OS X ).
Add Files
Adds links to files on the local file system.
Add Edited File
Adds a link to the currently edited file in the project.
Removing Folders and Files
To remove logical folders or the linked resources inside them from the project, use Remove from Project from the contextual menu (or press Delete on your keyboard).

To remove folders or files from both the project and the local file system, use Remove from Disk from the contextual menu (or press Shift+Delete on your keyboard).

Moving Folders and Files

You can move the resources by using drag and drop actions from within the Project view (the Enable drag-and-drop in Project view option must be selected in the View preferences page).

You can also use the usual Cut, Copy, and Paste actions to move resources in the project.

You can also move certain types of files (such as XML, XML Schema, Relax NG, WSDL, and XSLT) by using the Refactoring > Move resource action from the contextual menu. This action opens the Move resource dialog box that includes the following options:
  • Destination - Presents the path to the current location of the resource you want to move and gives you the option to introduce a new location.
  • New name - Presents the current name of the moved resource and gives you the option to change it.
  • Update references of the moved resource(s) - Select this option to update the references to the resource you are moving, based upon the selected scope. You can select or configure the scope by using the button.
Renaming Folders and Files
There are several ways to rename a folder or file in the project (this works for both physical and linked resources):
  • Select Rename from the contextual menu.
  • Press F2 on your keyboard.
  • Select the item, then click the name, and type the new name.
You also can rename certain types of files (such as XML, XML Schema, Relax NG, WSDL, and XSLT) by using the Refactoring > Rename resource action from the contextual menu. This action opens the Rename resource dialog box that includes the following options:
  • New name - Presents the current name of the edited resource and allows you to modify it.
  • Update references of the renamed resource - Select this option to update the references to the resource you are renaming. You can select or configure the scope by using the button.
Opening Files
There are several ways to open a file:
  • Double-click the file.
  • Select it and press Enter on your keyboard.
  • Right-click the file and select Open.
  • If there are no other files open in the editor area, you can drag the file from the project tree and drop it in the editor area.
  • If you want to choose the application or location where to open it, you can right-click the file and select Open with.
Saving the Project
The project file is automatically saved every time the content of the Project view is saved or modified by actions such as adding or removing files and drag and drop.

Other Contextual Menu Actions

Numerous other actions are available in the contextual menu, depending on the type of file or folder where it is invoked from (some actions are available for multiple selected files):
Show in submenu
Explorer (Finder on OS X)
On Windows and Mac OS X, the parent directory of the selected file or folder is presented in a specific Explorer/Finder window, and the selected resource is highlighted. On Linux, the selected file or folder is not highlighted after opening its parent in the file explorer.
Terminal
Opens a console (terminal) at the location of the selected physical resource. If the resource is a file, it will start at the parent directory.
Copy Location
Copies an application-specific URL for the selected resource to the clipboard.
Refactoring submenu
Oxygen XML Editor includes some refactoring operations that help you manage the structure of your documents. The following actions are available from the contextual menu in the Refactoring submenu:
Rename resource (Available for certain types of XML documents)
Opens the Rename resource dialog box where you can change the name of a resource. It also includes an option to update the references to the renamed resource and you can choose between various scopes for the operation.
Move resource (Available for certain types of XML documents)
Opens the Move resource dialog box where you can choose a destination and change the name of a resource. It also includes an option to update the references to the moved resource and you can choose between various scopes for the operation.
XML Refactoring
Opens the XML Refactoring tool wizard that presents refactoring operations to assist you with managing the structure of your XML documents.
Other XML Refactoring Actions
For your convenience, the last 5 XML Refactoring tool operations that were finished or previewed will also appear in this submenu.
Resource Hierarchy
Opens the Resource Hierarchy/Dependencies view that allows you to see the resource hierarchy for an XML document.
Resource Dependencies
Opens the Resource Hierarchy/Dependencies view that allows you to see the resource dependencies for an XML document.
Refresh
Refreshes the content and the dependencies between the resources in the Master Files directory.
Find/Replace in Files
Opens the Find/Replace in Files dialog box that allows you to find and replace text in multiple files.
XPath in Files
Opens the XPath/XQuery Builder view that allows you to compose XPath and XQuery expressions and execute them over the currently edited XML document.
Open/Find Resource
Opens the Open/Find Resource dialog box.
Check Spelling in Files
Allows you to check the spelling of multiple files.
Format and Indent Files
Opens the Format and Indent Files dialog box that allows you to configure the format and indent (pretty-print) action that will be applied on the selected documents.
Open in SVN Client
Syncro SVN Client tool is opened and it highlights the selected resource in its corresponding working copy.
Compare
Allows you to compare multiple files or directories and the order of your selection determines where they are opened in the Compare Files or Compare Directories tool. If you select two files or folders, your first selection will be opened in the left panel and the other one in the right panel.

You can also select 3 files and the tool will automatically be opened in the three-way comparison mode. If you select three files, your first selection will be opened in the left panel, the second in the right panel, and the third selection will be the base (ancestor) file.

Transform submenu
The currently selected files in the Project view can be transformed in one step with one of the following actions available from contextual menu in the Transform submenu:
Apply Transformation Scenario(s)
Obtains the output with one of the built-in scenarios.
Configure Transformation Scenario(s)
Opens a dialog box that allows you to configure pre-defined transformation scenarios.
Transform with
Allows you to select a transformation scenario to be applied to the currently selected files.
Validate submenu
The currently selected files in the Project view can be checked to be XML well-formed or validated against a schema (DTD, XML Schema, Relax NG, Schematron or NVDL) with one of the following contextual menu actions found in the Validate submenu:
Check Well-Formedness
Checks if the selected file or files are well-formed.
Validate
Validates the selected file or files against their associated schema. For EPUB files, this action triggers an EPUB Validate and Check for Completeness operation.
Validate with Schema
Validates the selected file of files against a specified schema.
Configure Validation Scenario(s)
Allows you to configure and run a validation scenario.
Generate Documentation submenu
Generate Documentation > XML Schema Documentation
Opens the XML Schema Documentation Dialog Box.
Generate Documentation > XSLT Stylesheet Documentation
Opens the XSLT Stylesheet Documentation Dialog Box.
Generate Documentation > XQuery Documentation
Opens the XQuery Documentation Dialog Box.
Generate Documentation > WSDL Documentation
Opens the WSDL Documentation Dialog Box.
Properties
Displays the properties of the current file in a Properties dialog box.
Enable Master Files Support (Available from the project container)
Allows you to enable the Master Files Support for each project you are working on.
Detect Master Files (Available from the project container when Master Files Support is enabled)
Opens the Detect Master Files wizard that enables the automatic detection of master files.
Add to Master Files (Available when Master Files Support is enabled)
Adds the selected files to the Master Files folder.

Project Menu Actions

The following actions are available in the Project menu:
New Project
Creates a new, empty project.
Open Project (Ctrl + F2 (Command + F2 on OS X))
Opens an existing project. Alternatively, you can open a project by dropping an Oxygen XML Editor XPR project file from the file explorer into the Project panel.
Note: When a project is opened for the first time, a confirmation dialog box will be displayed that asks you to confirm that the project came from a trusted source. This is meant to help prevent potential security issues.
Save Project As
Allows you to save the current project under a different name.
Validate all project files
Checks if the project files are well-formed and their mark-up conforms with the specified DTD, XML Schema, or Relax NG schema rules. It returns an error list in the message panel.
Filters
Opens the Project filters dialog box that allows you to decide which files and directories will be shown or hidden.
Enable Master Files Support
Allows you to enable the Master Files Support for each project you are working on.
Change Search and Refactor operations scope
Opens a dialog box that allows you to define the context of search and refactor operations.
Show Project View
Displays the Project view.
Reopen Project
Contains a list of links of previously used projects. This list can be emptied by invoking the Clear history action.