History | Edit

A command-line tool can be started in the Oxygen XML Editor user interface as if from the command line of the operating system shell. The External Tools preferences page allows you to add and configure these external tools that could be used while working with Oxygen XML Editor. To access this preferences page, open the Preferences dialog box (Options > Preferences) and go to External Tools (or select Configure from the Tools > External Tools menu).

This preferences page presents a list of the external tools that have been configured. You can use the buttons at the bottom of the page to configure the items in the list. Once a tool has been configured, you can open it by selecting it from the Tools > External Tools menu or from the External Tools drop-down menu on the toolbar (the Tools toolbar needs to be selected in the Configure Toolbars dialog box).

How to Configure an External Tool

To configure an external tool in the External Tools preferences page, use any of the following buttons at the bottom of the page:
  • New - Adds a new external tool to the list.
  • Edit - Allows you to configure an existing external tool, selected from the list.
  • Duplicate - Duplicates an existing external tool, selected from the list, to use as a template for configuring a similar tool.
Any of those three buttons opens the External Tools configuration dialog box.

Figure: External Tools Configuration Dialog Box

This configuration dialog box includes the following options:
Name
The name of tool that will be displayed in the Tools > External Tools menu and in the External Tools drop-down menu on toolbar.
Description
A description of the tool displayed as a tooltip where the tool name is used.
Working directory
The directory that the external tool will use to store intermediate and final results. You can specify the path by using the text field, the Insert Editor Variables button, or the Browse button. You can use one of the following editor variables: ${cfd}, ${pd}, ${oxygenInstallDir}, ${homeDir}, ${system(var.name)}, ${date(pattern)}, ${xpath_eval(expression)}. You can also use the browsing tools to select the directory.
Command line
The command line that will start the external tool. You can specify the path by using the text field, the Insert Editor Variables button, or the Browse button. You can use one of the following editor variables: ${homeDir}, ${home}, ${cfn}, ${cfne}, ${cf}, ${currentFileURL}, ${cfd}, ${cfdu}, ${tsf}, ${pd}, ${pdu}, ${oxygenInstallDir}, ${oxygenHome}, ${frameworksDir}, ${frameworks}, ${ps}, ${timeStamp}, ${uuid}, ${id}, ${afn}, ${afne}, ${af}, ${afu}, ${afd}, ${afdu}, ${ask('message', type, 'default_value')}, ${dbgXML}, ${dbgXSL}, ${env(VAR_NAME)}, ${system(var.name)}, ${date(pattern)}, and ${xpath_eval(expression)}. You can also use the browsing tools to select a file path.
Show output messages
When this option is selected, all the messages emitted by the external tool are displayed in the Results view. When this option is not selected, only the error messages are displayed. You can also choose the output encoding and content type:
  • Output encoding - The encoding of the output stream of the external tool that will be used byOxygen XML Editor to read the output of the tool.
  • Output content type - A list of predefined content type formats that instructOxygen XML Editor how to display the generated output. For example, setting the Output content type to text/xml enables the syntax coloring of XML output.
Error Encoding
The encoding of the error stream of the external tool that will be used by Oxygen XML Editor to read the error stream.
Shortcut key
You can choose a keyboard shortcut that can be used to launch the external tool.