History | Edit

The menus in the Compare Files tool contain some of the same actions that are on the toolbar, as well as some common actions that are identical to the same actions in the Oxygen XML Editor menus. The menu actions include:

File Menu

Source > Open
Browses for a file that will be displayed in the left panel.
Source > Open URL
Browses for a remote file that will be displayed in the left panel.
Source > Open File from Archive
Browses an archive for a file that will be displayed in the left panel.
Source > Reload
Reloads the file in the left panel.
Source > Save
Saves the changes made to the file in the left panel.
Source > Save As
Allows you to choose a destination to save the file in the left panel.
Source > Close
Closes the file in the left panel.
Target > Open
Browses for a file that will be displayed in the right panel.
Target > Open URL
Browses for a remote file that will be displayed in the right panel.
Target > Open File from Archive
Browses an archive for a file that will be displayed in the right panel.
Target > Reload
Reloads the file in the right panel.
Target > Save
Saves the changes made to the file in the right panel.
Target > Save As
Allows you to choose a destination to save the file in the right panel.
Target > Close
Closes the file in the right panel.
Base > Open
Browses for a file that will be compared with both files in a three-way comparison.
Base > Open URL
Browses for a remote file that will be compared with both files in a three-way comparison.
Base > Open File from Archive
Browses an archive for a file that will be compared with both files in a three-way comparison.
Close (Ctrl + W (Command + W on OS X))
Closes the application.

Edit Menu

Cut
Cut the selection from the currently focused editor panel to the clipboard.
Copy
Copy the selection from the currently focused editor panel to the clipboard.
Paste
Paste content from the clipboard into the currently focused editor panel.
Select all
Selects all content in the currently focused editor panel.
Undo
Undo changes in the currently focused editor panel.
Redo
Redo changes in the currently focused editor panel.

Find Menu

Find/Replace
Perform find/replace operations in the currently focused editor panel.
Find Next
Go to the next match using the same options as the last find operation. This action runs in both editor panels.
Find Previous
Go to the previous match using the same options as the last find operation. This action runs in both editor panels.

Compare Menu

Three-Way Comparison
Toggle action that allows you to perform a three-way comparison between the two files displayed in the two editing panes and a base (ancestor) file.
Perform Files Differencing
Looks for differences between the two files displayed in the left and right side panels.
Next Block of Changes (Ctrl + Period (Command + Period on OS X))
Jumps to the next block of changes. This action is not available when the cursor is positioned on the last change block or when there are no changes.
Note: A change block groups one or more consecutive lines that contain at least one change.
Previous Block of Changes (Ctrl + Comma (Command + Comma on OS X))
Jumps to the previous block of changes. This action is not available when the cursor is positioned on the first change block or when there are no changes.
Next Change (Ctrl + Shift + Period (Command + Shift + Period on OS X))
Jumps to the next change from the current block of changes. When the last change from the current block of changes is reached, it highlights the next block of changes. This action is not available when the cursor is positioned on the last change or when there are no changes.
Previous Change (Ctrl + Shift + Comma (Command + Shift + M on OS X))
Jumps to the previous change from the current block of changes. When the first change from the current block of changes is reached, it highlights the previous block of changes. This action is not available when the cursor is positioned on the first change or when there are no changes.
Last Change (Ctrl + E (Command + E on OS X))
Jumps to the last change.
First Change (Ctrl + B (Command + B on OS X))
Jumps to the first change.
Copy All Changes from Right to Left
Copies all changes from the file in the right panel to the file in the left panel.
Copy All Changes from Left to Right
Copies all changes from the file in the left panel to the file in the right panel.
Copy Change from Right to Left
Copies the selected difference from the file in the right panel to the file in the left panel.
Copy Change from Left to Right
Copies the selected difference from the file in the left panel to the file in the right panel.
Show Word Level Details
Provides a word-level comparison of the selected change.
Show Character Level Details
Provides a character-level comparison of the selected change.
Format and Indent Both Files (Ctrl + Shift + P (Command + Shift + P on OS X))
Formats and indents both files before comparing them. Use this option for comparisons that contain long lines that make it difficult to spot differences.
Note: When comparing two JSON files, the Format and Indent Both Files action will automatically sort the keys in both files the same to make it easier to compare.

Options Menu

Preferences
Opens the preferences dialog box that includes numerous pages of options that can be configured.
Menu Shortcut Keys
Opens the Menu Shortcut Keys option page where you can configure keyboard shortcuts available for menu items.
Reset Global Options
Resets options to their default values. Note that this option appears only when the tool is executed as a stand-alone application.
Import Global Options
Allows you to import an options set that you have previously exported.
Export Global Options
Allows you to export the current options set to a file.

Help Menu

Help (F1)
Opens a Help dialog box that displays the User Manual at a section that is appropriate for the context of the current cursor position.
Use Online Help
If this option is selected, when you select Help or press F1 while hovering over any part of the interface, Oxygen XML Editor attempts to open the help documentation in online mode. If this option is not selected or an internet connection fails, the help documentation is opened in offline mode.
Report problem
Opens a dialog box that allows the user to write the description of a problem that was encountered while using the application. You can change the URL where the reported problem is sent by using the com.oxygenxml.report.problems.url system property. The report is sent in XML format through the report parameter of the POST HTTP method.
Support Center
Opens the Oxygen XML Editor Support Center web page in a browser.