History | Edit

The Editor perspective is the most commonly used perspective and it is the default perspective when you start Oxygen XML Editor for the first time. It is the perspective that you will use to edit the content of your XML documents.

To switch the focus to this perspective, select the Editor button in the top-right corner of Oxygen XML Editor (or select Editor from the Window > Open perspective menu)

The layout of this perspective is composed of the following components:
Menus
Provides menu driven access to all the features and functions available in Oxygen XML Editor. Most of the menus are common for all types of documents. However, Oxygen XML Editor also includes some context-sensitive and framework-specific menus that are only available for a specific context or type of document.
Toolbars
Provides easy access to common and frequently used functions. Each icon is a button that acts as a shortcut to a related function. Most of the toolbars are common for all types of documents. However, Author mode also includes framework-specific toolbars, depending on the type of document that is being edited (for example, if you are editing a DITA document, a DITA Author Custom Actions toolbar is available that includes operations that are specific to DITA documents). The toolbars can be configured to suit your specific needs.
Editor Pane
The main editing pane where you spend most of your time reading, editing, applying markup, and validating your documents.
Views
Oxygen XML Editor includes a large variety of dockable views to assist you with editing, viewing, searching, validating, transforming, and organizing your documents. The most commonly used views are displayed by default and you can choose to display others by selecting them from the Window > Show View menu. The layout of the views can also be configured according to your preferences.

When two or more views are displayed, the application provides divider bars. Divider bars can be dragged to a new position increasing the space occupied by one panel while decreasing it for the other.

As the majority of the work process centers around the Editor area, other views can be hidden using the toggle controls located on the top corner of the view ( [ on Mac OS X]).

Some of the most helpful views in the Editor perspective include the following:

  • Project view - Enables the definition of projects and logical management of the documents they contain.
  • DITA Maps Manager view - For DITA document types, this view helps you organize, manage, and edit DITA topics and maps.
  • Open/Find Resource view - Designed to offer advanced search capabilities in various scopes.
  • Outline view - It provides an XML tag overview and offers a variety of functions, such as modifications follow-up, document structure change, document tag selection, and elements filtering.
  • Results view - Displays the messages generated as a result of user actions such as validations, transformation scenarios, spell checking in multiple files, search operations, and others. Each message is a link to the location related to the event that triggered the message.
  • Attributes view - Presents all possible attributes of the current element and allows you to edit attribute values. You can also use this view to insert attributes in Text mode. Author mode also includes an in-place attribute editor.
  • Model view - Presents the current edited element structure model and additional documentation as defined in the schema.
  • Elements view - Presents a list of all defined elements that you can insert at the current cursor position according to the document's schema. In Author mode this view includes tabs that present additional information relative to the cursor location.
  • Entities view - Displays a list with all entities declared in the current document as well as built-in ones.
  • Transformation Scenarios view - Displays a list with all currently configured transformation scenarios.
  • XPath/XQuery Builder view - Displays the results from running an XPath expression.
  • WSDL SOAP Analyzer view - Provides a tool that helps you test if the messages defined in a Web Service Descriptor (WSDL) are accepted by a Web Services server.