History | Edit

Oxygen XML Editor includes some useful features to help you navigate XML documents.

Using the Keyboard

Oxygen XML Editor allows you to quickly navigate through a document using the Tab key to move the cursor to the next XML node and Shift + Tab to go to the previous one. If you encounter a space-preserved element when you navigate through a document and you do not press another key, pressing the Tab key will continue the navigation. However, if the cursor is positioned in a space-preserved element and you press another key or you position the cursor inside such an element using the mouse, the Tab key can be used to arrange the text.

To navigate one word forward or backwards, use Ctrl + RightArrow (Command + RightArrow on OS X), and Ctrl + LeftArrow (Command + LeftArrow on OS X), respectively. Entities and hidden elements are skipped. To position the cursor at the beginning or at the end of the document you can use Ctrl + Home (Command + Home on OS X), and Ctrl + End (Command + End on OS X), respectively.

Navigation Buttons

Oxygen XML Editor includes some actions that help you to quickly navigate to a particular modification. These navigation buttons are available in the main toolbar and the actions can also be accessed from the Find menu. The three actions include:

  • Last Modification - Moves the cursor to the last modification in any opened document.
  • Back - Moves the cursor to the previous position.
  • Forward - Moves the cursor to the next position after the Back button has been used at least once.

Navigating with the Outline View

Oxygen XML Editor includes a very useful Outline view that displays a hierarchical tag overview of the currently edited XML Document.

You can use this view to quickly navigate through the current document by selecting nodes in the outline tree. It is synchronized with the editor area, so when you make a selection in the Outline view, the corresponding nodes are highlighted in the editor area.

Figure: Outline View Navigation in Author Mode

Using the Breadcrumb to Navigate

A breadcrumb on the top stripe indicates the path from document root to the current element. It can also be used as a helpful tool to navigate to specific elements throughout the structure of the document.

Figure: Breadcrumb in Author Mode

The last element listed in the breadcrumb is the element at the current cursor position. The last element is also highlighted by a thin light blue bar for easier identification. Clicking an element from the breadcrumb selects the entire element and navigates to it in the editor area.

Using the Linking Support

When working on multiple documents that reference each other (references, external entities, XInclude, DITA conref, etc), the linking support is useful for navigating between the documents. In the predefined customizations that are bundled with Oxygen XML Editor, links are marked with an icon representing a chain link (). When hovering over the icon, the mouse pointer changes its shape to indicate that the link can be accessed and a tooltip presents the destination location. Click the link to open the referenced resource in the editor or system browser. The same effect can be obtained by using the Document > File > Open file at cursor (Ctrl + Enter (Command + Enter on OS X)) action when the cursor is inside a link element.
Note: Depending on the referenced file type, the target link will either be opened in the Oxygen XML Editor or in the default system application. If the target file does not exist, Oxygen XML Editor prompts you to create it.

Navigating with Bookmarks

A position in a document can be marked with a bookmark. You can then quickly go to the marked position with a keyboard shortcut or a menu action. This is useful when navigating large documents or working on multiple documents where the cursor needs to move between several marked positions. The bookmarks are displayed with a small icon on the vertical strip to the left of the editor. You can place up to nine distinct bookmarks in any document. Shortcut keys are available to place the bookmarks or to return to any of the marked positions. You can configure these shortcut keys in the Options > Menu Shortcut Keys menu.

Figure: Editor Bookmarks

A bookmark can be inserted in Author mode by doing one of the following:
  • Click in the vertical stripe on the left side of the editor.
  • Select the Create Bookmark (F9) action from the Edit > Bookmarks menu.

A bookmark can be removed by right-clicking its icon on the vertical stripe and select Remove or Remove all (Ctrl+F7 (Command+F7 on OS X)).

You can navigate the bookmarks by using one of the actions available on the Edit > Bookmarks > Go to menu or by using the shortcut keys that are listed in that menu.