Edit online

Content Fusion Connector Add-on

The Content Fusion Connector add-on integrates the intuitive collaboration platform into Oxygen XML Editor/Author, allowing authors to create review tasks and integrate proposed changes directly from the application.

Compatibility:
This add-on is compatible with the following products:
  • Oxygen XML Editor
  • Oxygen XML Author
  • Oxygen XML Developer
  • Oxygen JSON Editor

An Oxygen Content Fusion Connector add-on is available that can be installed to integrate Oxygen Content Fusion into Oxygen XML Editor/Author. This allows authors to create review tasks directly from Oxygen XML Editor/Author and integrate proposed changes. Content Fusion is a flexible, intuitive collaboration platform designed to adapt to virtually any type of workflow that a collaborative team may use for their documentation review process.

To fully take advantage of all of the benefits and features, your organization will need an Oxygen Content Fusion Enterprise Server. This solution allows you to host, setup, and configure your own server and control your data. With this model, you are also able to upload custom frameworks and plugins, and to configure various settings. It is possible to evaluate Content Fusion free of charge, for a limited time. For more information, see the Oxygen Content Fusion website.

Edit online

Installation and Configuration

This section provides information about installing, configuring, and updating the Content Fusion Connector add-on within Oxygen XML Editor/Author.

Edit online

Installing the Content Fusion Connector Add-on

To use and manage Content Fusion within Oxygen XML Editor or Oxygen XML Author, you must install the Oxygen Content Fusion Connector add-on using one of the following methods:

Quick Installation

You can drag the following Install button and drop it into the main editor in Oxygen to quickly initiate the installation process:

Install

Manual Installation

To manually install the Oxygen Content Fusion Connector add-on in Oxygen XML Editor or Oxygen XML Author, follow these steps:
  1. Go to Window > Show View and select Content Fusion Task Manager.
  2. If it has not already been installed, a message will appear asking you if you want to install the add-on.
  3. To continue, click Install and follow the on-screen instructions.
    Note:
    If you don't see the add-on because Oxygen is unable to connect to the default update site, you can download the add-on package, unzip it, then use the Browse for local files action in the Install new add-ons dialog box to locate the downloaded addon.xml file.
  4. Restart Oxygen.

Result: The Content Fusion Task Manager and Content Fusion Project views are now available in the Window > Show View menu.

Edit online

Configuring Your Enterprise Server Address

If your organization is connecting to Content Fusion using your own hosted server, your system administrator first needs to set up and configure your Enterprise server and they can either use a properties file to impose the Enterprise server address or they can send you the server address and you can manually configure Oxygen XML Editor/Author to connect to the server.

Manually Configuring Oxygen XML Editor/Author to Connect to Your Enterprise Server

  1. Click the Show Content Fusion Task Manager toolbar button to display the task management view.
  2. You are asked to Choose the Oxygen Content Fusion server. Select Enterprise and enter the address of your Enterprise server (for example,http://fusion.example.com). Ask your system administrator for the server address if you do not know it. If your organization uses the properties file to impose the Enterprise server address, you will not need to enter it manually.
    Important:
    The Evaluation option is a service where the content is stored on an Evaluation server hosted by Oxygen and with a default configuration. It is meant for trial purposes only. When using this option, you should only use sample documents that do not contain sensitive information or ownership rights.
  3. Click Connect to open the Content Fusion interface in your default browser.
    Note:
    If a connection to the server could not be established, a Choose the Oxygen Content Fusion server box is displayed . You can enter the address of your server (it must be a valid URL), click Connect, and this also automatically sets the address of your server in the preference page described in steps 3 and 4.
  4. If this is your first time using Content Fusion, click on SIGN UP and follow the instructions to create your account. If you already have an account, log in and click Authorize.

Result: You are now ready to start using the Content Fusion Task Manager and when you upload tasks, the documents are stored on your Enterprise server.

Manually Changing the Enterprise Server Address in Oxygen XML Editor/Author

To change the server address of your Enterprise server, use the following procedure:
  1. In Oxygen XML Editor/Author, go to Options > Preferences > Plugins > Oxygen Content Fusion Connector.
  2. Enter the new address in the Server URL field.
    Tip:
    You can click the Test Connection button to test the URL. If Content Fusion cannot find a connection, it attempts to find an alternative (for example, the same URL without a port number). If the attempt at connecting to the alternative URL is successful, you are given the choice to connect to that server address instead.
  3. Click OK.
Edit online

Updating the Connector Add-on

The Oxygen Content Fusion Connector add-on is updated periodically to enhance its functionality and solve issues. There are several ways to update the add-on and there is an option that you can select to have Oxygen XML Editor/Author automatically check for add-on updates at startup.

How to Enable Automatic Add-on Update Checking

To instruct Oxygen XML Editor/Author to automatically check for add-on updates when the application is started, go to Options > Preferences > Add-ons and select the Enable automatic updates checking option.

How to Update the Content Fusion Add-on

There are several ways to update the Oxygen Content Fusion Connector add-on:

Automatic Add-on Update Checking Feature
If you have enabled the automatic add-on update checking feature, whenever the add-on is updated, you will receive a notification the next time you start Oxygen XML Editor/Author that an update is available. To update the add-on, follow these steps:
  1. Click Review updates in the pop-up notification.
  2. Make sure the Oxygen Content Fusion Connector add-on is selected in the next dialog box and click Update.
  3. Select the I accept all terms of the end user license agreement option and click Finish.
  4. Restart Oxygen XML Editor/Author.
Manually Check for Add-ons Updates
To manually check for updates, go to Help > Check for add-ons updates. If there is an update available for the add-on, this dialog box displays Update available in the Status column. To update the add-on, follow these steps:
  1. Make sure the Oxygen Content Fusion Connector add-on is selected and click Update.
  2. Select the I accept all terms of the end user license agreement option and click Finish.
  3. Restart Oxygen XML Editor/Author.
Manage Add-ons Dialog Box
You can also go to Help > Manage add-ons to check for updates. If there is an update available for the add-on, this dialog box displays Update available in the Status column. To update the add-on, follow these steps:
  1. Make sure the Oxygen Content Fusion Connector add-on is selected and click Update.
  2. Select the I accept all terms of the end user license agreement option and click Finish.
  3. Restart Oxygen XML Editor/Author.
Edit online

Content Fusion Tasks Manager View

To open the Content Fusion Task Manager view, click the Show Content Fusion Tasks Manager toolbar button (or go to Window > Show View > Content Fusion Tasks Manager). If neither of them is there, see Installing the Content Fusion Connector Add-on.

By default, the Content Fusion Task Manager view is displayed to the right of the main editing panel. This view is where you can create tasks, manage them, attach documents, and upload them to the Content Fusion server.

Connecting to the Server

When you first open the Content Fusion Task Manager view, you must choose the server to connect to and there are two choices:
  • Cloud - This option connects to a fully managed cloud service without needing to host or maintain your own server. Your data and configuration are securely stored.
  • Other Server - This option allows you to use your own hosted server and control your own data and configuration. You will also be able to use custom frameworks and plugins, and configure various options. Before connecting to your server, you first need to configure your Enterprise server address.

After choosing the server option, click the Connect button to open the Content Fusion interface in your default browser where you will enter your credentials (if you do not already have an account, click SIGN UP and follow the instructions to create your account). When finished, click Authorize.

Tasks Manager View

Figure 1. Content Fusion Tasks Manager View

The Content Fusion Tasks Manager view contains the following actions and components:

User Name drop-down menu

Once connected and authorized, your user name will appear in the upper right corner of the view. If you hover over your name, you can see what email address is associated with the account. The drop-down menu offers the following actions:

Refresh Tasks
Forces a refresh to synchronize the information in the view with the Content Fusion server.
Go to my Account
Opens your profile information in your default browser.
Connection Status
Provides information such as the server address, plugin version, and connection status. This option can be used for troubleshooting purposes. For more information, see Uploading a Review Task Takes Too Long.
Help
Opens the Content Fusion user guide in your default browser.
Preferences
Opens the Oxygen Content Fusion Connector preferences page where you can change the server address.
Disconnect
Signs you out of Content Fusion. To re-establish the connection, you need to click Connect and then Authorize.
New Task box

Use this box to create new tasks. Drag files from the Project view, DITA Maps Manager, or your system file explorer and drop them in this box (or click the Choose link to select files) to add the files to a new task.

Figure 2. New Task Box (for DITA Projects)
Title
The task title will help you differentiate between multiple tasks so each one should be unique.
Description (optional)
An optional description for the task.
Note:
The Description field is available if the server you are connected to has this field enabled.
Files to Review
You will see all of the attached files in this section. There are several ways to add files to the task. For more details, see Creating Tasks and Uploading Files.
DITA Context (for DITA projects only)
Root Map
If you are working with a DITA project, context root map is used to resolve the references and defined keys so that they are displayed properly for the reviewers and they can see the hierarchy of all the attached files in the Content Fusion interface. When you add DITA files to the task, the root map that is specified in the toolbar of the DITA Maps Manager is automatically detected but you can also drag a DITA map file and drop it in this section or click to the Choose context root map button to select a map.
DITAVAL File
If you are working with a DITA project, you can specify a DITAVAL file so that the content in the uploaded DITA topics is filtered based upon the conditional profiling attribute values defined in the DITAVAL file. You can drag a DITAVAL file and drop it in this section or click to the Choose DITAVAL button to select a file. If a condition set is selected in the DITA Maps Manager, the corresponding DITAVAL file will automatically be selected in the task.
Also include all files that are referenced within the attached files (non-DITA files only)
If you have only attached non-DITA XML files (and a DITA map is not selected as the context root map in the DITA Maps Manager), this option becomes available. If selected, snapshots of any files that are referenced within any of the attached Files to Review will also be attached so that reviewers will have access to the referenced content. Also, when this option is selected, you can click the Next button to preview the referenced files and you can choose to remove any that you do not want uploaded.
Due Date
Optionally, you can specify a Due Date. Within the browser interface, the amount of time left before the due date arrives is displayed under the review task's title when you have navigated inside the task and also in the table in the My Review Tasks page. Also, any reviewers who have not finalized the task will receive an email notification when the due date is within 3 days, 1 day, and 12 hours of its expiration.
Upload/Cancel buttons
Once you are finished adding files and entering a task summary, use the Upload button to finalize the task and upload it to the Content Fusion server. Use the Cancel button to cancel the task creation process.
Tasks

Each created task is listed with its own box in the view. In this box, you will see the task name, the date/time it was created, that task status (if it is in the state of either Integrating or Review closed), and notifications when messages are added in the Content Fusion interface or when a file is changed (the background color of the task box also changes when a new message or file change is detected). Click on the name of a task to open it in your default browser where you can view and manage the task, share a link to it with reviewers, view and add messages, and monitor the task progress.

Figure 3. Task Display Box
Get Changes
Once the reviewers are done with their process, you will have access to a Get Changes link. Clicking this link opens the Get Changes merge tool that is used to automatically merge all the changes back into the original documents.
Delete Task
Once you are finished merging the changes, you can click the Delete Task link to remove it from the view and the Content Fusion server. It is recommended that you always delete tasks that have been merged so that you do not accidentally merge them again since that could create some complicated conflicts.
Contextual Menu

If you right-click a task box, the contextual menu offers the following actions:

Open task in browser
Opens the task in your default browser.
Copy task link
Copies the task link to the system clipboard. You can then use any common messaging application to send this copied link to reviewers. You can also paste the copied link in any browser to open it in the Content Fusion browser interface.
Edit context DITA map
Opens the DITA map that is specified as the context map for the task in the editor. It allows you to open and edit a file from the Content Fusion server directly in Oxygen XML Editor/Author.
Notes:
  • This action is only available for tasks with a context map specified.
  • The editing works only for servers with a version 5.0 or higher. For versions prior to 5.0, you can open files but they are read-only.
Close/Reopen Review
Closes or reopens the review for the task. Closing the review locks the task and prevents others from making changes to it, giving you some time to address the feedback before integrating the changes. Reopening the review makes the task editable again in case further review is needed.
Get changes
Opens the Get Changes merge tool that is used to automatically merge all the changes back into the original documents.
Mark as integrated
Marks the task as integrated to archive the task, remove it from visibility for all users, and make it uneditable.
Note:
A task owner can view integrated (archived) tasks in the browser interface by clicking the Show integrated review tasks button at the bottom of the Owned By Me tab in the My Review Task page. Integrated tasks can be reactivated (to regain access to the task) by using the Mark as not integrated action that appears for integrated tasks.
Delete task
Removes the task from the view and the Content Fusion server.
Refresh tasks
Refreshes the Content Fusion Tasks Manager view.
Edit online

Creating Tasks and Uploading Files

Creating a task using the Content Fusion Tasks Manager view in Oxygen XML Editor/Author offers several advantages. You can add existing files, select a context root map to resolve keys and references, or specify a DITAVAL file for filtering purposes (for DITA content), you do not need to leave the application (other than to send the task link to reviewers), and you will be able to merge proposed changes back into your documentation.

To create a new task, add files to it, and then upload the task to the Content Fusion server, follow these steps:
  1. If the Content Fusion Tasks Manager view is not already opened, click the Show Content Fusion Task Manager toolbar button (or go to Window / Show View / Content Fusion Tasks Manager).
  2. Add files to the New Task box:

    Figure 4. Adding Files to the New Task Box
    You can use any of the following methods:
    • Drag files that you want to be reviewed from the Project view or your system file explorer and drop them in the New Task box (or click the Choose link to select the files) to add the files to a new task. If you drag and drop a folder from the Project view or system file explorer, all files in that directory will be added to the task.
    • You can add the currently open document to a task by selecting Add File to Review Task from the Review submenu in the contextual menu in Author mode.
    • You can also add external resources (for example, WebDAV resources or DITA references to external resources). For example, you can drag resources from the Data Source Explorer view and drop them in the New Task box. However, only modifications to external resources can be applied when you merge the changes (you cannot add or delete external resources).
    • For DITA files, drag the files from the DITA Maps Manager and drop them into the New Task box (or select Add to Review Task from the contextual menu in the DITA Maps Manager). If the topic reference has unselected child nodes, a dialog box will be displayed that asks you whether or not you want to include the child nodes.
      Note:
      By default, DITA resources that either have a @processing-role attribute set to resource-only or a @format attribute set to something other than dita or ditamap are not automatically added to a new task. If either one of these scenarios is detected, a message will be displayed indicating that some files were not added and you can click a link to open a Manage Files dialog box where you can see the reason for each file and you can choose to manually add them to the new task, if desired.
      Figure 5. Manage Files Dialog Box
  3. Enter a Title for the task. This task title will help you differentiate between multiple tasks so each one should be unique.
  4. [DITA Only] If you are working with DITA, you should attach the context root map () so that all references and defined keys can be resolved and displayed properly for the reviewers. When you add files to the task, if a context root map is specified in the toolbar of the DITA Maps Manager, it is automatically added in the DITA Context section, but you can also drag a DITA map file and drop it in that section or click the Choose context root map button to select a map. Specifying the root map also allows reviewers to edit content referenced through a @conref or @conkeyref attribute.

    Figure 6. Creating a New Task
  5. [DITA Only] If you are working with DITA, you can specify a DITAVAL file () so that the content in the uploaded DITA topics is filtered based upon the conditional profiling attribute values defined in the DITAVAL file. You can drag a DITAVAL file and drop it in the DITA Context section or click the Choose DITAVAL button to select a file. If a condition set is selected in the DITA Maps Manager, the corresponding DITAVAL file will automatically be selected in the task.
  6. [Non-DITA] If the attached files are detected as any file type other than DITA (and a DITA map is not selected as the context root map in the DITA Maps Manager), an option (Also include all files that are referenced within the attached files) will be available. If you select this option, all files that are referenced within the attached documents will automatically be attached to the task so that reviewers will have access to the referenced content. Also, when this option is selected, you can click the Next button to preview the referenced files and you can choose to remove any that you do not want uploaded.
  7. Optionally, you can specify a Due Date. Within the browser interface, the amount of time left before the due date arrives is displayed under the review task's title when you have navigated inside the task and also in the table in the My Review Tasks page. Also, any reviewers who have not finalized the task will receive an email notification when the due date is within 3 days, 1 day, and 12 hours of its expiration.
  8. Click the Upload button to finish the task creation process and upload the information to the Content Fusion server.
Result: The task information is now available in the Content Fusion browser interface. The next logical step would most likely be to share the task link with anyone you want to review the documents.
Note:
No actual files are uploaded, rather snapshots of the files are uploaded with the task information. Therefore, when you eventually merge the proposed changes back into the original files in Oxygen XML Editor/Author, you will use your normal process to save the actual files and eventually commit the changes to your repository.

Uploading a Review Task Takes Too Long

When uploading a review task that contains DITA files, along with the files explicitly selected for review, the task also contains the DITA map and all the files referenced from it (directly or indirectly). For large projects, this set of files is also large and can take a long time to upload.

To improve the loading time, go to Options > Preferences > Plugins > Oxygen Content Fusion Connector and enable the Upload only resources that are directly referenced in the files to be reviewed. option.

When this option is enabled, only resources such as other topics and images that are directly referenced from the files to review are uploaded, including all the submaps that are referenced in the context DITA map. This may lead to a smaller set of files, but there are some limitations:

  • References that use the @conkeyref attribute are not uploaded.
  • References that use the <xref> element will be uploaded and reviewers can open them. However, images and other references in these files will not be uploaded.
  • If the set of files to be reviewed is large, the upload will still take a long time.
Edit online

Opening Files From the Browser in Oxygen XML Editor/Author

To quickly open the version of a file that is opened in the Content Fusion browser interface in either Oxygen XML Editor or Oxygen XML Author:
  1. Copy the URL of opened file in the browser.
  2. In Oxygen XML Editor/Author, use the Open URL action from the toolbar or the File menu.
  3. In the resulting dialog box, paste the copied URL in the URL field and click OK.
Result: The corresponding file is opened in the editor and [CF] will appear as a prefix to the file name in the editor tab label.
Note:
If the version of the Content Fusion server is below 5.0, the file will be opened in the editor in read-only mode.
Edit online

Merging Proposed Changes

Once the reviewers are done with their process, the task owner will have access to a Get Changes link when hovering over the task in the Content Fusion Tasks Manager view. Clicking this link opens a built-in Get Changes merge tool that allows you to automatically merge all the proposed changes back into Oxygen XML Editor/Author.

In most instances, you will simply click the Apply button at the bottom of the merge tool to automatically integrate all the proposed changes and when the files are opened in Oxygen XML Editor/Author, you will see the changes. If you happen to encounter a conflict, you will need to select a Merge Action from the drop-down menu for that particular file.

If you need to resolve conflicts or make some manual changes to the merge process, refer to the next section for more in-depth information on using the built-in Get Changes merge tool.

Get Changes Merge Tool

When you click the Get Changes link on a task, a built-in merge tool is displayed that allows you to automatically integrate the changes and you also have access to numerous actions to manually adjust the merge.

Figure 7. Get Changes Merge Tool

The merge tool includes the following information, features, and actions:

Number of Changes and Conflicts
The first thing you see in top-left corner of the tool is the grand total of all the changes made by others, changes made by you, and the number of conflicts.
Filter Buttons

In the top-right corner you can use the toggle buttons to filter the list of modifications:

Show all files
Use this button to show all modified and unmodified files, as well as conflicts.
Show only files with incoming and local changes
Filters the list to show all files that have been modified, including conflicts.
Show only files with incoming changes
Filters the list to only show the files that were modified by others.
Show only files with local changes
Filters the list to only show the files that were modified by you.
Show only conflicting files
Filters the list to only show files that contain conflicts.
List of Files Panel
This panel shows the list of files in the compared file sets based upon the filter button that is selected. This panel includes the following sortable columns:
  • Name - The file names.
  • Status - An icon that represents the file status. Red icons indicate some sort of conflict. Gray icons indicate modifications made by you. Blue icons indicate modifications made by others.
  • Description - A description of the file status.
  • Merge Action - This column provides a drop-down menu for each file that allows you to choose some merge actions depending upon its status. A default action is always set to automatically merge the changes made by others with your changes. If there is a conflict, the default is <Select action> and you are required to make a selection. Click this column to access the drop-down menu where you can make a selection. The same actions are available in the contextual menu.

You can click on a file to open it in the file comparison panel. The file from your file set is shown in the left panel, while the file from the file set with changes made by others is shown in the right panel. For image files, the comparison panel displays a preview of the image. For other binary files, a preview is not available and you will only see its status.

File Comparison Panels

If you click a file in the top panel, the file is opened in this file comparison section. The file from your file set is shown in the left panel and the file from the other file set is shown in the right panel. This panel includes a variety of toolbar actions, depending on whether the merge tool is in Text or Author mode. To determine whether the files are initially opened in the merge tool's Text or Author mode, it detects the Initial Edit Mode in the Document Type Association configuration and the mode the files were last opened in Oxygen XML Editor/Author.

The information and actions that are available in the file comparison section are as follows:

File Path
The first thing you see in this panel is the file path where merge actions will be applied if you make changes.
Close
Closes the file comparison panel.
Algorithm Drop-Down Menu
This drop-down menu allows you to select one of the following diff algorithms to be used for file comparisons:
  • Auto - Selects the most appropriate algorithm, based on the compared content and its size (selected by default).
  • Lines - Computes the differences at line level, meaning that it compares two files or fragments looking for identical lines of text. This algorithm is not available when the merge tool is in Author mode.
  • XML Fast - Comparison that works well on large files or fragments, but it is less precise than XML Accurate.
  • XML Accurate - Comparison that is more precise than XML Fast, at the expense of speed. It compares two XML files or fragments looking for identical XML nodes.
Diff Options
Opens a preferences page where you can configure various options.
Perform Files Differencing
Looks for differences between the two files displayed in the left and right side panels.
Synchronized scrolling
Toggles synchronized scrolling. When toggled on, a selected difference can be seen in both panels.
Ignore Whitespaces
Enables or disables the whitespace ignoring feature. Ignoring whitespace means that before performing the comparison, the application normalizes the content and trims its leading and trailing whitespaces. This option is not available when the merge tool is in Author mode.
Tags Display Mode
Allows you to select the amount of markup to be displayed in the Author visual mode. You can choose between: Full Tags with Attributes, Full Tags, Block Tags, Inline Tags, Partial Tags, or No Tags.
Copy Change from Right to Left
Copies the selected difference from the file in the right panel to the file in the left panel.
Copy All Changes from Right to Left
Copies all changes from the file in the right panel to the file in the left panel.
Next Block of Changes
Jumps to the next block of changes. This action is not available when the cursor is positioned on the last change block or when there are no changes.
Note:
A change block groups one or more consecutive lines that contain at least one change.
Previous Block of Changes
Jumps to the previous block of changes. This action is not available when the cursor is positioned on the first change block or when there are no changes.
Next Change
Jumps to the next change from the current block of changes. When the last change from the current block of changes is reached, it highlights the next block of changes. This action is not available when the cursor is positioned on the last change or when there are no changes.
Previous Change
Jumps to the previous change from the current block of changes. When the first change from the current block of changes is reached, it highlights the previous block of changes. This action is not available when the cursor is positioned on the first change or when there are no changes.
First Change
Jumps to the first change.
Left-Side File (Your changes)
Above the panel you can see the file path and the following two buttons:
Save
Saves changes made to the file.
Reload
Reloads the file.
Right-Side File (Changes made by others)
Above the panel you can see the file path and the following two buttons:
Reload
Reloads the file.
Displaying Differences in the File Comparison Panels
Colored marks on the right-side vertical stripe help you to quickly identify the locations of the differences. The differences are also highlighted in several colors in the comparison panes, depending on the type of change, and dynamic lines connect the compared fragments in the middle section between the two panes. The default colors and their shades mean the following:
  • Pink - Identifies modifications on either side.
  • Gray - Identifies an addition of a node in the left side (your outgoing changes).
  • Blue - Identifies an addition of a node in the right side (incoming changes).
  • Lighter Shade - Identifies blocks of changes that can be merged in their entirety.
  • Darker Shade - Identifies specific changes within the blocks that can be merged more precisely.
Figure 8. File Comparison Panels
Direct Editing Actions in the File Comparison Panels

In addition to selecting merge actions from the drop-down menus in the Merge Action column in the top panel, you can also edit the files directly in the left pane (your local changes). The two editors are constantly synchronized and the differences are refreshed when you save the modified document (Save button or Ctrl+S) or when you click the Perform File Differencing button.

A variety of actions are available in the contextual menu in both editing panes. The tool also includes some inline actions to help you merge, copy, or remove changes. When you select a change, the following inline action widgets are available, depending on the type of change:
Append right change to left
Copies the content of the selected change from the right side and appends it on the left side.
Copy change from right to left
Replaces the content of a change in the left side with the content of the change in the right side.
Remove change
Removes the change from the left side.

Any time you save manual changes (Save button or Ctrl+S), the selection in the Merge Action column in the top panel automatically changes to Use merged and a copy of the original file is kept so that you can revert to the original file if necessary. To discard your manual changes and revert to your original changes, select a different action in the Merge Action drop-down menu.

Text Mode
The Text button below the comparison panels allows you to switch to a Text mode that displays the files as source code.
Author Mode
The Author button below the comparison panels allows you to switch to an Author mode that displays the files in a visual mode similar to the Author editing mode in Oxygen XML Editor/Author. This visual mode is available when the compared files are detected as being XML and it includes unique features such as a Tags Display Mode drop-down button on the toolbar that allows you to select the amount of tags to display in this visual mode. This mode also presents differences that were made using the Track Changes feature (although the Track Changes feature is not available in the merge tool).
Note:
This mode is not available if the Enable file comparison in Author mode option is not selected in the Diff > Files Comparison preferences page.
Open Merged Files
If you select this option, all the files that will be modified by the merge operation will be opened in the editor after the operation is finished.
Applying Changes

When you click the Apply button, all the merge actions you have selected and the changes you have made will be processed.

If there are unresolved conflicts (conflicts where no merge action is selected in the Merge Action drop-down menu), a dialog box will be displayed that allows you to choose how to solve the conflicts. You can choose between the following:
  • Keep your changes - If you select this option and then click Apply, your local changes will be preserved for the unresolved conflicts.
  • Overwrite your changes - If you select this option and then click Apply, your local changes will be overwritten with the changes made by others, for the unresolved conflicts.
  • Cancel - You can click the Cancel button to go back to the merge tool to resolve the conflicts individually.
Canceling Changes
If you click the Cancel button at the bottom of the merge tool, any manual changes you made in the merge tool will be lost.
Edit online

Using the Review Functionality with an External CMS

In addition to its core content management capabilities, Content Fusion includes integrated review functionality. If you are working with content stored in an external CMS (Content Management System), you can also create review tasks using files from that system, provided the external CMS has a connector for Oxygen XML Editor/Author.

Note:
External CMS platforms often provide customized versions of Oxygen, so some of the methods described below may not be available or may work differently depending on your environment.

Uploading a Review Task

To create a review task using files from an external CMS, you have several options:

  • Open the file in the editor and use the Add File to Review Task action from the contextual menu.
  • For DITA resources, open the map in the DITA Maps Manager view and use the Add File to Review Task action from the contextual menu. You can also drag map entries and drop them in the New Task box.
  • If available in your customized version of Oxygen, drag resources from the Data Source Explorer view and drop them in the New Task box.
  • If you have a special view for exploring the server that contains documents on your CMS, you can also drag resources from that view and drop them in the New Task box.

Specifying the Root DITA Map

If you choose to add the files to the task from DITA Maps Manager, the root map that is specified in the DITA Maps Manager is automatically added as the Context DITA Map. Otherwise, if you work with DITA projects, you should manually add the root DITA map to the task.

Getting the Changes

To retrieve the changes made by reviewers and save them in the CMS, follow these steps:
  1. Click the Get Changes link in the task box. The merge tool is displayed.
  2. Merge the changes from the remote files with the current version of the files. The files are automatically opened in the editor as modified with all the changes applied.
  3. Save the files using the specific procedure for your CMS.
Edit online

Control File Content Before Being Sent to Content Fusion

A cf-file protocol can be used when a customizer wants to control the file content before it is sent to Content Fusion or control the content that is saved in the original files after the Get Changes action is performed. To use this feature, you must:

  1. Set the value of the com.oxygenxml.use.cffile.protocol system property to true. This will result in the Oxygen Content Fusion Connector using the cf-file protocol when requesting the file content or when trying to save the modified content back to the files.
  2. Implement an URLStreamHandlerPluginExtension API to impose the URL stream handlers for the cf-file protocol.
Edit online

Content Fusion Projects View

The Content Fusion Projects view allows you to browse and work with projects directly from Oxygen XML Editor/Author. This view provides access to project files, branches, and enables you to pull changes from and commit changes to the Content Fusion server.

To open the Content Fusion Projects view, go to Window > Show View > Content Fusion Projects. If the view is not available, make sure the Content Fusion Connector add-on is installed.

Requirements

The following are required to use the Content Fusion Projects view:
  • A Content Fusion server version 9.0 or later that supports the Projects API.
  • A user account with the Content Fusion Author role assigned.
  • At least one project created in the Content Fusion browser interface.

Projects View Interface

The Content Fusion Projects view allows you to access project files, branches, and to pull changes from and commit changes to the Content Fusion server.

Figure 9. Content Fusion Projects View

The Content Fusion Projects view contains the following components:

User Name drop-down menu

Once connected and authorized, your user name appears in the upper-right corner of the view. The drop-down menu offers the following actions:

Open Project in Content Fusion
Opens the currently selected project in your default browser.
Refresh Projects
Forces a refresh to synchronize the project list with the Content Fusion server.
Go to my account
Opens the account profile page in Content Fusion.
Connection Status
Provides information such as the server address, plugin version, and connection status. This option can be used for troubleshooting purposes.
Help
Opens the Content Fusion user guide in your default browser.
Preferences
Opens the Oxygen Content Fusion Connector preferences page where you can change the server address.
Disconnect
Signs you out of Content Fusion. To re-establish the connection, you need to click Connect and then Authorize.
Project and Branch Selection

At the top of the view, you can select a project from the Project combo box. Once a project is selected, you can choose a branch from the Branch combo box. The project tree will automatically update to show the files from the selected branch.

A Refresh button is available next to the project selection to manually refresh the project list from the server.

Project Tree

The main area displays a tree view of all files and folders in the selected project branch. You can:

  • Double-click a file to open it in the editor.
  • Right-click a file or folder to access the contextual menu.
  • Expand and collapse folders to navigate the project structure.
Pull and Commit Changes Buttons

At the bottom of the view, two buttons are available:

Pull Changes
Pulls incoming changes from the Content Fusion server to your local workspace. The button displays the number of incoming commits (if any are available).
Commit Changes
Commits your local changes to the Content Fusion server. The button displays the number of outgoing commits (if any are available).

The status of incoming and outgoing commits is automatically updated every 10 seconds while the view is active and the application window is not minimized.

Contextual Menu Actions

When you right-click on a file or folder in the project tree, a contextual menu appears with the following options:

Open in Editor
Opens the selected file in Oxygen XML Editor/Author for editing. This action is only available for files, not folders.
Open in Content Fusion
Opens the selected file in the Content Fusion browser interface. This action is only available for files, not folders.
Open Project in Content Fusion
Opens the current project in your default browser. This action appears when right-clicking on a folder.
New Folder
Creates a new folder in the selected location. A dialog box will prompt you to enter the folder name.
Refresh
Refreshes the project tree to synchronize with the Content Fusion server.

Working with Project Files

You can work with project files in several ways:

  • Opening Files: Double-click a file or use the Open in Editor action from the contextual menu to open it in Oxygen XML Editor/Author. Files opened from the Projects view are opened from the Content Fusion server, allowing you to edit them directly in Oxygen.
  • Editing Files: Once a file is opened, you can edit it just like any other file in Oxygen XML Editor/Author. Your changes are tracked locally until you commit them to the server.
  • Creating Folders: Use the New Folder action from the contextual menu to create new folders in your project structure.
  • Synchronizing Changes: Use the Pull Changes button to get the latest changes from the server, and the Commit Changes button to commit your local changes to the server.

Working with Branches

The Content Fusion Projects view allows you to switch between different branches of a project. When you select a different branch from the Branch combo box, the project tree automatically updates to show the files from that branch.

Browsing Content Fusion Projects from Open/Save Dialogs

The Content Fusion Connector add-on adds a Browse Content Fusion (or Open from Content Fusion) action to the Open URL and Save As dialog boxes in Oxygen XML Editor/Author. This allows you to browse and select files directly from your Content Fusion projects without having to manually enter URLs.

To use this feature:
  1. Open the Open URL dialog box (from File > Open URL) or the Save As dialog box (from File > Save As).
  2. Click the Browse drop-down button (or Open from button, depending on the dialog type).
  3. Select Browse Content Fusion (or Open from Content Fusion) from the menu.
  4. A dialog box will appear showing the file tree from the currently selected project in the Content Fusion Projects view. Navigate through the project structure and select the file or folder you want to open or save to.
  5. Click OK to confirm your selection. The URL will be automatically filled in the dialog box.
To use the browse functionality, you must:
  • Be connected to the Content Fusion server.
  • Have a Content Fusion server version 9.0 or later that supports the Projects API.
  • Have a user account with the Content Fusion Author role assigned.
  • Have at least one project selected in the Content Fusion Projects view

If you are not connected or do not meet the requirements, a message will be displayed indicating what is needed. The dialog box will show the file tree from the project and branch currently selected in the Content Fusion Projects view. If you change the project or branch selection in the Projects view, the browse dialog box will reflect those changes when you open it again.

The dialog box also includes a Selected Path field that displays the path of the currently selected file or folder. You can manually type or edit the path in this field if needed. The path is automatically updated when you select items in the tree.