[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

RE: [xsl] Re: Comparing nodes in XPath


Subject: RE: [xsl] Re: Comparing nodes in XPath
From: Pieter Reint Siegers Kort <pieter.siegers@xxxxxxxxxxx>
Date: Fri, 21 Jan 2005 16:51:22 -0600

Hi Antsnio,

I'd suggest you show a bit more code (xml and xslt) - for example, where is
your $conn defined? What type is it? I'd also take some time to debug the
stylesheet you have using your favorite processor IDE.

Cheers,
<prs/>

-----Original Message-----
From: Antsnio Mota [mailto:amsmota@xxxxxxxxx]
Sent: Viernes, 21 de Enero de 2005 12:48 p.m.
To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
Subject: [xsl] Re: Comparing nodes in XPath

I don't understand, it seems that none of the expressions is working ok
afterall.

@id=Conn is allways false

@id=$conn is allways true

I think i save this for monday...

On Fri, 21 Jan 2005 18:42:12 +0000, Antsnio Mota <amsmota@xxxxxxxxx> wrote:
> Why is this xpath NOT working
>
> <xsl:value-of
> select="document('connections.xml')/connections/connection[@id=Conn]"/
> >
>
>  and this IS
>
> <xsl:variable name="conn" select="Conn"/> <xsl:value-of
> select="document('connections.xml')/connections/connection[@id=$conn]"
> />
>
> I can think that the first is comparing a attribute to a node so it
> allways returns a node set(0)?
>
> And the second is comparing a attribute with a string?
>
> I also tryed using text(Conn), Conn/text() and some others, but none
> work,
>
> This is probably a basic question, maybe it's getting late for me...


Current Thread
Keywords