[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

Re: [xsl] Configuring apache 1.3.3 with modxslt, libxml2 and libxslt


Subject: Re: [xsl] Configuring apache 1.3.3 with modxslt, libxml2 and libxslt
From: prasannap@xxxxxx
Date: Tue, 18 Jan 2005 11:29:18 -0800

Thanks, Daniel Bibbens.
It worked.

Now, after successfully installing modxslt, when I tried to load the module into apache 

LoadModule mxslt_module       libexec/mod_xslt.so
AddModule modxslt.c

and when I started apache, I get the following error (which I got earlier while compiling modxslt):

Cannot load /home/ppadmanabhan/apache_1.3.33-dynamic2/apps/apache/libexec/mod_xslt.so into server: /usr/local/lib/libmodxslt0.so.0: undefined symbol: xmlXIncludeProcessFlags

Could you please let me know what is the problem.
TIA,
Prasanna



----- Original Message -----
From: Daniel Bibbens <dbibbens@xxxxxxxxxx>
Date: Tuesday, January 18, 2005 8:34 am
Subject: Re: [xsl] Configuring apache 1.3.3 with modxslt, libxml2 and libxslt

> prasannap@xxxxxx writes:
> 
> > Hello,
> >
> > Im trying to configure Apache 1.3.3 with modxslt.
> > I installed libxml2-2.6.16, libxslt-1.1.12 and and then tried to 
> install modxslt-2004112100.
> >
> > While trying to compile modxslt, I ran up to the following problem,
> >
> > Configuring modxslt: ./configure --with-sapi=apache1 --with-
> apxs='path-to-apxs' --with-xml2-config='path-to-xml2-config' --
> with-xslt-config='path-to-xslt-config'
> >
> > gcc -o .libs/modxslt-parse .libs/modxslt-parse.o  -
> L/usr/local/apps/xml/lib -L/usr/local/apps/lib 
> ../lib/.libs/libmodxslt0.so> ../lib/.libs/libmodxslt0.so: 
> undefined reference to `xmlXIncludeProcessFlags'
> > ../lib/.libs/libmodxslt0.so: undefined reference to 
> `xsltSetCtxtParseOptions'> ../lib/.libs/libmodxslt0.so: undefined 
> reference to `xsltCopyTextString'
> > ../lib/.libs/libmodxslt0.so: undefined reference to 
> `xmlCtxtUseOptions'>
> > I have compiled and installed both libxml2 and libxslt successfully.
> > I dont know which library to include in the library path. Could 
> you please throw some light on me.
> >
> > Thanks,
> > Prasanna
> >
> 
> You're on the right track, but your 'include' and 'lib' are messed
> up and the compiler is not finding them. You should have something
> like this in your Makefile:
> 
> PREFIX=/usr/local
> 
> INCPREFIX=$(PREFIX)/include
> LIBPREFIX=$(PREFIX)/lib
> 
> INC=-I$(INCPREFIX) -I$(INCPREFIX)/libxml2
> LIB=$(LIBPREFIX)/libxml2.so $(LIBPREFIX)/libxslt.so
> 
> This is probably a topic best sent to the Apache modules list at:
> http://modules.apache.org/
> -- 
> *------------------------------------------------------------------
> ----*
> |XOBJEX Research & Development Corp.            Daniel Bibbens, 
> Partner||Santa Monica, California                            
> http://xobjex.com/||    +------------------------------------------
> ------------------+    |	
> |     Apache modules and other open-source projects for XSL & RSS  
>    |
> *------------------------------------------------------------------
> ----*


Current Thread
Keywords
xsl