[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

RE: [xsl] xsl:copy-of problem with < and > chars by html output


Subject: RE: [xsl] xsl:copy-of problem with < and > chars by html output
From: "Dagoberto Flores" <dagof@xxxxxxxxxxxx>
Date: Tue, 11 Jan 2005 08:46:55 -0500

Hi, try it using the entitiy references:

&lt; < less than
&gt; > greater than
&amp; & ampersand
&apos; ' apostrophe
&quot; " quotation mark

Or may be you could use the <![CDATA[ YOUR_CODE ]]> to get a string output
as you write.  It is used when you need put a JavaScript function in your
output document, by example.

Dago Flores

-----Original Message-----
From: Markus Hanel [mailto:markus.hanel@xxxxxx]
Sent: January 11, 2005 2:34 AM
To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
Subject: RE: [xsl] xsl:copy-of problem with < and > chars by html output


>
>
> > From: Markus Hanel [mailto:markus.hanel@xxxxxx]
> >
> > hello,
> >
> > I am having a problem with the xsl:copy-of function by creating html
> > output. I want to fill in a complete node set with content into a
> > textarea and have
> > problems with the < and > chars.
>
> Hi Markus,
>
> Are you actually wanting literal XML _markup_ to be displayed in the
> textarea control?
>
> -ml-
If it is possible with xsl, the complete content: node set and text should
be displayed. The problem is how to handle with the chars < and >.

markus
>

--
-----------------------------
Mag. Markus Hanel
Rottweilerstra_e 29
A-6460 IMST
0650 - 7847941
markus.hanel@xxxxxx
----------------------------


Current Thread
Keywords