[oXygen-user] XSLTHL with DocBook on oXygen 14 (built-in support throws error)

Sorin Ristache sorin at sync.ro
Tue Jul 3 05:18:21 CDT 2012


In version 14.0 the built-in frameworks like Docbook, DITA, etc use the 
editor variable ${frameworkDir} in the values of some XSLT parameters 
but version 13.2 used ${frameworks}/docbook, ${frameworks}/dita, etc. 
For example the Docbook transformations have a parameter


The problem is that ${frameworkDir} is not good for all parameters 
because it is expanded to a filepath. In this case the ${framework} 
variable should be used for expanding it to a URL:


Please edit the Docbook scenarios from Options -> Preferences -> 
Document Type Association -> Docbook -- Edit -- Transformations and 
change the value of the highlight.xslthl.config parameter.

We will apply this change in the next maintenance build of Oxygen 14.0.


Florent Georges wrote:
>   Hi,
>   With the latest oXygen 14.0, I tried to use XSLTHL with
> DocBook.  So I created a simple DocBook article using the
> built-in oXygen template.  I added a programlisting with a
> language="xml" attribute.  A complete example is:
>   When I run the built-in DocBook to PDF scenario, I get an
> error.  If I duplicate it and disable FOP processing (to keep
> just the XSL-FO as the output), I have something like the
> following:
>     <fo:block ...>
>        <http://xslthl.sf.net:tag xmlns:http://xslthl.sf.net="xslthl">&lt;hello&gt;</http://xslthl.sf.net:tag>World!<http://xslthl.sf.net:tag xmlns:http://xslthl.sf.net="xslthl">&lt;/hello&gt;</http://xslthl.sf.net:tag>
>     </fo:block>
>   That is, it seems like at some point, the piece of code that is
> generating (or serializing?) the above element is mixing up the
> xslthl prefix and the URI "http://xslthl.sf.net".  If you replace
> each of them by the other (prefix and URI), you get the following
> (I guess correct) element:
>     <fo:block ...>
>        <xslthl:tag xmlns:xslthl="http://xslthl.sf.net">&lt;hello&gt;</xslthl:tag>World!<xslthl:tag xmlns:xslthl="http://xslthl.sf.net">&lt;/hello&gt;</xslthl:tag>
>     </fo:block>
>   I've tried to track it a bit further down using the debugger,
> but could not find anything more, really.  Do you have any idea?
> Did I miss anything?
>   Regards,

More information about the oXygen-user mailing list