[oXygen-user] XSLTHL with DocBook on oXygen 14 (built-in support throws error)

Florent Georges lists at fgeorges.org
Mon Jul 2 09:46:46 CDT 2012


  With the latest oXygen 14.0, I tried to use XSLTHL with
DocBook.  So I created a simple DocBook article using the
built-in oXygen template.  I added a programlisting with a
language="xml" attribute.  A complete example is:

  When I run the built-in DocBook to PDF scenario, I get an
error.  If I duplicate it and disable FOP processing (to keep
just the XSL-FO as the output), I have something like the

    <fo:block ...>
       <http://xslthl.sf.net:tag xmlns:http://xslthl.sf.net="xslthl">&lt;hello&gt;</http://xslthl.sf.net:tag>World!<http://xslthl.sf.net:tag xmlns:http://xslthl.sf.net="xslthl">&lt;/hello&gt;</http://xslthl.sf.net:tag>

  That is, it seems like at some point, the piece of code that is
generating (or serializing?) the above element is mixing up the
xslthl prefix and the URI "http://xslthl.sf.net".  If you replace
each of them by the other (prefix and URI), you get the following
(I guess correct) element:

    <fo:block ...>
       <xslthl:tag xmlns:xslthl="http://xslthl.sf.net">&lt;hello&gt;</xslthl:tag>World!<xslthl:tag xmlns:xslthl="http://xslthl.sf.net">&lt;/hello&gt;</xslthl:tag>

  I've tried to track it a bit further down using the debugger,
but could not find anything more, really.  Do you have any idea?
Did I miss anything?



Florent Georges

More information about the oXygen-user mailing list