[oXygen-user] 10.1 takes a step backward?

Syd Bauman
Fri Mar 6 22:58:15 CST 2009

First, if this has already been mentioned on the list or via your bug
reporting system and I've missed it, my apologies.

Second, let me state for the record that despite the following
complaint, I am a big fan of oXygen. There is no other commercial
proprietary software that I outright recommend people buy, except
for Mac OS X. (And even that only for those not up to dealing with

I have severe tendonitis to my wrists (bilaterally). One consequence
of this is that I really try to avoid using the pointer (in my case
a trackball or trackpad, as I cannot use a mouse at all), and try to
type most commands. For those menu items that do not have keyboard
shortcuts, I often use the operating system's "access the menu"
shortcut (ctl-F2 on a Mac, alt-underlined_letter on my GNU/Linux

I have not tried oXygen 10.1 on a GNU/Linux yet (I use oXygen there
very rarely), but I use oXygen almost daily on Mac OS X 10.5 with "In
windows and dialogs, press Tab to move the keyboard focus between" set
to "All controls" in the Keyboard & Mouse pane of System Preferences.

One action I perform reasonably frequently is Associate Schema,
although it's usually via the New XML Document rather than explicitly
associating a schema to an already existing XML document. Either way,
in previous versions of oXygen I would perform this entirely from the
keyboard. Something like:
* cmd-N                       > new dialog
* XML Document selected       > defaulted from last time
* enter                       > gets "Create an XML document" dialog
* Use DTD or Schema checked   > defaulted from last time
* tab                         > moves me to set of schema language tabs
* R-cursor R-cursor           > selects Relax NG
* tab tab                     > selected "browse local" folder icon [X]
* space                       > gets open dialog box
* [navigate to schema]        > use normal Mac OS X keystrokes
* return                      > syntax button automatically set from extension
* return                      > done!

But note the [X]. Here, in oXygen 10.0 (and earlier versions, but I
don't know how far back), there was no visual indication that I had
selected the button with the normal folder icon that means "Browse
for local file" (the leftmost of the 2 or 3 folder icons for browsing
local, remote, or archive), but it worked. Now, in 10.1, tabbing in
this dialog box skips right over the browse icons! I've tried all
sorts of key combinations (ctl-tab, opt-tab, cursor keys, cursor keys
w/ modifiers, etc.), but cannot seem to select that button without
using the pointer.

Snif! Sob! PLEASE give me a way to create a new document with a
schema associated without using the pointer!

P.S. It turns out I can still create new files in oXygen without
     using the pointer so long as I don't associate a schema. Some
     time ago (9.2? 10.0? I forget), the "New" dialog box became a
     combined "New" and "New from template" box. As far as I could
     tell, there was no way to select one or the other of those tabs
     from the keyboard, though. However, I recently discovered that
     pressing ctl-tab 3 times or shift-ctl-tab once selected the tabs
     bar, so that either L or R cursor keys would select the other
     tab. Not exactly convenient, but I'm trying to teach my fingers
     to do that.

More information about the oXygen-user mailing list