[oXygen-user] xsl:result-document and Saxon-SA gives "Cannot write to a URI that has already been read"

Sorin Ristache
Thu Jun 25 05:13:13 CDT 2009

I get the same error as you *only* when the output file is set to be the 
same as the input XML file but:

- I get the error with both Saxon B and Saxon SA,

- it is an error reported correctly (not the bug that I mentioned) and

- I get the same behavior in Oxygen as from a command line where I run 
Saxon B/SA.

You get the error only with Saxon SA so there is something different in 
your transformation scenario. Please specify more details about your 
scenario: the URL of the input XML, the URL of the input XSL, the value 
of the field Save As, the full error message (including the URI that 
cannot be written).

Thank you,

Andrew Welch wrote:
> Running this stylesheet, using Saxon SA in oXygen (10.2 or
> 10.3 :) gives: "Cannot write to a URI that has already been read: ..."
> <xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
>      xmlns:xs="http://www.w3.org/2001/XMLSchema"
>      exclude-result-prefixes="xs"
>      version="2.0">
> <xsl:template match="/">
>    <xsl:result-document>
>        <foo/>
>    </xsl:result-document>
> </xsl:template>
> </xsl:stylesheet>
> cheeeers

More information about the oXygen-user mailing list