History | Edit

Oxygen XML Editor includes some useful features to help you navigate XML documents in Text mode.

Using the Keyboard

Oxygen XML Editor allows you to quickly navigate through a document using the Ctrl + CloseBracket (Command + CloseBracket on OS X) key to go to the next XML node and Ctrl + OpenBracket (Command + OpenBracket on OS X) to go to the previous one.

To navigate one word forward or backwards, use Ctrl + RightArrow (Command + RightArrow on OS X), and Ctrl + LeftArrow (Command + LeftArrow on OS X), respectively. To position the cursor at the beginning or end of the document you can use Ctrl + Home (Command + Home on OS X), and Ctrl + End (Command + End on OS X), respectively.

Navigation Buttons

Oxygen XML Editor includes some actions that help you to quickly navigate to a particular modification. These navigation buttons are available in the main toolbar and the actions can also be accessed from the Find menu. The three actions include:

  • Last Modification - Moves the cursor to the last modification in any opened document.
  • Back - Moves the cursor to the previous position.
  • Forward - Moves the cursor to the next position. Available after you use the Back button at least once.

Navigating with the Outline View

Oxygen XML Editor includes a very useful Outline view that displays a hierarchical tag overview of the currently edited XML Document.

You can use this view to quickly navigate through the current document by selecting nodes in the outline tree. It is synchronized with the editor area, so when you make a selection in the Outline view, the corresponding nodes are highlighted in the editor area.

Figure: Outline View Navigation in Text Mode

Using the Breadcrumb to Navigate

A breadcrumb on the top stripe indicates the path from the document root element to the current element. It can also be used as a helpful tool to navigate to specific elements throughout the structure of the document.

Figure: Breadcrumb in Text Mode

The last element listed in the breadcrumb is the element at the current cursor position. The current element is also highlighted by a thin light blue bar for easy identification. Clicking an element from the breadcrumb selects the entire element and navigates to it in the editor area.

Navigating with the Go To Dialog Box

In Text mode, you can navigate precisely to a location in the document you are editing by using the Go to dialog box. To open this dialog box, go to Find > Go to (Ctrl+L (Command+L on OS X)).

Figure: Go to Dialog Box

The dialog box includes the following fields for specifying a specific navigation location:

  • Line - Destination line in the current document.
  • Column - Destination column in the current document.
  • Offset - Destination offset relative to the beginning of document.

Navigating with Bookmarks

By using bookmarks, you can mark positions in an edited document so that you can return to it later. This is especially helpful for navigating through large documents or while editing multiple documents. You can place up to nine distinct bookmarks in any document. Shortcut keys are available to place the bookmarks or to return to any of the marked positions. You can configure these shortcut keys in the Options > Menu Shortcut Keys menu.

Figure: Editor Bookmarks

A bookmark can be inserted in Text mode by doing one of the following:
  • Click in the vertical stripe on the left side of the editor (to the left of the line number).
  • Select the Create Bookmark (F9) action from the Edit > Bookmarks menu.

A bookmark can be removed by right-clicking its icon on the vertical stripe and selecting Remove or Remove all (Ctrl+F7 (Command+F7 on OS X)).

You can navigate the bookmarks by using one of the actions available on the Edit > Bookmarks > Go to menu or by using the shortcut keys that are listed in that menu.