Oxygen XML Perspective

The Oxygen XML perspective is the most commonly used perspective and it is the default perspective when you start Oxygen XML Developer plugin for the first time. It is the perspective that you will use to edit the content of your XML documents.

To switch the focus to this perspective, select Oxygen XML from the Window > Open Perspective menu.

The layout of this perspective is composed of the following components:
Menus
Provides menu driven access to all the features and functions available in Oxygen XML Developer plugin. Most of the menus are common for all types of documents. However, Oxygen XML Developer plugin also includes some context-sensitive and framework-specific menus that are only available for a specific context or type of document.
Toolbars
Provides easy access to common and frequently used functions. Each icon is a button that acts as a shortcut to a related function.
Editor Pane
The main editing pane where you spend most of your time reading, editing, applying markup, and validating your documents.
Views
Oxygen XML Developer plugin includes a large variety of dockable views to assist you with editing, viewing, searching, validating, transforming, and organizing your documents. The most commonly used views are displayed by default and you can choose to display others by selecting them from the Window > Show View menu.

When two or more views are displayed, the application provides divider bars. Divider bars can be dragged to a new position increasing the space occupied by one panel while decreasing it for the other.

As the majority of the work process centers around the Editor area, other views can be hidden using the toggle controls located on the top corner of the view ().

Some of the most helpful views in the Oxygen XML perspective include the following:

  • Navigator view - Enables the definition of projects and logical management of the documents they contain.
  • Outline view - It provides an XML tag overview and offers a variety of functions, such as modifications follow-up, document structure change, document tag selection, and elements filtering.
  • Results view - Displays the messages generated as a result of user actions such as validations, transformation scenarios, spell checking in multiple files, search operations, and others. Each message is a link to the location related to the event that triggered the message.
  • Attributes view - Presents all possible attributes of the current element and allows you to edit attribute values. You can also use this view to insert attributes in Text mode.
  • Model view - Presents the current edited element structure model and additional documentation as defined in the schema.
  • Elements view - Presents a list of all defined elements that you can insert at the current cursor position according to the document's schema.
  • Entities view - Displays a list with all entities declared in the current document as well as built-in ones.
  • Transformation Scenarios view - Displays a list with all currently configured transformation scenarios.
  • XPath/XQuery Builder view - Displays the results from running an XPath expression.
  • Text view - Displays the text output that is produced in XSLT transformations.
  • Browser view - Displays HTML output from XSLT transformations.
  • Problems view - A general Eclipse view that displays system-generated errors, warnings, or information associated with a resource.
  • Console view - Status information generated by the Schema detection, validation, and transformation threads.
  • WSDL SOAP Analyzer view - Provides a tool that helps you test if the messages defined in a Web Service Descriptor (WSDL) are accepted by a Web Services server.