[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

Re: [xsl] xpath 3.0/3.1 in schema 1.1


Subject: Re: [xsl] xpath 3.0/3.1 in schema 1.1
From: "Michael Kay mike@xxxxxxxxxxxx" <xsl-list-service@xxxxxxxxxxxxxxxxxxxxxx>
Date: Tue, 1 Mar 2016 18:27:11 -0000

The answer is technically, no. A processor allowing you to use XPath 3.0
expressions would not be a conformant XSD 1.1 processor.

However, we need to remember that conformance is not an absolute requirement
that takes precedence over everything else. If some vendor sees a market
demand for a validation engine that offers XSD 1.1 with XPath 3.1 additions
there is nothing to stop them producing a product that meets that demand. The
fact that it's not a conformant XSD 1.1 processor wouldn't stop it being a
useful product.

Michael Kay
Saxonica

> On 1 Mar 2016, at 17:01, Leo Studer leo.studer@xxxxxxxxxxx
<xsl-list-service@xxxxxxxxxxxxxxxxxxxxxx> wrote:
>
> hello friends
>
> I am wondering whether I can use xPath 3. in a schema 1.1.
> I know it is a kind of off topicb& Do I still get an answer?
>
> Cheers
> Leo


Current Thread
Keywords