[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

[xsl] Specifying XSD version


Subject: [xsl] Specifying XSD version
From: "Lizzi, Vincent" <Vincent.Lizzi@xxxxxxxxxxxxxxxxxxxx>
Date: Fri, 25 Apr 2014 21:26:40 +0000

This touches on something I've wondered about. Why must XSD version be a
configuration option instead of having a schema declare for itself which
version of XSD should be used? Shouldn't this decision be made by the schema
author and not by users of the schema?

For example, in XSLT the attribute <xsl:stylesheet version="2.0" is an
effective way to declare that the stylesheet expects the processor use XSLT
2.0. It seems as though it would be very useful to have the schema element
declare that the schema expects the processor to use XSD 1.1. The obvious way
might be this:

<xs:schema vc:minVersion="1.1" xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:vc="http://www.w3.org/2007/XMLSchema-versioning">

Does this method actually work to specify that a parser that supports both 1.0
and 1.1 should use 1.1?

Apologies for this being an off-topic post.

Vincent


-----Original Message-----
From: Dimitre Novatchev [mailto:dnovatchev@xxxxxxxxx]
Sent: Thursday, April 24, 2014 11:22 PM
To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
Subject: Re: [xsl] How to construct an instance of xs:dateTimeStamp ?

On Thu, Apr 24, 2014 at 1:08 AM, Michael Kay <mike@xxxxxxxxxxxx> wrote:
> It's supported in Saxon if XSD 1.1 is enabled (typically by
> -xsdversion:1.1 on the command line)

Thank you, Michael and Liam,

Does someone know how to specify options for Saxon when executed from within
Oxygen?

Cheers,
Dimitre


Current Thread
Keywords