[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

RE: [xsl] Node-sets using


Subject: RE: [xsl] Node-sets using <xsl:with-param>
From: "Michael Kay" <mhk@xxxxxxxxx>
Date: Thu, 22 Jan 2004 12:48:31 -0000

Can't tell what's wrong from this fragment, you'll have to show us more
of the code. And tell us which version you're using.

Michael Kay

> -----Original Message-----
> From: owner-xsl-list@xxxxxxxxxxxxxxxxxxxxxx 
> [mailto:owner-xsl-list@xxxxxxxxxxxxxxxxxxxxxx] On Behalf Of 
> Mir Farooq Ali
> Sent: 22 January 2004 05:27
> To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
> Subject: [xsl] Node-sets using <xsl:with-param>
> 
> 
> 
> I'm getting an error when trying to pass the current node into a 
> template using <xsl:with-param name="current" select="current()"/> or 
> <xsl:with-param name="current" select="."/>
> 
> The place where I'm trying to access it
> <xsl:apply-templates mode="structure1" select="$current"/>  
> is where I'm 
> getting an error message using Saxon indicating that the select 
> attribute is expecting node and what it's getting is xs:string.
> 
> What am I doing wrong here?
> 
> -Farooq.
> -- 
> Mir Farooq Ali
> 
> Computer Science, Virginia Tech,
> Email: miali@xxxxxxxxx
> Web: http://purl.org/net/farooq
> Office: 525 McBryde Hall
> Tel: (540) 231-1927 (Office)
> --------------------------------------------
> (c) 2004 Mir Farooq Ali  All rights reserved
> --------------------------------------------
> 
> 
> 
>  XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list
> 


 XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list



Current Thread