[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

Re: [xsl] Re: encoding <-> omit-xml-declaration


Subject: Re: [xsl] Re: encoding <-> omit-xml-declaration
From: "Maia Zaharieva" <m.zaharieva@xxxxxxx>
Date: Sun, 18 Jan 2004 22:40:25 +0100

----- Original Message ----- 
| > the background: i am actually writing xml-to-php
| > transformation (with multiple documents and a php-template as
| > input). because of the php section in the html code i had to
| > choose between - 1) simulating xml output and manipulating
| > the encoding or 2) getting html output and manipulating the
| > processing instructions.
|
| I do quite a bit of this type of thing with PHP and not quite sure where
| the problem would be,
| perhaps a representative example of your xml and xslt ( to php ) might
| result in a pratical answer.
|
| Gl, jim fuller

thanks for the offer jum! maybe i have done some error in reasoning, but
what i was thinking about was -  php script is always starting with <? and
ends with ?>... if i simply do copy of the processing instruction i am
loosing the question mark at the end when its the html output. thats why i
have changed to xml output (with omit-xml-declaration) and everything worked
perfect till the moment i noticed some of the elements may contain ansii
entities. hence the try to change the encoding.
anyway, now i am back to the html output and force the "?>" at the end of
the php script and all my problems arre solved

/maia



 XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list



Current Thread
Keywords