[XSL-LIST Mailing List Archive Home] [By Thread] [By Date]

RE: [xsl] Replace Apostrophe Template -- very brief example...not working


Subject: RE: [xsl] Replace Apostrophe Template -- very brief example...not working
From: "Kathy Burke" <Kathy_Burke@xxxxxxxxx>
Date: Fri, 10 Oct 2003 15:39:45 -0400

UGH...I had forgotten the with-param!  Thanks...works great.  Learned
something new.

I really appreciate the responses.

Kathy

-----Original Message-----
From: Passin, Tom [mailto:tpassin@xxxxxxxxxxxx]
Sent: Friday, October 10, 2003 3:21 PM
To: xsl-list@xxxxxxxxxxxxxxxxxxxxxx
Subject: RE: [xsl] Replace Apostrophe Template -- very brief
example...not working


[ Kathy Burke]

> I did TRY calling it, but must not have done it correctly. 

Guess not, since you did not have an xsl:call-template instruction in
the stylesheet you posted.  If you do not invoke a template with its
match expression, and you do not call it by name, there is no other way
to apply it.

> Were would I call
> it from, Tom? I would like it to apply to all output content.
> 

As an example, for just the para element -

<xsl:template match="para">
   <p><xsl:call-template name='escape-apos'>
      <xsl:with-param name='string' select='.'/>
      </xsl:call-template></p>
</xsl:template>

In general, anywhere you would otherwise insert the string value of an
element, you would call the template instead.

Cheers,

Tom P

 XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list



 XSL-List info and archive:  http://www.mulberrytech.com/xsl/xsl-list



Current Thread